source: projects/specs/trunk/o/openhpi/openhpi-vl.spec @ 1318

Revision 1318, 10.6 KB checked in by daisuke, 14 years ago (diff)

openhpi: new package, 2.14.1

Line 
1Summary: Hardware Platform Interface library and tools
2Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
3Name: openhpi
4Version: 2.14.1
5Release: 1%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://www.openhpi.org
9Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10Source1: %{name}.initd
11Source2: %{name}.sysconfig
12# https://sourceforge.net/tracker/?func=detail&aid=2932689&group_id=71730&atid=532251
13Patch0: openhpi-2.14.1-fumi-type.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
16BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
17BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
18Requires(post): chkconfig
19Requires(preun): chkconfig
20Requires(preun): initscripts
21
22%description
23OpenHPI is an open source project created with the intent of providing an
24implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
25provides an abstracted interface to managing computer hardware, typically for
26chassis and rack based servers. HPI includes resource modeling; access to and
27control over sensor, control, watchdog, and inventory data associated with
28resources; abstracted System Event Log interfaces; hardware events and alerts;
29and a managed hot swap interface.
30
31OpenHPI provides a modular mechanism for adding new hardware and device support
32easily. Many plug-ins exist in the OpenHPI source tree to provide access to
33various types of hardware. This includes, but is not limited to, IPMI based
34servers, Blade Center, and machines which export data via sysfs.
35
36
37%package libs
38Group: System Environment/Libraries
39Summary: The system libraries for the OpenHPI project
40Summary(ja): OpenHPI のシステムライブラリ
41Obsoletes: %{name} < 2.10.2-1
42
43%description libs
44The system libraries for the OpenHPI project.
45
46
47%package devel
48Group: Development/Libraries
49Summary: The development environment for the OpenHPI project
50Summary(ja): OpenHPIの開発環境
51Requires: %{name}-libs = %{version}-%{release}
52Requires: glib2-devel, pkgconfig
53
54%description devel
55The development libraries and header files for the OpenHPI project.
56
57
58%prep
59%setup -q
60%patch0 -p1 -b .fumi-type
61
62# fix permissions
63chmod a-x plugins/simulator/*.[ch]
64chmod a-x clients/*.[ch]
65
66
67%build
68export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
69%configure --disable-static
70
71# Don't use rpath!
72sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
73sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
74
75make %{?_smp_mflags}
76
77
78%install
79mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
80mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
81mkdir -p $RPM_BUILD_ROOT%{_initddir}
82mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
83make install DESTDIR=$RPM_BUILD_ROOT
84
85rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
86install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
87install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
88
89rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
90rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
91
92# fix perms for generated docs
93chmod 0644 docs/hld/openhpi-manual/*.html
94
95
96%check
97make check
98
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103
104%post
105/sbin/chkconfig --add openhpid
106
107%preun
108if [ $1 = 0 ] ; then
109    /sbin/service openhpid stop >/dev/null 2>&1
110    /sbin/chkconfig --del openhpid
111fi
112
113%postun
114if [ "$1" -ge "1" ] ; then
115    /sbin/service openhpid condrestart >/dev/null 2>&1
116fi
117
118%post libs -p /sbin/ldconfig
119
120%postun libs -p /sbin/ldconfig
121
122
123%files
124%defattr(-,root,root,-)
125%doc COPYING README README.daemon docs/hld/openhpi-manual openhpi.conf.example
126%dir %{_sysconfdir}/%{name}
127%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
128%config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
129%{_initddir}/openhpid
130%config(noreplace) %{_sysconfdir}/sysconfig/openhpid
131%attr(1777,root,root) %{_var}/lib/%{name}
132%{_bindir}/*
133%{_sbindir}/*
134%{_libdir}/%{name}
135%{_mandir}/man1/*
136%{_mandir}/man7/*
137%{_mandir}/man8/*
138
139%files libs
140%defattr(-,root,root,-)
141%{_libdir}/*.so.*
142
143%files devel
144%defattr(-,root,root,-)
145%doc COPYING
146%{_libdir}/*.so
147%{_includedir}/%{name}
148%{_libdir}/pkgconfig/*.pc
149
150
151%changelog
152* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
153- initial build for Vine Linux
154
155* Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
156- update initscript (#521648, #521830)
157
158* Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
159- added fix for inconsistent SaHpi.h
160
161* Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
162- updated to bug fix release 2.14.1
163
164* Fri Oct  9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
165- rebuilt with net-snmp 5.5
166
167* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
168- rebuilt with new openssl
169
170* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
174- add BR: libuuid-devel
175
176* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
177- use upstream default config
178- libtoolize/autoreconf is not needed
179
180* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
181- update to 2.14.0
182
183* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
184- fix ppc/ppc64 builds
185
186* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
187- update to 2.13.3
188
189* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
190- rebuild with new openssl
191
192* Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
193- shorten Summary
194
195* Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
196- update to 2.13.1
197
198* Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
199- rebuild for new libtool
200
201* Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
202- update to 2.12.0
203
204* Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
205- update to 2.11.3
206
207* Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
208- enable the sysfs plugin
209- add missing R: for -devel subpackage
210
211* Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
212- update to 2.10.2
213- spec file and patch cleanup
214
215* Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
216- Removed incorrect patch for IBM BC snmp_bc plugin
217- Fixed GCC 4.3 rebuild problems
218
219* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
220- Autorebuild for GCC 4.3
221
222* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
223- Updated to openhpi-2.10.1
224- Bump release and rebuild due to new openssl
225
226* Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
227- Bump release and rebuild because of PPC issues
228- Fix rebuild problems due to new glibc open macro
229
230* Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
231- Fix for hpipower segfaulting when using -b option out of range (#247279)
232
233* Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
234- Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
235
236* Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
237- Fixed missing e2fsprogs-devel and openssl-devel build requires
238
239* Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
240- Update to openhpi-2.8.1
241
242* Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
243- Fixed some silly bugs in the specfile
244
245* Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
246- Bump and rebuild.
247
248* Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
249- Update to openhpi-2.8.0
250
251* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
252- Rebuilt due to new net-snmp-5.4
253- Small specfile updates
254
255* Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
256- Fixed file conflicts for openhpi-switcher (#205226)
257
258* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
259- rebuild
260
261* Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
262- Had to disable sysfs support due to new libsysfs and incompatible API.
263- Added missing ncurses-devel buildrequires
264
265* Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
266- Rebuilt with final memset patch
267- Added missing pkgconfig buildprereq (#191935)
268
269* Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
270- rebuilt for new libnetsnmp and net-snmp-config changes
271
272* Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
273- Fixed buggy use of memset throughout the code
274- Made the package build and install properly
275
276* Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
277- Added missing glib2-devel build prereq (#191935)
278- Update to latest stable version openhpi-2.4.1
279
280* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
281- bump again for double-long bug on ppc(64)
282
283* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
284- rebuilt for new gcc4.1 snapshot and glibc changes
285
286* Mon Jan  9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
287- Don't use -Werror, it doesn't build with that on ppc64 currently.
288
289* Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
290- Fix to not use stict-aliasing.
291
292* Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
293- Rebuilt against new libnetsnmp
294
295* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
296- rebuilt
297
298* Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
299- Update to stable openhpi-2.2.1
300
301* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
302- Rebuilt to link against latest openssl lib.
303
304* Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
305- Added the openhpi config file
306- Added missing /var/lib/openhpi dir with proper rights
307- Added a few missing BuildPreReqs
308
309* Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
310- Rebuild against new net-snmp libs
311
312* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
313- Moved the pkgconfig files to the devel package (#152507)
314- Update to openhpi-2.0.3
315- Had to manually disable ipmi support for now until openhpi builds correctly
316  against it again
317- Dropped net-snmp-config patch, not needed anymore
318
319* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
320- Fixed gcc4 rebuild problems
321
322* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
323- bump release and rebuild with gcc 4
324
325* Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
326- Rebuilt for new rpm-4.4
327
328* Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
329- Fixed overflow in plugins/sysfs/sysfs2hpi.c
330- Fixed rebuild problem with latest net-snmp
331- Removed is_simulator patch, not needed anymore
332
333* Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
334- update to 1.9.2
335
336* Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
337- Added proper BuildRequires
338- Drop ia64 for first build, something fishy with the compiler and warning.
339
340* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
341- Initial version
342- Disable dummy plugin, doesn't compile
343- Fix missing () in snmp_bc_session.c
Note: See TracBrowser for help on using the repository browser.