source: projects/specs/trunk/o/openhpi/openhpi-vl.spec @ 10768

Revision 10768, 10.7 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary: Hardware Platform Interface library and tools
2Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
3Name: openhpi
4Version: 3.0.0
5Release: 2%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://www.openhpi.org
9Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10Source1: %{name}.initd
11Source2: %{name}.sysconfig
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
14BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
15BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
16Requires(post): chkconfig
17Requires(preun): chkconfig
18Requires(preun): initscripts
19
20%description
21OpenHPI is an open source project created with the intent of providing an
22implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
23provides an abstracted interface to managing computer hardware, typically for
24chassis and rack based servers. HPI includes resource modeling; access to and
25control over sensor, control, watchdog, and inventory data associated with
26resources; abstracted System Event Log interfaces; hardware events and alerts;
27and a managed hot swap interface.
28
29OpenHPI provides a modular mechanism for adding new hardware and device support
30easily. Many plug-ins exist in the OpenHPI source tree to provide access to
31various types of hardware. This includes, but is not limited to, IPMI based
32servers, Blade Center, and machines which export data via sysfs.
33#'
34
35%package libs
36Group: System Environment/Libraries
37Summary: The system libraries for the OpenHPI project
38Summary(ja): OpenHPI のシステムライブラリ
39Obsoletes: %{name} < 2.10.2-1
40
41%description libs
42The system libraries for the OpenHPI project.
43
44
45%package devel
46Group: Development/Libraries
47Summary: The development environment for the OpenHPI project
48Summary(ja): OpenHPIの開発環境
49Requires: %{name}-libs = %{version}-%{release}
50Requires: glib2-devel, pkgconfig
51
52%description devel
53The development libraries and header files for the OpenHPI project.
54
55
56%prep
57%setup -q
58
59# fix permissions
60chmod a-x plugins/simulator/*.[ch]
61chmod a-x clients/*.[ch]
62
63
64%build
65export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
66%configure --disable-static
67
68# Don't use rpath!
69sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
70sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
71
72make %{?_smp_mflags}
73
74
75%install
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
78mkdir -p $RPM_BUILD_ROOT%{_initddir}
79mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
83install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
84install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
85
86rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
87rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
88
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93
94%post
95/sbin/chkconfig --add openhpid
96
97%preun
98if [ $1 = 0 ] ; then
99    /sbin/service openhpid stop >/dev/null 2>&1
100    /sbin/chkconfig --del openhpid
101fi
102
103%postun
104if [ "$1" -ge "1" ] ; then
105    /sbin/service openhpid condrestart >/dev/null 2>&1
106fi
107
108%post libs -p /sbin/ldconfig
109
110%postun libs -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root,-)
115%doc COPYING README README.daemon openhpi.conf.example
116%dir %{_sysconfdir}/%{name}
117%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
118%config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
119%config(noreplace) %{_sysconfdir}/openhpi/simulation.data
120%{_initddir}/openhpid
121%config(noreplace) %{_sysconfdir}/sysconfig/openhpid
122%attr(1777,root,root) %{_var}/lib/%{name}
123%{_bindir}/*
124%{_sbindir}/*
125%{_libdir}/%{name}
126%{_mandir}/man1/*
127%{_mandir}/man7/*
128%{_mandir}/man8/*
129
130%files libs
131%defattr(-,root,root,-)
132%{_libdir}/*.so.*
133
134%files devel
135%defattr(-,root,root,-)
136%doc COPYING
137%{_libdir}/*.so
138%{_includedir}/%{name}
139%{_libdir}/pkgconfig/*.pc
140
141
142%changelog
143* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 3.0.0-2
144- rebuild with gcc-5.4.0
145
146* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
147- new upstream release
148- remove Patch0
149
150* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-2
151- rebuild with openssl-1.0.0d
152
153* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
154- initial build for Vine Linux
155
156* Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
157- update initscript (#521648, #521830)
158
159* Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
160- added fix for inconsistent SaHpi.h
161
162* Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
163- updated to bug fix release 2.14.1
164
165* Fri Oct  9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
166- rebuilt with net-snmp 5.5
167
168* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
169- rebuilt with new openssl
170
171* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
173
174* Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
175- add BR: libuuid-devel
176
177* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
178- use upstream default config
179- libtoolize/autoreconf is not needed
180
181* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
182- update to 2.14.0
183
184* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
185- fix ppc/ppc64 builds
186
187* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
188- update to 2.13.3
189
190* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
191- rebuild with new openssl
192
193* Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
194- shorten Summary
195
196* Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
197- update to 2.13.1
198
199* Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
200- rebuild for new libtool
201
202* Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
203- update to 2.12.0
204
205* Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
206- update to 2.11.3
207
208* Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
209- enable the sysfs plugin
210- add missing R: for -devel subpackage
211
212* Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
213- update to 2.10.2
214- spec file and patch cleanup
215
216* Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
217- Removed incorrect patch for IBM BC snmp_bc plugin
218- Fixed GCC 4.3 rebuild problems
219
220* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
221- Autorebuild for GCC 4.3
222
223* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
224- Updated to openhpi-2.10.1
225- Bump release and rebuild due to new openssl
226
227* Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
228- Bump release and rebuild because of PPC issues
229- Fix rebuild problems due to new glibc open macro
230
231* Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
232- Fix for hpipower segfaulting when using -b option out of range (#247279)
233
234* Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
235- Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
236
237* Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
238- Fixed missing e2fsprogs-devel and openssl-devel build requires
239
240* Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
241- Update to openhpi-2.8.1
242
243* Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
244- Fixed some silly bugs in the specfile
245
246* Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
247- Bump and rebuild.
248
249* Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
250- Update to openhpi-2.8.0
251
252* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
253- Rebuilt due to new net-snmp-5.4
254- Small specfile updates
255
256* Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
257- Fixed file conflicts for openhpi-switcher (#205226)
258
259* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
260- rebuild
261
262* Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
263- Had to disable sysfs support due to new libsysfs and incompatible API.
264- Added missing ncurses-devel buildrequires
265
266* Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
267- Rebuilt with final memset patch
268- Added missing pkgconfig buildprereq (#191935)
269
270* Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
271- rebuilt for new libnetsnmp and net-snmp-config changes
272
273* Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
274- Fixed buggy use of memset throughout the code
275- Made the package build and install properly
276
277* Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
278- Added missing glib2-devel build prereq (#191935)
279- Update to latest stable version openhpi-2.4.1
280
281* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
282- bump again for double-long bug on ppc(64)
283
284* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
285- rebuilt for new gcc4.1 snapshot and glibc changes
286
287* Mon Jan  9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
288- Don't use -Werror, it doesn't build with that on ppc64 currently.
289
290* Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
291- Fix to not use stict-aliasing.
292
293* Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
294- Rebuilt against new libnetsnmp
295
296* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
297- rebuilt
298
299* Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
300- Update to stable openhpi-2.2.1
301
302* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
303- Rebuilt to link against latest openssl lib.
304
305* Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
306- Added the openhpi config file
307- Added missing /var/lib/openhpi dir with proper rights
308- Added a few missing BuildPreReqs
309
310* Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
311- Rebuild against new net-snmp libs
312
313* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
314- Moved the pkgconfig files to the devel package (#152507)
315- Update to openhpi-2.0.3
316- Had to manually disable ipmi support for now until openhpi builds correctly
317  against it again
318- Dropped net-snmp-config patch, not needed anymore
319
320* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
321- Fixed gcc4 rebuild problems
322
323* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
324- bump release and rebuild with gcc 4
325
326* Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
327- Rebuilt for new rpm-4.4
328
329* Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
330- Fixed overflow in plugins/sysfs/sysfs2hpi.c
331- Fixed rebuild problem with latest net-snmp
332- Removed is_simulator patch, not needed anymore
333
334* Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
335- update to 1.9.2
336
337* Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
338- Added proper BuildRequires
339- Drop ia64 for first build, something fishy with the compiler and warning.
340
341* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
342- Initial version
343- Disable dummy plugin, doesn't compile
344- Fix missing () in snmp_bc_session.c
Note: See TracBrowser for help on using the repository browser.