source: projects/specs/trunk/o/openh323/openh323-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

RevLine 
[521]1%define pkgver v1_18_0
2
3Summary: Library for H323 spec.
4Summary(ja): H323 ¥é¥¤¥Ö¥é¥ê
5Name: openh323
6Version: 1.18.0
7Release: 0vl5
8URL: http://openh323.sourceforge.net/
9Source0: %{name}-%{pkgver}-src-tar.gz
10
11Patch1: openh323-1.13.2-libname.patch
12Patch2: openh323-1.12.0-asnparser.patch
13Patch3: openh323-1.12.0-nosamples.patch
14Patch4: openh323-1.12.0-prefix.patch
15Patch5: openh323-1.12.0-PIC.patch
16Patch6: openh323-1.13.2-ptlib-config.patch
17License: MPL
18Group: System Environment/Libraries
19Requires: pwlib >= 1.6.3
20Requires: speex
21BuildRequires: pwlib-devel >= 1.6.3
22BuildRequires: XOrg-devel speex-devel openldap-devel
23BuildRequires: gcc-c++
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26%description
27Implementation of the ITU H.323 teleconferencing protocol.
28
29%package devel
30Summary: Development package for openh323
31Group: Development/Libraries
32Requires: openh323 = %{version}-%{release}
33Requires: pwlib-devel >= 1.6.3
34
35%description devel
36Static libraries and header files for development with openh323.
37
38%prep
39%setup -q -n openh323_%{pkgver}
40#patch1 -p1 -b .libname
41#patch2 -p1 -b .ansparser
42#patch3 -p1 -b .nosamples
43#patch4 -p1 -b .prefix
44#patch5 -p1 -b .PIC
45#patch6 -p1 -b .ptlib-config
46
47%build
48#autoconf
49CFLAGS="$CFLAGS -fPIC"; export CFLAGS
50CCFLAGS="$CCFLAGS -fPIC"; export CCFLAGS
51%configure
52#configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-localspeex=no
53
54%ifarch ia64
55# Disable optimization due to g++ segfault (#116369)
56make optshared OPTCCFLAGS="$RPM_OPT_FLAGS" || true
57g++  -DP_USE_PRAGMA -fno-rtti -D_REENTRANT -Wall  -DP_64BIT -fPIC -DPTRACING -Iinclude -DHAS_OSS -DPTRACING -I/usr/share/pwlib//include -DNDEBUG  -x c++ -c src/h245_1.cxx -o lib/obj_linux_ia64_r/h245_1.o
58g++  -DP_USE_PRAGMA -fno-rtti -D_REENTRANT -Wall  -DP_64BIT -fPIC -DPTRACING -Iinclude -DHAS_OSS -DPTRACING -I/usr/share/pwlib//include -DNDEBUG  -x c++ -c src/h245_2.cxx -o lib/obj_linux_ia64_r/h245_2.o
59g++  -DP_USE_PRAGMA -fno-rtti -D_REENTRANT -Wall  -DP_64BIT -fPIC -DPTRACING -Iinclude -DHAS_OSS -DPTRACING -I/usr/share/pwlib//include -DNDEBUG  -x c++ -c src/h245_3.cxx -o lib/obj_linux_ia64_r/h245_3.o
60make optshared OPTCCFLAGS="$RPM_OPT_FLAGS"
61%else
62make optshared OPTCCFLAGS="$RPM_OPT_FLAGS"
63%endif
64
65#Remove this for now, seems to break stuff: %{?_smp_mflags}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70#makeinstall
71make DESTDIR=$RPM_BUILD_ROOT install
72mv $RPM_BUILD_ROOT%{_libdir}/libopenh323.@SHAREDLIBEXT@ $RPM_BUILD_ROOT%{_libdir}/libopenh323.so
73
74#chmod 755 $RPM_BUILD_ROOT%{_libdir}/libh323_linux_x86_r.so.*
75chmod 755 $RPM_BUILD_ROOT%{_libdir}/libh323_linux_*_r.so.*
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81
82%postun -p /sbin/ldconfig
83
84%files
85%defattr(-,root,root)
86%doc ReadMe.txt mpl-1.0.htm
87%{_libdir}/*.so.*
88%{_libdir}/pwlib/codecs/audio/*.so
89
90%files devel
91%defattr(-,root,root)
92%{_libdir}/*.so
93%{_includedir}/*
94%{_datadir}/openh323
95
96%changelog
97* Sun Oct  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.18.0-0vl5
98- rebuilt with pwlib-1.10.10
99
100* Tue May 23 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.18.0-0vl4
101- rebuilt with new toolchain and pwlib-1.10.7
102
103* Sat Mar 17 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.18.0-0vl3
104- Hey Mr.Somebody, don't assume that there is only x86 target on Vine :(
105  libh323_linux_x86_r.so.* -> libh323_linux_*_r.so.* in %%install section
106
107* Fri Feb 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.0-0vl2
108- rebuilt with pwlib-1.10.4
109
110* Sat Feb  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.0-0vl1
111- new upstream release
112- updated URL
113
114* Wed Mar  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.2-1vl1
115- initial build for Vine Linux
116
117* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.13.2-1
118- update to 1.13.2 final
119
120* Mon Feb 23 2004 Alexander Larsson <alexl@redhat.com> 1.13.2-0.pre1.1
121- better ia64 workaround
122
123* Fri Feb 20 2004 Alexander Larsson <alexl@redhat.com> 1.13.2-0.pre1.0
124- update to 1.13.2pre1
125
126* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
127- rebuilt
128
129* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 1.12.0-2
130- Rebuild with right P_64BIT define on ppc64
131
132* Tue Jul  1 2003 Alexander Larsson <alexl@redhat.com> 1.12.0-1
133- Update to 1.12.0
134- Redo all patches for new makefiles
135
136* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
137- rebuilt
138
139* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
140- rebuilt
141
142* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.11.2-3
143- Update the PIC patch for the speex codec.
144
145* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.11.2-2
146- Actually mkdir datadir/openh323
147
148* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.11.2-1
149- Update to 1.11.2
150- Removed extra speex source as it's now built in
151- Update build patches
152- Moved openh323u.mak to datadir/openh323
153
154* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.9.10-5
155- Rebuild
156
157* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 1.9.10-4
158- Add speex header files
159
160* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 1.9.10-3
161- Fix unpackages files
162
163* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 1.9.10-2
164- Fix speex linking
165- Remove custom strndup that was colliding with system one
166
167* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 1.9.10-1
168- Update to 1.9.10
169- Include speex tarball
170
171* Wed Oct  9 2002 Alex Larsson <alexl@redhat.com> 1.9.3-5
172- Change to use _libdir etc. throughout specfile
173- Build with -fPIC
174
175* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
176- rebuilt with gcc-3.2 (we hope)
177
178* Tue Aug  6 2002 Alexander Larsson <alexl@redhat.com> 1.9.3-3
179- Removed excludearch ia64
180
181* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.9.3-2
182- rebuild using gcc-3.2-0.1
183
184* Thu Jul 11 2002 Alexander Larsson <alexl@redhat.com> 1.9.3-1
185- Update to 1.9.3
186
187* Tue Jul  2 2002 Alexander Larsson <alexl@redhat.com> 1.9.1-1
188- Updated to 1.9.1, some changes borrowed from
189- the rpms by Carl-Johan Kjellander
190
191* Fri Mar 22 2002 Alex Larsson <alexl@redhat.com>
192- Add versioned dependency on main package in devel package
193- Fix to long line in desctiption
194
195* Fri Mar  8 2002 Alex Larsson <alexl@redhat.com>
196- Bump version to rebuild against new pwlib
197
198* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
199- Update to 1.8.0
200
201* Wed Sep 28 2001 Alex Larsson <alexl@redhat.com> 1.6.1-3
202- made the devel package require the binary package
203
204* Mon Aug 13 2001 Alexander Larsson <alexl@redhat.com> 1.6.0-2
205- Changed libname to liboh323
206
207* Mon Aug 13 2001 Alexander Larsson <alexl@redhat.com> 1.6.0-1
208- Upgraded to 1.6.0
209
210* Thu Jul  5 2001 Elliot Lee <sopwith@redhat.com> 1.5.5-3
211- Remove PLATFORM_TYPE from libname
212
213* Wed Jul  4 2001 Elliot Lee <sopwith@redhat.com> 1.5.5-2
214- More fixups. The patch is not named IHATEYOU because of a loving relationship...
215
216* Wed Jul  4 2001 Jonathan Blandford <jrb@redhat.com>
217- Initial build.
Note: See TracBrowser for help on using the repository browser.