source: projects/specs/trunk/o/opencv/opencv-vl.spec @ 12469

Revision 12469, 22.9 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%bcond_with test
2
3%bcond_without gstreamer
4#global indice   a
5
6Name:           opencv
7Version:        4.4.0
8Release:        1%{?_dist_release}
9Summary:        Collection of algorithms for computer vision
10Summary(ja):    コンピュータビジョン用のアルゴリズム集
11Group:          graphics
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15# This is normal three clause BSD.
16License:        BSD
17URL:            https://opencv.org
18
19# RUN opencv-clean.sh TO PREPARE TARBALLS
20#
21# Need to remove copyrighted lena.jpg images from tarball (rhbz#1295173)
22# and SIFT/SURF from tarball, due to legal concerns.
23#
24#Source0:        https://github.com/opencv/opencv/archive/%{version}.tar.gz
25Source0:        %{name}-clean-%{version}.tar.gz
26Source1:        %{name}_contrib-clean-%{version}.tar.gz
27Source2:        %{name}_extra-clean-%{version}.tar.gz
28Source3:        face_landmark_model.dat.xz
29# from https://github.com/opencv/ade/archive/v0.1.1f.zip
30Source4:        b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
31Source5:        xorg.conf
32Source100:      opencv-clean.sh
33
34Patch0:         opencv-4.1.0-install_3rdparty_licenses.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  libtool
38BuildRequires:  cmake >= 2.6.3
39BuildRequires:  chrpath
40
41BuildRequires:  eigen3-devel
42BuildRequires:  libtheora-devel
43BuildRequires:  libvorbis-devel
44#BuildRequires:  libraw1394-devel
45#BuildRequires:  libdc1394-devel
46BuildRequires:  jasper-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libjpeg-devel
49BuildRequires:  libtiff-devel
50BuildRequires:  libv4l-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  mesa-libGL-devel
53BuildRequires:  OpenEXR-devel
54#ifarch %{ix86} x86_64
55#BuildRequires:  openni-devel
56#BuildRequires:  openni-primesense
57#endif
58BuildRequires:  tbb-devel
59
60BuildRequires:  qt5-qtbase-devel
61BuildRequires:  freetype2-devel
62BuildRequires:  harfbuzz-devel
63
64BuildRequires:  zlib-devel pkgconfig
65BuildRequires:  python3-devel
66BuildRequires:  python3-setuptools
67BuildRequires:  python3-rpm-macros
68BuildRequires:  python3-numpy
69BuildRequires:  swig >= 1.3.24
70#BuildRequires:  python-sphinx
71#BuildRequires:  ffmpeg-devel >= 0.4.9
72
73BuildRequires:  gstreamer1-devel
74BuildRequires:  gstreamer1-plugins-base-devel
75#BuildRequires:  xine-lib-devel
76#BuildRequires:  opencl-headers
77BuildRequires:  vulkan-headers
78BuildRequires:  mesa-dri-drivers
79BuildRequires:  xorg-x11-drv-dummy
80
81Requires:       opencv-core = %{version}-%{release}
82
83
84%description
85OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
86C functions and a few C++ classes that implement some popular Image Processing
87and Computer Vision algorithms.
88
89
90%package        core
91Summary:        OpenCV core libraries
92Summary(ja):    OpenCV コアライブラリ
93Group:          graphics
94Obsoletes:      %{name}-python < %{version}-%{release}
95
96%description    core
97This package contains the OpenCV C/C++ core libraries.
98
99%package        devel
100Summary:        Development files for using the OpenCV library
101Summary(ja):    OpenCV ライブラリを使用するための開発用ファイル
102Group:          programming
103Requires:       opencv = %{version}-%{release}
104
105%description    devel
106This package contains the OpenCV C/C++ library and header files, as well as
107documentation. It should be installed if you want to develop programs that
108will use the OpenCV library. You should consider installing opencv-devel-docs
109package.
110
111%package -n     python3-opencv
112Summary:        Python bindings for apps which use OpenCV
113Summary(ja):    OpenCV を使用するアプリケーション用の Python バインディング
114Group:          programming
115Requires:       opencv = %{version}-%{release}
116Requires:       python3-numpy
117
118%description -n python3-opencv
119This package contains Python bindings for the OpenCV library.
120
121%package        contrib
122Summary:        OpenCV contributed functionality
123Summary(ja):    寄付された OpenCV の追加機能
124Group:          graphics
125
126%description    contrib
127This package is intended for development of so-called "extra" modules, contribut
128ed
129functionality. New modules quite often do not have stable API, and they are not
130well-tested. Thus, they shouldn't be released as a part of official OpenCV
131distribution, since the library maintains binary compatibility, and tries
132to provide decent performance and stability.
133
134
135%debug_package
136
137
138%prep
139%setup -q -a1 -a2
140# we don't use pre-built contribs except quirc
141pushd 3rdparty
142shopt -s extglob
143rm -r !(openexr|openvx|quirc)
144shopt -u extglob
145popd &>/dev/null
146
147%patch0 -p1 -b .install_3rdparty_licenses
148
149# Install ADE, needed for opencv_gapi
150mkdir -p .cache/ade
151install -pm 0644 %{SOURCE4} .cache/ade/
152
153
154%build
155# enabled by default if libraries are presents at build time:
156# GTK, GSTREAMER, 1394, V4L
157# non available on Fedora: FFMPEG, XINE
158mkdir -p build
159pushd build
160
161rm -rf  share/opencv4/testdata/cv/face
162mkdir -p share/opencv4/testdata/cv/face
163install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
164pushd share/opencv4/testdata/cv/face
165  xz -d face_landmark_model.dat.xz
166popd
167
168# disabling IPP because it is closed source library from intel
169
170%cmake CMAKE_VERBOSE=1 \
171        -DWITH_IPP=OFF \
172        -DWITH_ITT=OFF \
173        -DWITH_QT=ON \
174        -DWITH_OPENGL=ON \
175        -DOpenGL_GL_PREFERENCE=GLVND \
176        -DWITH_GDAL=ON \
177        -DWITH_OPENEXR=ON \
178        -DWITH_UNICAP=ON \
179        -DCMAKE_SKIP_RPATH=ON \
180        -DWITH_CAROTENE=OFF \
181%ifnarch x86_64 ia64
182        -DENABLE_SSE=0 \
183        -DENABLE_SSE2=0 \
184%else
185        -DCPU_BASELINE=SSE2 \
186%endif
187        -DENABLE_PRECOMPILED_HEADERS=OFF \
188        -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
189        -DBUILD_opencv_java=OFF \
190        %{?with_tbb: -DWITH_TBB=ON } \
191        %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
192        -DWITH_FFMPEG=OFF \
193        %{?with_openni: -DWITH_OPENNI=ON } \
194        -DWITH_XINE=OFF \
195        -DBUILD_DOCS=OFF \
196        -DBUILD_EXAMPLES=OFF \
197        -DBUILD_opencv_python2=OFF \
198        -DINSTALL_C_EXAMPLES=OFF \
199        -DINSTALL_PYTHON_EXAMPLES=OFF \
200        -DPYTHON3_EXECUTABLE=%{__python3} \
201        -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
202        -DENABLE_PYLINT=ON \
203        -DBUILD_PROTOBUF=OFF \
204        -DPROTOBUF_UPDATE_FILES=ON \
205        -DWITH_OPENCL=OFF \
206        -DOPENCV_SKIP_PYTHON_LOADER=ON \
207        -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
208        -DWITH_LIBV4L=ON \
209        -DWITH_OPENMP=ON \
210        -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
211        -DOPENCV_GENERATE_PKGCONFIG=ON \
212        -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
213        %{?with_gdcm: -DWITH_GDCM=ON } \
214        %{?with_libmfx: -DWITH_MFX=ON } \
215        %{?with_clp: -DWITH_CLP=ON } \
216        %{?with_va: -DWITH_VA=ON } \
217        -DWITH_VTK=OFF \
218        -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
219        -DWITH_VULKAN=ON -DVULKAN_INCLUDE_DIRS=%{_includedir}/vulkan \
220        ..
221 
222make VERBOSE=1 %{?_smp_mflags}
223
224popd
225
226
227%install
228rm -rf %{buildroot}
229%make_install -C build
230find %{buildroot} -name '*.la' -delete
231rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
232
233
234%if %{with test}
235%check
236# Check fails since we don't support most video
237# read/write capability and we don't provide a display
238# ARGS=-V increases output verbosity
239pushd build
240    cp %SOURCE5 .
241    if [ -x /usr/libexec/Xorg ]; then
242       Xorg=/usr/libexec/Xorg
243    else
244       Xorg=/usr/libexec/Xorg.bin
245    fi
246    $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
247    export DISPLAY=:99
248    LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
249popd
250%endif
251
252
253%clean
254rm -rf %{buildroot}
255
256
257%post core -p /sbin/ldconfig
258%postun core -p /sbin/ldconfig
259
260%post -p /sbin/ldconfig
261%postun -p /sbin/ldconfig
262
263%post contrib -p /sbin/ldconfig
264%postun contrib -p /sbin/ldconfig
265
266
267%files
268%doc README.md
269%{_bindir}/opencv_*
270%dir %{_datadir}/opencv4
271%{_datadir}/opencv4/haarcascades
272%{_datadir}/opencv4/lbpcascades
273%{_datadir}/opencv4/valgrind*
274%{_datadir}/opencv4/quality
275
276%files core
277%license LICENSE
278%{_datadir}/licenses/opencv4/
279%{_libdir}/libopencv_alphamat.so.*
280%{_libdir}/libopencv_core.so.*
281%{_libdir}/libopencv_cvv.so.*
282%{_libdir}/libopencv_features2d.so.*
283%{_libdir}/libopencv_flann.so.*
284%{_libdir}/libopencv_gapi.so.*
285%{_libdir}/libopencv_hfs.so.*
286%{_libdir}/libopencv_highgui.so.*
287%{_libdir}/libopencv_imgcodecs.so.*
288%{_libdir}/libopencv_imgproc.so.*
289%{_libdir}/libopencv_intensity_transform.so.*
290%{_libdir}/libopencv_ml.so.*
291%{_libdir}/libopencv_objdetect.so.*
292%{_libdir}/libopencv_photo.so.*
293%{_libdir}/libopencv_rapid.so.*
294%{_libdir}/libopencv_shape.so.*
295%{_libdir}/libopencv_stitching.so.*
296%{_libdir}/libopencv_superres.so.*
297%{_libdir}/libopencv_video.so.*
298%{_libdir}/libopencv_videoio.so.*
299%{_libdir}/libopencv_videostab.so.*
300
301%files devel
302%dir %{_includedir}/opencv4
303%{_includedir}/opencv4/opencv2
304%{_libdir}/lib*.so
305%{_libdir}/pkgconfig/opencv*.pc
306%{_libdir}/cmake/OpenCV/*.cmake
307
308%files -n python3-opencv
309%exclude %{_bindir}/setup_vars_opencv4.sh
310%{python3_sitearch}/cv2.cpython-3*.so
311
312
313%files contrib
314%{_libdir}/libopencv_aruco.so.*
315%{_libdir}/libopencv_bgsegm.so.*
316%{_libdir}/libopencv_bioinspired.so.*
317%{_libdir}/libopencv_calib3d.so.*
318%{_libdir}/libopencv_ccalib.so.*
319%{_libdir}/libopencv_datasets.so.*
320# needs protobuf
321#{_libdir}/libopencv_dnn.so.*
322#{_libdir}/libopencv_dnn_objdetect.so.*
323#{_libdir}/libopencv_dnn_superres.so.*
324%{_libdir}/libopencv_dpm.so.*
325%{_libdir}/libopencv_face.so.*
326%{_libdir}/libopencv_freetype.so.*
327%{_libdir}/libopencv_fuzzy.so.*
328# needs hdf5
329#{_libdir}/libopencv_hdf.so.*
330%{_libdir}/libopencv_img_hash.so.*
331%{_libdir}/libopencv_line_descriptor.so.*
332%{_libdir}/libopencv_optflow.so.*
333%{_libdir}/libopencv_phase_unwrapping.so.*
334%{_libdir}/libopencv_plot.so.*
335%{_libdir}/libopencv_reg.so.*
336%{_libdir}/libopencv_rgbd.so.*
337%{_libdir}/libopencv_quality.so.*
338%{_libdir}/libopencv_saliency.so.*
339%{_libdir}/libopencv_stereo.so.*
340%{_libdir}/libopencv_structured_light.so.*
341%{_libdir}/libopencv_surface_matching.so.*
342# needs tesseract
343#{_libdir}/libopencv_text.so.*
344%{_libdir}/libopencv_tracking.so.*
345%{_libdir}/libopencv_ximgproc.so.*
346%{_libdir}/libopencv_xobjdetect.so.*
347%{_libdir}/libopencv_xphoto.so.*
348
349
350%changelog
351* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4.0-1
352- new upstream release.
353- enabled vulkan compute backend
354
355* Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
356- new upstream release.
357
358* Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
359- use eigen2 on Vine Linux 6.x
360- disable tbb/v4l on Vine Linux 6.x
361
362* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
363- rebuild with gcc-5.4.0
364
365* Wed Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
366- built with tbb
367- moved main package to System Environment/Libraries Group
368
369* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
370- Initial build for Vine Linux
371
372* Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
373- rebuild (openexr)
374
375* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
376- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
377
378* Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
379- backport support for GStreamer 1 (#1123078)
380
381* Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
382- Update to 2.4.9
383
384* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
385- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
386
387* Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
388- revert pkgcmake2 patch (#1070428)
389
390* Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
391- Fix opencv_ocl isn't part of -core
392
393* Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
394- Enable OpenCL support.
395- SPEC small cleanup.
396
397* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
398- rebuild (openexr)
399
400* Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
401- OpenCV cmake configuration broken (#1031312)
402
403* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
404- Update to 2.4.7
405
406* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
407- rebuild (openexr)
408
409* Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
410- Update to 2.4.6.1
411
412* Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
413- Update to 2.4.5-clean
414- Spec file clean-up
415- Split core libraries into a sub-package
416
417* Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
418- change project URL.
419
420* Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
421- make clean source without SIFT/SURF
422
423* Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
424- Update to 2.4.4a
425- Fix ttb-devel architecture conditionals
426
427* Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
428- rebuild (OpenEXR)
429
430* Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
431- Update to 2.4.4 beta
432- Drop python-imaging also from requires
433- Drop merged patch for additionals codecs
434- Disable the java binding for now (untested)
435
436* Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
437- Do not build with 1394 libs in rhel
438
439* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
440- rebuild due to "jpeg8-ABI" feature drop
441
442* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
443- Add more FourCC for gstreamer - rhbz#812628
444- Allow to use python-pillow - rhbz#895767
445
446* Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
447- Switch Build Type to ReleaseWithDebInfo to avoid -03
448
449* Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
450- Disable SSE3 and allow --with sse3 build conditional.
451- Disable gpu module as we don't build cuda
452- Update to 2.4.3
453
454* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
455- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
456
457* Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
458- Update to 2.4.2
459
460* Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
461- Fixed cmake script for generating opencv.pc file
462- Fixed OpenCVConfig script file
463
464* Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
465- Update to 2.4.1
466- Rework dependencies - rhbz#828087
467  Re-enable using --with tbb,opennpi,eigen2,eigen3
468
469* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
470- Rebuilt for c++ ABI breakage
471
472* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
473- Update gcc46 patch for ARM FTBFS
474
475* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
476- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
477
478* Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
479- Rebuild for new libpng
480
481* Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
482- Rebuilt for tbb silent ABI change
483
484* Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
485- Update to 2.3.1a
486
487* Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
488- openni is exclusive for x86/x86_64
489
490* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
491- Update to 2.3.1
492- Add BR openni-devel python-sphinx
493- Remove deprecated cmake options
494- Add --with cuda conditional (wip)
495- Disable make test (unavailable)
496
497* Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
498- Backport fixes from branch 2.2 to date
499
500* Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
501- Re-enable v4l on f15
502- Remove unused cmake options
503
504* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
505- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
506
507* Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
508- Fix with gcc46
509- Disable V4L as V4L1 is disabled for Fedora 15
510
511* Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
512- Update to 2.2.0
513- Disable -msse and -msse2 on x86_32
514
515* Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
516- -devel: include OpenCVConfig.cmake (#627359)
517
518* Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
519- TBB is available only on x86/x86_64 and ia64
520
521* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
522- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
523
524* Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
525- Move samples from main to -devel
526- Fix spurious permission
527- Add BR tbb-devel
528- Fix CFLAGS
529
530* Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
531- Update to 2.1.0
532- Update libdir patch
533
534* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
535- Fix nonstandard executable permissions
536
537* Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
538- apply the previously added patch
539
540* Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
541- re-enable testing on CMake build system
542- fix memory corruption in the gaussian random number generator
543
544* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
545- replaced BR unicap-devel by libucil-devel (unicap split)
546
547* Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
548- use cmake build system
549- applications renamed to opencv_xxx instead of opencv-xxx
550- add devel-docs subpackage #546605
551- add OpenCVConfig.cmake
552- enable openmp build
553- enable old SWIG based python wrappers
554- opencv package is a good boy and use global instead of define
555
556* Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
557- Set CXXFLAXS without -match=i386 for i386 architecture #565074
558
559* Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
560- Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
561
562* Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
563- Fixed spec file issues detected by rpmlint
564
565* Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
566- Fix autotools scripts (missing LBP features) - #544167
567
568* Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
569- Updated to 2.0.0
570- Removed upstream-ed patches
571- Ugly hack (added cvconfig.h)
572- Disable %%check on ppc64
573
574* Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
575- fix build on s390x where we don't have libraw1394 and devel
576
577* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
578- Fix typo I introduced that prevented build on i386/i586
579
580* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
581- Added 1394 libs and unicap support
582
583* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
584- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
585
586* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
587- Build with gstreamer support - #491223
588- Backport gcc43 fix from trunk
589
590* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
591- Fix FTBFS #511705
592
593* Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
594- Update to 1.1pre1
595- Disable CXXFLAGS hardcoded optimization
596- Add BR: python-imaging, numpy
597- Disable make check failure for now
598
599* Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
600- Fix for gcc44
601- Enable BR jasper-devel
602- Disable ldconfig run on python modules (uneeded)
603- Prevent timestamp change on install
604
605* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
606- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
607
608* Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
609- fix URL field
610
611* Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
612- Adopt latest python spec rules.
613- Rebuild for Python 2.6 once again.
614
615* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
616- Rebuild for Python 2.6
617
618* Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
619- fix license tag
620
621* Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
622- Adjust library order in opencv.pc.in (BZ 445937).
623
624* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
625- Autorebuild for GCC 4.3
626
627* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
628- Rebuild for gcc43.
629
630* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
631- Rebuild for selinux ppc32 issue.
632
633* Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
634- Mass rebuild.
635
636* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
637- Fix %%{_datadir}/opencv/samples ownership.
638- Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
639
640* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
641- Move all of the python module to pyexecdir (BZ 233128).
642- Activate the testsuite.
643
644* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
645- Upstream update.
646
647* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
648- Remove python-abi.
649
650* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
651- rebuilt for unwind info generation, broken in gcc-4.1.1-21
652
653* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
654- Stop configure.in from hacking CXXFLAGS.
655- Activate testsuite.
656- Let *-devel require pkgconfig.
657
658* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
659- Upstream update.
660- Don't BR: autotools.
661- Install samples' Makefile as GNUmakefile.
662
663* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
664- Un'%%ghost *.pyo.
665- Separate %%{pythondir} from %%{pyexecdir}.
666
667* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
668- Rebuild for FC6.
669- BR: libtool.
670
671* Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
672- Rebuild.
673
674* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
675- Force a re-run of Autotools by calling autoreconf.
676
677* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
678- Added build dependency on Autotools.
679
680* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
681- Changed intrinsics patch so that it matches upstream.
682
683* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
684- More intrinsics patch fixing.
685
686* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
687- Don't do "make check" because it doesn't run any tests anyway.
688- Back to main intrinsics patch.
689
690* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
691- Using simple intrinsincs patch.
692
693* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
694- Still more fixing of intrinsics patch for Python bindings on x86_64.
695
696* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
697- Again fixed intrinsics patch so that Python modules build on x86_64.
698
699* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
700- Fixed intrinsics patch so that it works.
701
702* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
703- Fixed Python bindings location on x86_64.
704
705* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
706- SSE2 support on x86_64.
707
708* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
709- Rebuild
710
711* Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
712- Removed useless sample compilation makefiles/project files and replaced them
713  with one that works on Fedora Core.
714- Removed shellbang from Python modules.
715
716* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
717- Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
718
719* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
720- Initial package.
Note: See TracBrowser for help on using the repository browser.