source: projects/specs/trunk/o/opencv/opencv-vl.spec @ 10959

Revision 10959, 20.8 KB checked in by daisuke, 7 years ago (diff)

modified to build on Vine6.5

Line 
1#global indice   a
2
3Name:           opencv
4Version:        2.4.9
5Release:        8%{?_dist_release}
6Summary:        Collection of algorithms for computer vision
7Summary(ja):    コンピュータビジョン用のアルゴリズム集
8
9Group:          System Environment/Libraries
10# This is normal three clause BSD.
11License:        BSD
12URL:            http://opencv.org
13
14# Need to remove SIFT/SURF from source tarball, due to legal concerns
15# rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
16# rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
17# Removed because we don't use pre-built contribs
18# rm -rf 3rdparty
19#Source0:        http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
20Source0:        %{name}-clean-%{version}%{?indice}.tar.xz
21Source1:        opencv-samples-Makefile
22Patch0:         opencv-pkgcmake.patch
23#http://code.opencv.org/issues/2720
24Patch2:         OpenCV-2.4.4-pillow.patch
25Patch3:         opencv-2.4.9-ts_static.patch
26# fix/simplify cmake config install location (upstreamable)
27# https://bugzilla.redhat.com/1031312
28Patch4:         opencv-2.4.7-cmake_paths.patch
29
30# relevant gst1-related patches from upstream master branch
31# 0550 needed slight rebasing -- rex
32Patch10: 0550-bomb-commit-of-gstreamer-videocapture-and-videowrite.patch
33Patch11: 0552-eliminated-warnings.patch
34Patch12: 0587-Fix-build-with-gstreamer-0.10.28.patch
35Patch13: 0865-gstreamer-cleaning-up-resources.patch
36Patch14: 0871-allow-for-arbitraty-number-of-sources-and-sinks.patch
37
38BuildRoot:      %{_tmppath}/%{name}-%{version}-root
39BuildRequires:  libtool
40BuildRequires:  cmake >= 2.6.3
41BuildRequires:  chrpath
42
43%if "%{?_dist_release}" == "vl6"
44BuildRequires:  eigen2-devel
45%else
46BuildRequires:  eigen3-devel
47%endif
48BuildRequires:  gtk2-devel
49BuildRequires:  libtheora-devel
50BuildRequires:  libvorbis-devel
51BuildRequires:  libraw1394-devel
52BuildRequires:  libdc1394-devel
53BuildRequires:  jasper-devel
54BuildRequires:  libpng-devel
55BuildRequires:  libjpeg-devel
56BuildRequires:  libtiff-devel
57%if "%{?_dist_release}" != "vl6"
58BuildRequires:  libv4l-devel
59%endif
60BuildRequires:  mesa-libGL-devel
61BuildRequires:  gtkglext-devel
62BuildRequires:  OpenEXR-devel
63#ifarch %{ix86} x86_64
64#BuildRequires:  openni-devel
65#BuildRequires:  openni-primesense
66#endif
67
68%if "%{?_dist_release}" != "vl6"
69%ifarch %{ix86} x86_64 ia64 ppc ppc64
70BuildRequires:  tbb-devel
71%endif
72%endif
73
74BuildRequires:  zlib-devel pkgconfig
75BuildRequires:  python-devel
76BuildRequires:  numpy
77BuildRequires:  swig >= 1.3.24
78BuildRequires:  python-sphinx
79#BuildRequires:  ffmpeg-devel >= 0.4.9
80
81%if "%{?_dist_release}" == "vl6"
82BuildRequires:  gstreamer-devel
83BuildRequires:  gstreamer-plugins-base-devel
84%else
85BuildRequires:  gstreamer1-devel
86BuildRequires:  gstreamer1-plugins-base-devel
87%endif
88#BuildRequires:  xine-lib-devel
89#BuildRequires:  opencl-headers
90
91Requires:       opencv-core = %{version}-%{release}
92
93
94%description
95OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
96C functions and a few C++ classes that implement some popular Image Processing
97and Computer Vision algorithms.
98
99
100%package        core
101Summary:        OpenCV core libraries
102Summary(ja):    OpenCV コアライブラリ
103Group:          System Environment/Libraries
104
105%description    core
106This package contains the OpenCV C/C++ core libraries.
107
108%package        devel
109Summary:        Development files for using the OpenCV library
110Summary(ja):    OpenCV ライブラリを使用するための開発用ファイル
111Group:          Development/Libraries
112Requires:       opencv = %{version}-%{release}
113
114%description    devel
115This package contains the OpenCV C/C++ library and header files, as well as
116documentation. It should be installed if you want to develop programs that
117will use the OpenCV library. You should consider installing opencv-devel-docs
118package.
119
120%package        devel-docs
121Summary:        Development files for using the OpenCV library
122Summary(ja):    OpenCV ライブラリを使用するための開発用ドキュメント
123Group:          Documentation
124Requires:       opencv-devel = %{version}-%{release}
125BuildArch:      noarch
126
127%description    devel-docs
128This package contains the OpenCV documentation and examples programs.
129
130%package        python
131Summary:        Python bindings for apps which use OpenCV
132Summary(ja):    OpenCV 使用するアプリケーション用の Python バインディング
133Group:          Development/Libraries
134Requires:       opencv = %{version}-%{release}
135Requires:       numpy
136
137%description    python
138This package contains Python bindings for the OpenCV library.
139
140
141%prep
142%setup -q
143%patch0 -p1 -b .pkgcmake
144%patch2 -p1 -b .pillow
145%patch3 -p1 -b .ts_static
146%patch4 -p1 -b .cmake_paths
147
148# for gst1
149%patch10 -p1 -b .10
150%patch11 -p1 -b .11
151%patch12 -p1 -b .12
152%patch13 -p1 -b .13
153%patch14 -p1 -b .14
154
155# fix dos end of lines
156sed -i 's|\r||g'  samples/c/adaptiveskindetector.cpp
157
158
159%build
160# enabled by default if libraries are presents at build time:
161# GTK, GSTREAMER, UNICAP, 1394, V4L
162# non available on Fedora: FFMPEG, XINE
163mkdir -p build
164pushd build
165%cmake CMAKE_VERBOSE=1 \
166       -DPYTHON_PACKAGES_PATH=%{python_sitearch} \
167       -DCMAKE_SKIP_RPATH=ON \
168       -DENABLE_PRECOMPILED_HEADERS:BOOL=OFF \
169%ifnarch x86_64 ia64
170       -DENABLE_SSE=0 \
171       -DENABLE_SSE2=0 \
172%endif
173       -DENABLE_SSE3=0 \
174       -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
175       -DBUILD_TEST=1 \
176       -DBUILD_opencv_java=0 \
177       -DBUILD_opencv_nonfree=0 \
178       -DBUILD_opencv_gpu=0 \
179       -DWITH_FFMPEG=0 \
180       -DWITH_GSTREAMER_1_X=1 \
181       -DWITH_OPENGL=1 \
182       -DWITH_OPENMP=1 \
183%if "%{?_dist_release}" == "vl6"
184       -DWITH_V4L=0 \
185%else
186%ifarch %{ix86} x86_64 ia64
187       -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
188%endif
189%endif
190       -DWITH_XINE=0 \
191       -DINSTALL_C_EXAMPLES=1 \
192       -DINSTALL_PYTHON_EXAMPLES=1 \
193       ..
194
195
196#{?_without_gstreamer:-DWITH_GSTREAMER=0} \
197
198#%{?_with_cuda: \
199# -DCUDA_TOOLKIT_ROOT_DIR=%{?_cuda_topdir} \
200# -DCUDA_VERBOSE_BUILD=1 \
201# -DCUDA_PROPAGATE_HOST_FLAGS=0 \
202#} \
203
204 #%ifarch %{ix86} x86_64
205#%{?_with_openni: \
206# -DWITH_OPENNI=ON \
207#} \
208#%endif
209
210# -DOPENCL_INCLUDE_DIR=${_includedir}/CL \
211 
212make VERBOSE=1 %{?_smp_mflags}
213
214popd
215
216
217%install
218rm -rf %{buildroot}
219rm -rf __devel-doc
220pushd build
221make install DESTDIR=%{buildroot} INSTALL="install -p" CPPROG="cp -p"
222find %{buildroot} -name '*.la' -delete
223
224rm -f %{buildroot}%{_datadir}/OpenCV/samples/c/build_all.sh \
225      %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.dsp \
226      %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.vcproj \
227      %{buildroot}%{_datadir}/OpenCV/samples/c/facedetect.cmd
228install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/OpenCV/samples/c/GNUmakefile
229
230# remove unnecessary documentation
231rm -rf %{buildroot}%{_datadir}/OpenCV/doc
232
233popd
234
235%check
236# Check fails since we don't support most video
237# read/write capability and we don't provide a display
238# ARGS=-V increases output verbosity
239# Make test is unavailble as of 2.3.1
240%if 0
241#ifnarch ppc64
242pushd build
243    LD_LIBRARY_PATH=%{_builddir}/%{tar_name}-%{version}/lib:$LD_LIBARY_PATH make test ARGS=-V || :
244popd
245%endif
246
247%clean
248rm -rf %{buildroot}
249
250%post core -p /sbin/ldconfig
251%postun core -p /sbin/ldconfig
252
253%post -p /sbin/ldconfig
254%postun -p /sbin/ldconfig
255
256%files
257%doc LICENSE README.md
258%{_bindir}/opencv_*
259%{_libdir}/libopencv_calib3d.so.2.4*
260%{_libdir}/libopencv_contrib.so.2.4*
261%{_libdir}/libopencv_features2d.so.2.4*
262%{_libdir}/libopencv_highgui.so.2.4*
263%{_libdir}/libopencv_legacy.so.2.4*
264%{_libdir}/libopencv_objdetect.so.2.4*
265#{_libdir}/libopencv_ocl.so.2.4*
266%{_libdir}/libopencv_stitching.so.2.4*
267%{_libdir}/libopencv_superres.so.2.4*
268%{_libdir}/libopencv_ts.so.2.4*
269%{_libdir}/libopencv_videostab.so.2.4*
270%dir %{_datadir}/OpenCV
271%{_datadir}/OpenCV/haarcascades
272%{_datadir}/OpenCV/lbpcascades
273
274%files core
275%{_libdir}/libopencv_core.so.2.4*
276%{_libdir}/libopencv_flann.so.2.4*
277%{_libdir}/libopencv_imgproc.so.2.4*
278%{_libdir}/libopencv_ml.so.2.4*
279%{_libdir}/libopencv_photo.so.2.4*
280%{_libdir}/libopencv_video.so.2.4*
281
282%files devel
283%{_includedir}/opencv
284%{_includedir}/opencv2
285%{_libdir}/lib*.so
286%{_libdir}/pkgconfig/opencv.pc
287%dir %{_libdir}/OpenCV/
288%{_libdir}/OpenCV/*.cmake
289
290%files devel-docs
291%doc doc/*.{htm,png,jpg}
292%doc %{_datadir}/OpenCV/samples
293
294%files python
295%{python_sitearch}/cv.py*
296%{python_sitearch}/cv2.so
297
298%changelog
299* Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
300- use eigen2 on Vine Linux 6.x
301- disable tbb/v4l on Vine Linux 6.x
302
303* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
304- rebuild with gcc-5.4.0
305
306* Wed Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
307- built with tbb
308- moved main package to System Environment/Libraries Group
309
310* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
311- Initial build for Vine Linux
312
313* Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
314- rebuild (openexr)
315
316* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
317- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
318
319* Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
320- backport support for GStreamer 1 (#1123078)
321
322* Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
323- Update to 2.4.9
324
325* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
326- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
327
328* Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
329- revert pkgcmake2 patch (#1070428)
330
331* Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
332- Fix opencv_ocl isn't part of -core
333
334* Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
335- Enable OpenCL support.
336- SPEC small cleanup.
337
338* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
339- rebuild (openexr)
340
341* Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
342- OpenCV cmake configuration broken (#1031312)
343
344* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
345- Update to 2.4.7
346
347* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
348- rebuild (openexr)
349
350* Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
351- Update to 2.4.6.1
352
353* Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
354- Update to 2.4.5-clean
355- Spec file clean-up
356- Split core libraries into a sub-package
357
358* Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
359- change project URL.
360
361* Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
362- make clean source without SIFT/SURF
363
364* Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
365- Update to 2.4.4a
366- Fix ttb-devel architecture conditionals
367
368* Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
369- rebuild (OpenEXR)
370
371* Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
372- Update to 2.4.4 beta
373- Drop python-imaging also from requires
374- Drop merged patch for additionals codecs
375- Disable the java binding for now (untested)
376
377* Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
378- Do not build with 1394 libs in rhel
379
380* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
381- rebuild due to "jpeg8-ABI" feature drop
382
383* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
384- Add more FourCC for gstreamer - rhbz#812628
385- Allow to use python-pillow - rhbz#895767
386
387* Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
388- Switch Build Type to ReleaseWithDebInfo to avoid -03
389
390* Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
391- Disable SSE3 and allow --with sse3 build conditional.
392- Disable gpu module as we don't build cuda
393- Update to 2.4.3
394
395* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
396- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
397
398* Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
399- Update to 2.4.2
400
401* Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
402- Fixed cmake script for generating opencv.pc file
403- Fixed OpenCVConfig script file
404
405* Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
406- Update to 2.4.1
407- Rework dependencies - rhbz#828087
408  Re-enable using --with tbb,opennpi,eigen2,eigen3
409
410* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
411- Rebuilt for c++ ABI breakage
412
413* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
414- Update gcc46 patch for ARM FTBFS
415
416* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
417- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
418
419* Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
420- Rebuild for new libpng
421
422* Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
423- Rebuilt for tbb silent ABI change
424
425* Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
426- Update to 2.3.1a
427
428* Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
429- openni is exclusive for x86/x86_64
430
431* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
432- Update to 2.3.1
433- Add BR openni-devel python-sphinx
434- Remove deprecated cmake options
435- Add --with cuda conditional (wip)
436- Disable make test (unavailable)
437
438* Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
439- Backport fixes from branch 2.2 to date
440
441* Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
442- Re-enable v4l on f15
443- Remove unused cmake options
444
445* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
446- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
447
448* Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
449- Fix with gcc46
450- Disable V4L as V4L1 is disabled for Fedora 15
451
452* Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
453- Update to 2.2.0
454- Disable -msse and -msse2 on x86_32
455
456* Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
457- -devel: include OpenCVConfig.cmake (#627359)
458
459* Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
460- TBB is available only on x86/x86_64 and ia64
461
462* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
463- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
464
465* Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
466- Move samples from main to -devel
467- Fix spurious permission
468- Add BR tbb-devel
469- Fix CFLAGS
470
471* Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
472- Update to 2.1.0
473- Update libdir patch
474
475* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
476- Fix nonstandard executable permissions
477
478* Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
479- apply the previously added patch
480
481* Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
482- re-enable testing on CMake build system
483- fix memory corruption in the gaussian random number generator
484
485* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
486- replaced BR unicap-devel by libucil-devel (unicap split)
487
488* Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
489- use cmake build system
490- applications renamed to opencv_xxx instead of opencv-xxx
491- add devel-docs subpackage #546605
492- add OpenCVConfig.cmake
493- enable openmp build
494- enable old SWIG based python wrappers
495- opencv package is a good boy and use global instead of define
496
497* Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
498- Set CXXFLAXS without -match=i386 for i386 architecture #565074
499
500* Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
501- Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
502
503* Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
504- Fixed spec file issues detected by rpmlint
505
506* Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
507- Fix autotools scripts (missing LBP features) - #544167
508
509* Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
510- Updated to 2.0.0
511- Removed upstream-ed patches
512- Ugly hack (added cvconfig.h)
513- Disable %%check on ppc64
514
515* Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
516- fix build on s390x where we don't have libraw1394 and devel
517
518* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
519- Fix typo I introduced that prevented build on i386/i586
520
521* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
522- Added 1394 libs and unicap support
523
524* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
525- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
526
527* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
528- Build with gstreamer support - #491223
529- Backport gcc43 fix from trunk
530
531* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
532- Fix FTBFS #511705
533
534* Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
535- Update to 1.1pre1
536- Disable CXXFLAGS hardcoded optimization
537- Add BR: python-imaging, numpy
538- Disable make check failure for now
539
540* Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
541- Fix for gcc44
542- Enable BR jasper-devel
543- Disable ldconfig run on python modules (uneeded)
544- Prevent timestamp change on install
545
546* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
547- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
548
549* Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
550- fix URL field
551
552* Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
553- Adopt latest python spec rules.
554- Rebuild for Python 2.6 once again.
555
556* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
557- Rebuild for Python 2.6
558
559* Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
560- fix license tag
561
562* Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
563- Adjust library order in opencv.pc.in (BZ 445937).
564
565* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
566- Autorebuild for GCC 4.3
567
568* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
569- Rebuild for gcc43.
570
571* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
572- Rebuild for selinux ppc32 issue.
573
574* Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
575- Mass rebuild.
576
577* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
578- Fix %%{_datadir}/opencv/samples ownership.
579- Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
580
581* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
582- Move all of the python module to pyexecdir (BZ 233128).
583- Activate the testsuite.
584
585* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
586- Upstream update.
587
588* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
589- Remove python-abi.
590
591* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
592- rebuilt for unwind info generation, broken in gcc-4.1.1-21
593
594* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
595- Stop configure.in from hacking CXXFLAGS.
596- Activate testsuite.
597- Let *-devel require pkgconfig.
598
599* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
600- Upstream update.
601- Don't BR: autotools.
602- Install samples' Makefile as GNUmakefile.
603
604* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
605- Un'%%ghost *.pyo.
606- Separate %%{pythondir} from %%{pyexecdir}.
607
608* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
609- Rebuild for FC6.
610- BR: libtool.
611
612* Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
613- Rebuild.
614
615* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
616- Force a re-run of Autotools by calling autoreconf.
617
618* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
619- Added build dependency on Autotools.
620
621* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
622- Changed intrinsics patch so that it matches upstream.
623
624* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
625- More intrinsics patch fixing.
626
627* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
628- Don't do "make check" because it doesn't run any tests anyway.
629- Back to main intrinsics patch.
630
631* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
632- Using simple intrinsincs patch.
633
634* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
635- Still more fixing of intrinsics patch for Python bindings on x86_64.
636
637* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
638- Again fixed intrinsics patch so that Python modules build on x86_64.
639
640* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
641- Fixed intrinsics patch so that it works.
642
643* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
644- Fixed Python bindings location on x86_64.
645
646* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
647- SSE2 support on x86_64.
648
649* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
650- Rebuild
651
652* Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
653- Removed useless sample compilation makefiles/project files and replaced them
654  with one that works on Fedora Core.
655- Removed shellbang from Python modules.
656
657* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
658- Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
659
660* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
661- Initial package.
Note: See TracBrowser for help on using the repository browser.