source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 8780

Revision 8780, 13.9 KB checked in by daisuke, 10 years ago (diff)

openbox: fix file list

Line 
1Name:           openbox
2Version:        3.5.2
3Release:        2%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14#Source4:       openbox.desktop
15Source5:        terminals.menu
16
17#Patch0:         openbox-3.4.10-obxpropman.patch
18#Patch1: openbox-3.4.11.2-gnomesession.patch
19#Patch2: 07_fix_xml_load_file.patch
20#Patch3: 666676_wrong_undecorated_window_placement.patch
21#Patch4: 90_fix_link_obt.patch
22#Patch5: 675991_fix_crash_from_gtk3_apps.patch
23
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Requires:       %{name}-libs = %{version}-%{release}
28
29BuildRequires:  gettext
30BuildRequires:  glib2-devel >= 2.14.0
31BuildRequires:  desktop-file-utils
32BuildRequires:  pango-devel
33BuildRequires:  startup-notification-devel
34BuildRequires:  imlib2-devel
35BuildRequires:  librsvg2-devel
36BuildRequires:  libxml2-devel >= 2.6.0
37BuildRequires:  libSM-devel
38BuildRequires:  libXau-devel
39BuildRequires:  libXcursor-devel
40BuildRequires:  libXfixes-devel
41BuildRequires:  libXt-devel
42BuildRequires:  libXrandr-devel
43BuildRequires:  libXinerama-devel
44
45# The xdg-menu dynamic pipe menu requires the gmenu Python module
46Requires:       gnome-menus
47Requires:       pyxdg
48
49%description
50Openbox is a window manager designed explicity for standards-compliance and
51speed. It is fast, lightweight, and heavily configurable (using XML for its
52configuration data). It has many features that make it unique among window
53managers: window resistance, chainable key bindings, customizable mouse
54actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
55
56For a full list of the FreeDesktop.org standards with which it is compliant,
57please see the COMPLIANCE file in the included documentation of this package.
58For a graphical configuration editor, you'll need to install the obconf
59package. For a graphical menu editor, you'll need to install the obmenu
60package.
61
62
63%package        devel
64Summary:        Development files for %{name}
65Summary(ja):    %{name} の開発ファイル
66Group:          Development/Libraries
67Requires:       %{name}-libs = %{version}-%{release}
68Requires:       pkgconfig
69Requires:       pango-devel
70Requires:       libxml2-devel
71Requires:       glib2-devel
72
73%description    devel
74The %{name}-devel package contains libraries and header files for
75developing applications that use %{name}.
76
77
78%package        libs
79Summary:        Shared libraries for %{name}
80Summary:        %{name} の共有ライブラリ
81Group:          System Environment/Libraries
82
83%description    libs
84The %{name}-libs package contains shared libraries used by %{name}.
85
86
87%prep
88%setup -q
89#%patch1 -p1
90#%patch2 -p1
91#%patch3 -p1
92#%patch4 -p1
93#%patch5 -p1
94autoreconf
95
96%build
97%configure \
98        --disable-static
99## Fix RPATH hardcoding.
100sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
101sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
102make %{?_smp_mflags}
103
104gcc %{optflags} -o setlayout %{SOURCE1} -lX11
105
106%install
107rm -rf %{buildroot}
108make install DESTDIR=%{buildroot}
109
110mkdir -m 644 %{buildroot}%{_datadir}/%{name}
111install setlayout %{buildroot}%{_bindir}
112
113install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
114sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
115        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
116
117#desktop-file-install --vendor="" \
118#        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
119#        %{SOURCE4}
120       
121install -m644 -p %{SOURCE5} \
122        %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
123
124# 'make install' misses these two, so we install them manually
125install -m644 -D data/gnome-session/openbox-gnome.session \
126        %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome.session
127install -m644 -D data/gnome-session/openbox-gnome-fallback.session \
128        %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
129
130
131%find_lang %{name}
132rm -f %{buildroot}%{_libdir}/*.la
133rm -rf %{buildroot}%{_datadir}/doc/%{name}
134
135
136%clean
137rm -rf %{buildroot}
138
139
140%files -f %{name}.lang
141%defattr(-,root,root,-)
142%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
143%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
144%dir %{_sysconfdir}/xdg/%{name}/
145%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
146%{_bindir}/gnome-panel-control
147%{_bindir}/gdm-control
148%{_bindir}/%{name}*
149%{_bindir}/obxprop
150%{_bindir}/setlayout
151%{_datadir}/applications/*%{name}.desktop
152%{_datadir}/%{name}
153%{_datadir}/themes/*/
154%{_datadir}/pixmaps/%{name}.png
155%{_datadir}/gnome/wm-properties/
156%{_datadir}/gnome-session/sessions/openbox-gnome.session
157%{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
158%{_datadir}/xsessions/%{name}*.desktop
159%{_libexecdir}/openbox-*
160%{_mandir}/man1/*
161
162%files  libs
163%{_libdir}/libobrender.so.*
164%{_libdir}/libobt.so.*
165
166%files  devel
167%{_includedir}/%{name}/
168%{_libdir}/libobrender.so
169%{_libdir}/libobt.so
170%{_libdir}/pkgconfig/*.pc
171
172
173%post libs -p /sbin/ldconfig
174
175
176%postun libs -p /sbin/ldconfig
177
178
179%changelog
180* Fri Jul 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.5.2-2
181- fix file list (libs,devel)
182  - remove .so from -libs
183  - remove .so.* from -devel
184
185* Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.2-1
186- new upstream release
187- replaced Source2 to newer from Fedora rawhide
188- added BuildRequires: imlib2-devel, librsvg2-devel
189
190* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-4
191- added Patch3,4,5 from Debian sid
192
193* Sun Apr 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-3
194- replaced Source2 to newer from Fedora rawhide
195
196* Sat Feb 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-2
197- replaced Source2 to newer from Fedora rawhide
198- added Patch2 from Debian sid to fix load xml files
199
200* Fri Aug 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-1
201- new upstream release
202- dropt Patch0,7,10,11
203  - renumbered patches
204- added Source5 from Fedora development
205- improved Source3
206- run autoreconf in %%prep
207
208* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
209- dropt Patch1,3
210- added patch11 from Debian
211
212* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
213- rebuilt with rpm-4.8.1 for pkg-config
214- BuildRequires: libXau-devel
215
216* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
217- new upstream release
218- added Requires: pyxdg
219
220* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
221- new upstream release
222- changed URL and Source0
223- dropt Patch6
224- added BuildRequires: libXfixes-devel, libSM-devel
225- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
226
227* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
228- new upstream release
229- added Patch10 from Fedora
230- added summary(ja) in -devel and -libs
231
232* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
233- new upstream release
234- dropt Patch8
235- Patch9 from Fedora
236
237* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
238- new upstream release
239  - dropt patch2
240  - replaced and renamed Patch0 from Fedora
241
242* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
243- new upstream release
244  - dropt patch4,5
245  - added Patch8 from Fedora
246- added Requires: gnome-menus
247
248* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
249- improved Source3
250  - enabled administration menu (disabled preference menu because included)
251- added Patch6 from Mandriva
252- added Patch7 from Fedora
253- replaced Source1 from Fedora
254
255* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
256- updated Source4
257- added Patch4,5 from Debian
258
259* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
260- changed openbox-libs Group: System Environment/Libraries
261- spec in UTF-8
262
263* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
264- initial build for VineSeed
265
266* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
267- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
268
269* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
270- Restore gnome session script (#474143)
271- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
272
273* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
274- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
275- Add application desktop file to allow starting openbox in gnome-session
276  when configured in gconf
277
278* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
279- Don't use --choose-session option in gnome session script
280
281* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
282- Remove field codes from commands in xdg-menu (#452403)
283- Add support for launching applications in xterm to xdg-menu
284
285* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
286- Clean up properties after gdm in session scripts (#444135)
287- Add license to xdg-menu script
288
289* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
290- Drop numdesks patch (#444135)
291
292* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
293- Update to 3.4.7.2
294- Use gnome menus by default (Luke Macken) (#443548)
295- Force setting number of desktops (#444135)
296
297* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
298- Update to 3.4.7.1
299- Don't require /usr/share/themes
300
301* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
302- Update to 3.4.6.1
303
304* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
305- Update to 3.4.6
306
307* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
308- Update to 3.4.5
309
310* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
311- Rebuild
312
313* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
314- Update to 3.4.4
315- Update license tag
316
317* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
318- Update to 3.4.3
319- Package setlayout tool
320
321* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
322- Update to 3.4.2
323
324* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
325- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
326  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
327  Lichvar for the bug report.)
328
329* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
330- Split shared libraries into a -libs subpackage to properly handle multilib
331  setups. (This precludes the further need to %%ghost the byte-compiled
332  themeupdate scripts which was introduced in the previous release.)
333- Fix handling of the startup_notification build conditional. It will actually
334  work properly now. :)
335- Remove the hardcoded RPATH using some sed invocations from the packaging
336  guidelines.
337
338* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
339- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
340  (bug #228379).
341
342* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
343- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
344  by gnome-session in Rawhide and we should not have ownership conflicts with
345  Core packages.
346
347* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
348- Rebuild to pick up unwind info generation fixes in new GCC
349
350* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
351- Allow building with startup-notification as an rpmbuild option (though it is
352  disabled by default as recommended by upstream).
353
354* Sat Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
355- Update to new 3.3.1 from upstream
356
357* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
358- Mass FC6 rebuild
359
360* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
361- Bump release to fix sources tagging issue
362
363* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
364- Update to 3.3 final release from upstream
365- Remove the slew of versioning macros, as it's overkill for this and just adds
366  unneeded complexity to the spec.
367
368* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
369- Add missing BuildRequires: libXxf86vm-devel
370
371* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
372- Unconditionalize the BuildRequires for modular X.org, since it's branched
373  for a specific Fedora release.
374
375* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
376- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
377
378* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
379- Add %%{_datadir}/themes to Requires (#195292)
380
381* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
382- Own all created theme directories (#195292)
383- Fix previous review bug IDs in this %%changelog to point to the recreated
384  review bug (due to recent bugzilla outage)
385
386* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
387- Don't default to an executable xsession script (#195292)
388
389* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
390- Fix versioning to conform to the Extras packaging guidelines
391
392* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
393- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
394  login screen (#195292)
395
396* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
397- Unorphan, rewriting nearly all of the spec file
398- Update to upstream 3.3 RC2
399
400* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
401- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
402- Need to conflict with fluxbox (#422 / #440)
403
404* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
405- Need to own /usr/share/apps/switchdesk (#422)
406
407* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
408- More spec revisions (#422); change make and preserve timestamps
409
410* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
411- Minor spec revisions (#422); add epoch and versions to changelogs
412
413* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
414- Add switchdesk support
415- Add display manager support
416- Fix NLS build on Cambridge
417- Fedora'ize the spec
418
419* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
420- Rev to 2.3.1 release
421- Make go with GCC 3.3
422
423* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
424- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.