source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 521

Revision 521, 11.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           openbox
2Version:        3.4.11
3Release:        1%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://icculus.org/openbox
10Source0:        http://icculus.org/openbox/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15
16Patch0:         openbox-3.4.9-autostartdir.patch
17Patch1:         openbox-3.4.8-gdm.patch
18Patch3:         openbox-3.4.7.2-autostartid.patch
19Patch6:         05_fix_gnome-settings-daemon_path.patch
20Patch7:         openbox-3.4.7.2-24bit.patch
21Patch9:         openbox-3.4.10-obxpropman.patch
22Patch10:        openbox-3.4.11-Xau.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28BuildRequires:  gettext
29BuildRequires:  desktop-file-utils
30BuildRequires:  pango-devel
31BuildRequires:  startup-notification-devel
32BuildRequires:  libxml2-devel
33BuildRequires:  libXcursor-devel
34BuildRequires:  libXt-devel
35BuildRequires:  libXrandr-devel
36BuildRequires:  libXinerama-devel
37
38# The xdg-menu dynamic pipe menu requires the gmenu Python module
39Requires:       gnome-menus
40
41%description
42Openbox is a window manager designed explicity for standards-compliance and
43speed. It is fast, lightweight, and heavily configurable (using XML for its
44configuration data). It has many features that make it unique among window
45managers: window resistance, chainable key bindings, customizable mouse
46actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
47
48For a full list of the FreeDesktop.org standards with which it is compliant,
49please see the COMPLIANCE file in the included documentation of this package.
50For a graphical configuration editor, you'll need to install the obconf
51package. For a graphical menu editor, you'll need to install the obmenu
52package.
53
54
55%package        devel
56Summary:        Development files for %{name}
57Summary(ja):    %{name} の開発ファイル
58Group:          Development/Libraries
59Requires:       %{name}-libs = %{version}-%{release}
60Requires:       pkgconfig
61Requires:       pango-devel
62Requires:       libxml2-devel
63Requires:       glib2-devel
64
65%description    devel
66The %{name}-devel package contains libraries and header files for
67developing applications that use %{name}.
68
69
70%package        libs
71Summary:        Shared libraries for %{name}
72Summary:        %{name} の共有ライブラリ
73Group:          System Environment/Libraries
74
75%description    libs
76The %{name}-libs package contains shared libraries used by %{name}.
77
78
79%prep
80%setup -q
81%patch0 -p1 -b .autostartdir
82%patch1 -p1 -b .gdm
83%patch3 -p1 -b .autostartid
84%patch6
85%patch7 -p1 -b .24bit
86%patch9 -p1 -b .obxpropman
87%patch10 -p1 -b .Xau
88
89
90%build
91%configure \
92        --disable-static
93## Fix RPATH hardcoding.
94sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
95sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
96make %{?_smp_mflags}
97
98gcc %{optflags} -o setlayout %{SOURCE1} -lX11
99
100%install
101rm -rf %{buildroot}
102make install DESTDIR=%{buildroot}
103
104install setlayout %{buildroot}%{_bindir}
105install -p %{SOURCE2} %{buildroot}%{_datadir}/%{name}/xdg-menu
106sed 's|_XDGMENU_|%{_datadir}/%{name}/xdg-menu|g' < %{SOURCE3} \
107        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
108
109desktop-file-install --vendor="" \
110        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
111        %{SOURCE4}
112
113%find_lang %{name}
114rm -f %{buildroot}%{_libdir}/*.la
115rm -rf %{buildroot}%{_datadir}/doc/%{name}
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}.lang
123%defattr(-,root,root,-)
124%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
125%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
126%dir %{_sysconfdir}/xdg/%{name}/
127%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
128%{_bindir}/gnome-panel-control
129%{_bindir}/gdm-control
130%{_bindir}/%{name}*
131%{_bindir}/obxprop
132%{_bindir}/setlayout
133%{_datadir}/applications/*%{name}.desktop
134%{_datadir}/%{name}
135%{_datadir}/themes/*/
136%{_datadir}/pixmaps/%{name}.png
137%{_datadir}/gnome/wm-properties/
138%{_datadir}/xsessions/%{name}*.desktop
139%{_mandir}/man1/*
140
141%files  libs
142%{_libdir}/libobrender.so.*
143%{_libdir}/libobparser.so.*
144
145%files  devel
146%{_includedir}/%{name}/
147%{_libdir}/libobrender.so
148%{_libdir}/libobparser.so
149%{_libdir}/pkgconfig/*.pc
150
151
152%post libs -p /sbin/ldconfig
153
154
155%postun libs -p /sbin/ldconfig
156
157
158%changelog
159* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
160- new upstream release
161- added Patch10 from Fedora
162- added summary(ja) in -devel and -libs
163
164* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
165- new upstream release
166- dropt Patch8
167- Patch9 from Fedora
168
169* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
170- new upstream release
171  - dropt patch2
172  - replaced and renamed Patch0 from Fedora
173
174* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
175- new upstream release
176  - dropt patch4,5
177  - added Patch8 from Fedora
178- added Requires: gnome-menus
179
180* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
181- improved Source3
182  - enabled administration menu (disabled preference menu because included)
183- added Patch6 from Mandriva
184- added Patch7 from Fedora
185- replaced Source1 from Fedora
186
187* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
188- updated Source4
189- added Patch4,5 from Debian
190
191* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
192- changed openbox-libs Group: System Environment/Libraries
193- spec in UTF-8
194
195* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
196- initial build for VineSeed
197
198* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
200
201* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
202- Restore gnome session script (#474143)
203- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
204
205* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
206- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
207- Add application desktop file to allow starting openbox in gnome-session
208  when configured in gconf
209
210* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
211- Don't use --choose-session option in gnome session script
212
213* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
214- Remove field codes from commands in xdg-menu (#452403)
215- Add support for launching applications in xterm to xdg-menu
216
217* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
218- Clean up properties after gdm in session scripts (#444135)
219- Add license to xdg-menu script
220
221* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
222- Drop numdesks patch (#444135)
223
224* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
225- Update to 3.4.7.2
226- Use gnome menus by default (Luke Macken) (#443548)
227- Force setting number of desktops (#444135)
228
229* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
230- Update to 3.4.7.1
231- Don't require /usr/share/themes
232
233* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
234- Update to 3.4.6.1
235
236* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
237- Update to 3.4.6
238
239* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
240- Update to 3.4.5
241
242* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
243- Rebuild
244
245* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
246- Update to 3.4.4
247- Update license tag
248
249* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
250- Update to 3.4.3
251- Package setlayout tool
252
253* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
254- Update to 3.4.2
255
256* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
257- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
258  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
259  Lichvar for the bug report.)
260
261* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
262- Split shared libraries into a -libs subpackage to properly handle multilib
263  setups. (This precludes the further need to %%ghost the byte-compiled
264  themeupdate scripts which was introduced in the previous release.)
265- Fix handling of the startup_notification build conditional. It will actually
266  work properly now. :)
267- Remove the hardcoded RPATH using some sed invocations from the packaging
268  guidelines.
269
270* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
271- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
272  (bug #228379).
273
274* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
275- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
276  by gnome-session in Rawhide and we should not have ownership conflicts with
277  Core packages.
278
279* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
280- Rebuild to pick up unwind info generation fixes in new GCC
281
282* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
283- Allow building with startup-notification as an rpmbuild option (though it is
284  disabled by default as recommended by upstream).
285
286* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
287- Update to new 3.3.1 from upstream
288
289* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
290- Mass FC6 rebuild
291
292* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
293- Bump release to fix sources tagging issue
294
295* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
296- Update to 3.3 final release from upstream
297- Remove the slew of versioning macros, as it's overkill for this and just adds
298  unneeded complexity to the spec.
299
300* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
301- Add missing BuildRequires: libXxf86vm-devel
302
303* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
304- Unconditionalize the BuildRequires for modular X.org, since it's branched
305  for a specific Fedora release.
306
307* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
308- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
309
310* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
311- Add %%{_datadir}/themes to Requires (#195292)
312
313* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
314- Own all created theme directories (#195292)
315- Fix previous review bug IDs in this %%changelog to point to the recreated
316  review bug (due to recent bugzilla outage)
317
318* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
319- Don't default to an executable xsession script (#195292)
320
321* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
322- Fix versioning to conform to the Extras packaging guidelines
323
324* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
325- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
326  login screen (#195292)
327
328* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
329- Unorphan, rewriting nearly all of the spec file
330- Update to upstream 3.3 RC2
331
332* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
333- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
334- Need to conflict with fluxbox (#422 / #440)
335
336* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
337- Need to own /usr/share/apps/switchdesk (#422)
338
339* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
340- More spec revisions (#422); change make and preserve timestamps
341
342* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
343- Minor spec revisions (#422); add epoch and versions to changelogs
344
345* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
346- Add switchdesk support
347- Add display manager support
348- Fix NLS build on Cambridge
349- Fedora'ize the spec
350
351* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
352- Rev to 2.3.1 release
353- Make go with GCC 3.3
354
355* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
356- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.