source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 6637

Revision 6637, 13.2 KB checked in by kudoh, 12 years ago (diff)
Line 
1Name:           openbox
2Version:        3.5.0
3Release:        4%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15Source5:        terminals.menu
16Source6:        openbox.gnome-session
17
18#Patch0:         openbox-3.4.10-obxpropman.patch
19Patch1: openbox-3.4.11.2-gnomesession.patch
20Patch2: 07_fix_xml_load_file.patch
21Patch3: 666676_wrong_undecorated_window_placement.patch
22Patch4: 90_fix_link_obt.patch
23Patch5: 675991_fix_crash_from_gtk3_apps.patch
24
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27
28Requires:       %{name}-libs = %{version}-%{release}
29
30BuildRequires:  gettext
31BuildRequires:  glib2-devel >= 2.14.0
32BuildRequires:  desktop-file-utils
33BuildRequires:  pango-devel
34BuildRequires:  startup-notification-devel
35BuildRequires:  libxml2-devel >= 2.6.0
36BuildRequires:  libSM-devel
37BuildRequires:  libXau-devel
38BuildRequires:  libXcursor-devel
39BuildRequires:  libXfixes-devel
40BuildRequires:  libXt-devel
41BuildRequires:  libXrandr-devel
42BuildRequires:  libXinerama-devel
43
44# The xdg-menu dynamic pipe menu requires the gmenu Python module
45Requires:       gnome-menus
46Requires:       pyxdg
47
48%description
49Openbox is a window manager designed explicity for standards-compliance and
50speed. It is fast, lightweight, and heavily configurable (using XML for its
51configuration data). It has many features that make it unique among window
52managers: window resistance, chainable key bindings, customizable mouse
53actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
54
55For a full list of the FreeDesktop.org standards with which it is compliant,
56please see the COMPLIANCE file in the included documentation of this package.
57For a graphical configuration editor, you'll need to install the obconf
58package. For a graphical menu editor, you'll need to install the obmenu
59package.
60
61
62%package        devel
63Summary:        Development files for %{name}
64Summary(ja):    %{name} の開発ファイル
65Group:          Development/Libraries
66Requires:       %{name}-libs = %{version}-%{release}
67Requires:       pkgconfig
68Requires:       pango-devel
69Requires:       libxml2-devel
70Requires:       glib2-devel
71
72%description    devel
73The %{name}-devel package contains libraries and header files for
74developing applications that use %{name}.
75
76
77%package        libs
78Summary:        Shared libraries for %{name}
79Summary:        %{name} の共有ライブラリ
80Group:          System Environment/Libraries
81
82%description    libs
83The %{name}-libs package contains shared libraries used by %{name}.
84
85
86%prep
87%setup -q
88%patch1 -p1
89%patch2 -p1
90%patch3 -p1
91%patch4 -p1
92%patch5 -p1
93autoreconf
94
95%build
96%configure \
97        --disable-static
98## Fix RPATH hardcoding.
99sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
100sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
101make %{?_smp_mflags}
102
103gcc %{optflags} -o setlayout %{SOURCE1} -lX11
104
105%install
106rm -rf %{buildroot}
107make install DESTDIR=%{buildroot}
108
109mkdir -m 644 %{buildroot}%{_datadir}/%{name}
110install setlayout %{buildroot}%{_bindir}
111
112install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
113sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
114        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
115
116desktop-file-install --vendor="" \
117        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
118        %{SOURCE4}
119       
120install -m644 -p %{SOURCE5} \
121        %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
122
123install -m644 -D %{SOURCE6} \
124        %{buildroot}%{_datadir}/gnome-session/sessions/gnome-openbox.session
125
126%find_lang %{name}
127rm -f %{buildroot}%{_libdir}/*.la
128rm -rf %{buildroot}%{_datadir}/doc/%{name}
129
130
131%clean
132rm -rf %{buildroot}
133
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
138%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
139%dir %{_sysconfdir}/xdg/%{name}/
140%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
141%{_bindir}/gnome-panel-control
142%{_bindir}/gdm-control
143%{_bindir}/%{name}*
144%{_bindir}/obxprop
145%{_bindir}/setlayout
146%{_datadir}/applications/*%{name}.desktop
147%{_datadir}/%{name}
148%{_datadir}/themes/*/
149%{_datadir}/pixmaps/%{name}.png
150%{_datadir}/gnome/wm-properties/
151%{_datadir}/gnome-session/sessions/gnome-openbox.session
152%{_datadir}/xsessions/%{name}*.desktop
153%{_libexecdir}/openbox-*
154%{_mandir}/man1/*
155
156%files  libs
157%{_libdir}/libobrender.so.*
158%{_libdir}/libobt.so*
159
160%files  devel
161%{_includedir}/%{name}/
162%{_libdir}/libobrender.so
163%{_libdir}/libobt.so*
164%{_libdir}/pkgconfig/*.pc
165
166
167%post libs -p /sbin/ldconfig
168
169
170%postun libs -p /sbin/ldconfig
171
172
173%changelog
174* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-4
175- added Patch3,4,5 from Debian sid
176
177* Sun Apr 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-3
178- replaced Source2 to newer from Fedora rawhide
179
180* Sat Feb 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-2
181- replaced Source2 to newer from Fedora rawhide
182- added Patch2 from Debian sid to fix load xml files
183
184* Fri Aug 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-1
185- new upstream release
186- dropt Patch0,7,10,11
187  - renumbered patches
188- added Source5 from Fedora development
189- improved Source3
190- run autoreconf in %%prep
191
192* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
193- dropt Patch1,3
194- added patch11 from Debian
195
196* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
197- rebuilt with rpm-4.8.1 for pkg-config
198- BuildRequires: libXau-devel
199
200* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
201- new upstream release
202- added Requires: pyxdg
203
204* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
205- new upstream release
206- changed URL and Source0
207- dropt Patch6
208- added BuildRequires: libXfixes-devel, libSM-devel
209- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
210
211* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
212- new upstream release
213- added Patch10 from Fedora
214- added summary(ja) in -devel and -libs
215
216* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
217- new upstream release
218- dropt Patch8
219- Patch9 from Fedora
220
221* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
222- new upstream release
223  - dropt patch2
224  - replaced and renamed Patch0 from Fedora
225
226* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
227- new upstream release
228  - dropt patch4,5
229  - added Patch8 from Fedora
230- added Requires: gnome-menus
231
232* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
233- improved Source3
234  - enabled administration menu (disabled preference menu because included)
235- added Patch6 from Mandriva
236- added Patch7 from Fedora
237- replaced Source1 from Fedora
238
239* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
240- updated Source4
241- added Patch4,5 from Debian
242
243* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
244- changed openbox-libs Group: System Environment/Libraries
245- spec in UTF-8
246
247* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
248- initial build for VineSeed
249
250* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
251- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
252
253* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
254- Restore gnome session script (#474143)
255- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
256
257* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
258- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
259- Add application desktop file to allow starting openbox in gnome-session
260  when configured in gconf
261
262* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
263- Don't use --choose-session option in gnome session script
264
265* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
266- Remove field codes from commands in xdg-menu (#452403)
267- Add support for launching applications in xterm to xdg-menu
268
269* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
270- Clean up properties after gdm in session scripts (#444135)
271- Add license to xdg-menu script
272
273* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
274- Drop numdesks patch (#444135)
275
276* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
277- Update to 3.4.7.2
278- Use gnome menus by default (Luke Macken) (#443548)
279- Force setting number of desktops (#444135)
280
281* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
282- Update to 3.4.7.1
283- Don't require /usr/share/themes
284
285* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
286- Update to 3.4.6.1
287
288* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
289- Update to 3.4.6
290
291* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
292- Update to 3.4.5
293
294* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
295- Rebuild
296
297* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
298- Update to 3.4.4
299- Update license tag
300
301* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
302- Update to 3.4.3
303- Package setlayout tool
304
305* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
306- Update to 3.4.2
307
308* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
309- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
310  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
311  Lichvar for the bug report.)
312
313* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
314- Split shared libraries into a -libs subpackage to properly handle multilib
315  setups. (This precludes the further need to %%ghost the byte-compiled
316  themeupdate scripts which was introduced in the previous release.)
317- Fix handling of the startup_notification build conditional. It will actually
318  work properly now. :)
319- Remove the hardcoded RPATH using some sed invocations from the packaging
320  guidelines.
321
322* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
323- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
324  (bug #228379).
325
326* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
327- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
328  by gnome-session in Rawhide and we should not have ownership conflicts with
329  Core packages.
330
331* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
332- Rebuild to pick up unwind info generation fixes in new GCC
333
334* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
335- Allow building with startup-notification as an rpmbuild option (though it is
336  disabled by default as recommended by upstream).
337
338* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
339- Update to new 3.3.1 from upstream
340
341* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
342- Mass FC6 rebuild
343
344* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
345- Bump release to fix sources tagging issue
346
347* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
348- Update to 3.3 final release from upstream
349- Remove the slew of versioning macros, as it's overkill for this and just adds
350  unneeded complexity to the spec.
351
352* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
353- Add missing BuildRequires: libXxf86vm-devel
354
355* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
356- Unconditionalize the BuildRequires for modular X.org, since it's branched
357  for a specific Fedora release.
358
359* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
360- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
361
362* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
363- Add %%{_datadir}/themes to Requires (#195292)
364
365* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
366- Own all created theme directories (#195292)
367- Fix previous review bug IDs in this %%changelog to point to the recreated
368  review bug (due to recent bugzilla outage)
369
370* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
371- Don't default to an executable xsession script (#195292)
372
373* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
374- Fix versioning to conform to the Extras packaging guidelines
375
376* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
377- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
378  login screen (#195292)
379
380* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
381- Unorphan, rewriting nearly all of the spec file
382- Update to upstream 3.3 RC2
383
384* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
385- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
386- Need to conflict with fluxbox (#422 / #440)
387
388* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
389- Need to own /usr/share/apps/switchdesk (#422)
390
391* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
392- More spec revisions (#422); change make and preserve timestamps
393
394* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
395- Minor spec revisions (#422); add epoch and versions to changelogs
396
397* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
398- Add switchdesk support
399- Add display manager support
400- Fix NLS build on Cambridge
401- Fedora'ize the spec
402
403* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
404- Rev to 2.3.1 release
405- Make go with GCC 3.3
406
407* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
408- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.