source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 5615

Revision 5615, 12.9 KB checked in by kudoh, 12 years ago (diff)
Line 
1Name:           openbox
2Version:        3.5.0
3Release:        2%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15Source5:        terminals.menu
16Source6:        openbox.gnome-session
17
18#Patch0:         openbox-3.4.10-obxpropman.patch
19Patch1:  openbox-3.4.11.2-gnomesession.patch
20Patch2:  07_fix_xml_load_file.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24Requires:       %{name}-libs = %{version}-%{release}
25
26BuildRequires:  gettext
27BuildRequires:  glib2-devel >= 2.14.0
28BuildRequires:  desktop-file-utils
29BuildRequires:  pango-devel
30BuildRequires:  startup-notification-devel
31BuildRequires:  libxml2-devel >= 2.6.0
32BuildRequires:  libSM-devel
33BuildRequires:  libXau-devel
34BuildRequires:  libXcursor-devel
35BuildRequires:  libXfixes-devel
36BuildRequires:  libXt-devel
37BuildRequires:  libXrandr-devel
38BuildRequires:  libXinerama-devel
39
40# The xdg-menu dynamic pipe menu requires the gmenu Python module
41Requires:       gnome-menus
42Requires:       pyxdg
43
44%description
45Openbox is a window manager designed explicity for standards-compliance and
46speed. It is fast, lightweight, and heavily configurable (using XML for its
47configuration data). It has many features that make it unique among window
48managers: window resistance, chainable key bindings, customizable mouse
49actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
50
51For a full list of the FreeDesktop.org standards with which it is compliant,
52please see the COMPLIANCE file in the included documentation of this package.
53For a graphical configuration editor, you'll need to install the obconf
54package. For a graphical menu editor, you'll need to install the obmenu
55package.
56
57
58%package        devel
59Summary:        Development files for %{name}
60Summary(ja):    %{name} の開発ファイル
61Group:          Development/Libraries
62Requires:       %{name}-libs = %{version}-%{release}
63Requires:       pkgconfig
64Requires:       pango-devel
65Requires:       libxml2-devel
66Requires:       glib2-devel
67
68%description    devel
69The %{name}-devel package contains libraries and header files for
70developing applications that use %{name}.
71
72
73%package        libs
74Summary:        Shared libraries for %{name}
75Summary:        %{name} の共有ライブラリ
76Group:          System Environment/Libraries
77
78%description    libs
79The %{name}-libs package contains shared libraries used by %{name}.
80
81
82%prep
83%setup -q
84%patch1 -p1
85%patch2 -p1
86autoreconf
87
88%build
89%configure \
90        --disable-static
91## Fix RPATH hardcoding.
92sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
93sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
94make %{?_smp_mflags}
95
96gcc %{optflags} -o setlayout %{SOURCE1} -lX11
97
98%install
99rm -rf %{buildroot}
100make install DESTDIR=%{buildroot}
101
102mkdir -m 644 %{buildroot}%{_datadir}/%{name}
103install setlayout %{buildroot}%{_bindir}
104
105install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
106sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
107        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
108
109desktop-file-install --vendor="" \
110        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
111        %{SOURCE4}
112       
113install -m644 -p %{SOURCE5} \
114        %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
115
116install -m644 -D %{SOURCE6} \
117        %{buildroot}%{_datadir}/gnome-session/sessions/gnome-openbox.session
118
119%find_lang %{name}
120rm -f %{buildroot}%{_libdir}/*.la
121rm -rf %{buildroot}%{_datadir}/doc/%{name}
122
123
124%clean
125rm -rf %{buildroot}
126
127
128%files -f %{name}.lang
129%defattr(-,root,root,-)
130%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
131%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
132%dir %{_sysconfdir}/xdg/%{name}/
133%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
134%{_bindir}/gnome-panel-control
135%{_bindir}/gdm-control
136%{_bindir}/%{name}*
137%{_bindir}/obxprop
138%{_bindir}/setlayout
139%{_datadir}/applications/*%{name}.desktop
140%{_datadir}/%{name}
141%{_datadir}/themes/*/
142%{_datadir}/pixmaps/%{name}.png
143%{_datadir}/gnome/wm-properties/
144%{_datadir}/gnome-session/sessions/gnome-openbox.session
145%{_datadir}/xsessions/%{name}*.desktop
146%{_libexecdir}/openbox-*
147%{_mandir}/man1/*
148
149%files  libs
150%{_libdir}/libobrender.so.*
151%{_libdir}/libobt.so*
152
153%files  devel
154%{_includedir}/%{name}/
155%{_libdir}/libobrender.so
156%{_libdir}/libobt.so*
157%{_libdir}/pkgconfig/*.pc
158
159
160%post libs -p /sbin/ldconfig
161
162
163%postun libs -p /sbin/ldconfig
164
165
166%changelog
167* Sat Feb 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-2
168- replaced Source2 to newer from Fedora rawhide
169- added Patch2 from Debian sid to fix load xml files
170
171* Fri Aug 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-1
172- new upstream release
173- dropt Patch0,7,10,11
174  - renumbered patches
175- added Source5 from Fedora development
176- improved Source3
177- run autoreconf in %%prep
178
179* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
180- dropt Patch1,3
181- added patch11 from Debian
182
183* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
184- rebuilt with rpm-4.8.1 for pkg-config
185- BuildRequires: libXau-devel
186
187* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
188- new upstream release
189- added Requires: pyxdg
190
191* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
192- new upstream release
193- changed URL and Source0
194- dropt Patch6
195- added BuildRequires: libXfixes-devel, libSM-devel
196- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
197
198* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
199- new upstream release
200- added Patch10 from Fedora
201- added summary(ja) in -devel and -libs
202
203* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
204- new upstream release
205- dropt Patch8
206- Patch9 from Fedora
207
208* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
209- new upstream release
210  - dropt patch2
211  - replaced and renamed Patch0 from Fedora
212
213* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
214- new upstream release
215  - dropt patch4,5
216  - added Patch8 from Fedora
217- added Requires: gnome-menus
218
219* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
220- improved Source3
221  - enabled administration menu (disabled preference menu because included)
222- added Patch6 from Mandriva
223- added Patch7 from Fedora
224- replaced Source1 from Fedora
225
226* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
227- updated Source4
228- added Patch4,5 from Debian
229
230* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
231- changed openbox-libs Group: System Environment/Libraries
232- spec in UTF-8
233
234* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
235- initial build for VineSeed
236
237* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
239
240* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
241- Restore gnome session script (#474143)
242- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
243
244* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
245- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
246- Add application desktop file to allow starting openbox in gnome-session
247  when configured in gconf
248
249* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
250- Don't use --choose-session option in gnome session script
251
252* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
253- Remove field codes from commands in xdg-menu (#452403)
254- Add support for launching applications in xterm to xdg-menu
255
256* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
257- Clean up properties after gdm in session scripts (#444135)
258- Add license to xdg-menu script
259
260* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
261- Drop numdesks patch (#444135)
262
263* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
264- Update to 3.4.7.2
265- Use gnome menus by default (Luke Macken) (#443548)
266- Force setting number of desktops (#444135)
267
268* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
269- Update to 3.4.7.1
270- Don't require /usr/share/themes
271
272* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
273- Update to 3.4.6.1
274
275* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
276- Update to 3.4.6
277
278* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
279- Update to 3.4.5
280
281* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
282- Rebuild
283
284* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
285- Update to 3.4.4
286- Update license tag
287
288* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
289- Update to 3.4.3
290- Package setlayout tool
291
292* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
293- Update to 3.4.2
294
295* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
296- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
297  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
298  Lichvar for the bug report.)
299
300* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
301- Split shared libraries into a -libs subpackage to properly handle multilib
302  setups. (This precludes the further need to %%ghost the byte-compiled
303  themeupdate scripts which was introduced in the previous release.)
304- Fix handling of the startup_notification build conditional. It will actually
305  work properly now. :)
306- Remove the hardcoded RPATH using some sed invocations from the packaging
307  guidelines.
308
309* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
310- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
311  (bug #228379).
312
313* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
314- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
315  by gnome-session in Rawhide and we should not have ownership conflicts with
316  Core packages.
317
318* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
319- Rebuild to pick up unwind info generation fixes in new GCC
320
321* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
322- Allow building with startup-notification as an rpmbuild option (though it is
323  disabled by default as recommended by upstream).
324
325* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
326- Update to new 3.3.1 from upstream
327
328* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
329- Mass FC6 rebuild
330
331* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
332- Bump release to fix sources tagging issue
333
334* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
335- Update to 3.3 final release from upstream
336- Remove the slew of versioning macros, as it's overkill for this and just adds
337  unneeded complexity to the spec.
338
339* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
340- Add missing BuildRequires: libXxf86vm-devel
341
342* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
343- Unconditionalize the BuildRequires for modular X.org, since it's branched
344  for a specific Fedora release.
345
346* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
347- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
348
349* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
350- Add %%{_datadir}/themes to Requires (#195292)
351
352* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
353- Own all created theme directories (#195292)
354- Fix previous review bug IDs in this %%changelog to point to the recreated
355  review bug (due to recent bugzilla outage)
356
357* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
358- Don't default to an executable xsession script (#195292)
359
360* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
361- Fix versioning to conform to the Extras packaging guidelines
362
363* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
364- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
365  login screen (#195292)
366
367* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
368- Unorphan, rewriting nearly all of the spec file
369- Update to upstream 3.3 RC2
370
371* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
372- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
373- Need to conflict with fluxbox (#422 / #440)
374
375* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
376- Need to own /usr/share/apps/switchdesk (#422)
377
378* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
379- More spec revisions (#422); change make and preserve timestamps
380
381* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
382- Minor spec revisions (#422); add epoch and versions to changelogs
383
384* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
385- Add switchdesk support
386- Add display manager support
387- Fix NLS build on Cambridge
388- Fedora'ize the spec
389
390* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
391- Rev to 2.3.1 release
392- Make go with GCC 3.3
393
394* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
395- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.