source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 9812

Revision 9812, 13.7 KB checked in by kudoh, 8 years ago (diff)

new upstream and rebuilt

Line 
1Name:           openbox
2Version:        3.6.1
3Release:        1%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.xz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        terminals.menu
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       %{name}-libs = %{version}-%{release}
19
20BuildRequires:  gettext
21BuildRequires:  glib2-devel >= 2.14.0
22BuildRequires:  desktop-file-utils
23BuildRequires:  pango-devel
24BuildRequires:  startup-notification-devel
25BuildRequires:  imlib2-devel
26BuildRequires:  librsvg2-devel
27BuildRequires:  libxml2-devel >= 2.6.0
28BuildRequires:  libSM-devel
29BuildRequires:  libXau-devel
30BuildRequires:  libXcursor-devel
31BuildRequires:  libXfixes-devel
32BuildRequires:  libXt-devel
33BuildRequires:  libXrandr-devel
34BuildRequires:  libXinerama-devel
35
36# The xdg-menu dynamic pipe menu requires the gmenu Python module
37Requires:       gnome-menus
38Requires:       pyxdg
39
40%description
41Openbox is a window manager designed explicity for standards-compliance and
42speed. It is fast, lightweight, and heavily configurable (using XML for its
43configuration data). It has many features that make it unique among window
44managers: window resistance, chainable key bindings, customizable mouse
45actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
46
47For a full list of the FreeDesktop.org standards with which it is compliant,
48please see the COMPLIANCE file in the included documentation of this package.
49For a graphical configuration editor, you'll need to install the obconf
50package. For a graphical menu editor, you'll need to install the obmenu
51package.
52
53
54%package        devel
55Summary:        Development files for %{name}
56Summary(ja):    %{name} の開発ファイル
57Group:          Development/Libraries
58Requires:       %{name}-libs = %{version}-%{release}
59Requires:       pkgconfig
60Requires:       pango-devel
61Requires:       libxml2-devel
62Requires:       glib2-devel
63
64%description    devel
65The %{name}-devel package contains libraries and header files for
66developing applications that use %{name}.
67
68
69%package        libs
70Summary:        Shared libraries for %{name}
71Summary:        %{name} の共有ライブラリ
72Group:          System Environment/Libraries
73
74%description    libs
75The %{name}-libs package contains shared libraries used by %{name}.
76
77
78%prep
79%setup -q
80autoreconf
81
82%build
83%configure \
84        --disable-static
85## Fix RPATH hardcoding.
86sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
87sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
88make %{?_smp_mflags}
89
90gcc %{optflags} -o setlayout %{SOURCE1} -lX11
91
92%install
93rm -rf %{buildroot}
94make install DESTDIR=%{buildroot}
95
96mkdir -m 644 %{buildroot}%{_datadir}/%{name}
97install setlayout %{buildroot}%{_bindir}
98
99install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
100sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
101        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
102       
103install -m644 -p %{SOURCE4} \
104        %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
105
106# 'make install' misses these two, so we install them manually
107install -m644 -D data/gnome-session/openbox-gnome.session \
108        %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome.session
109install -m644 -D data/gnome-session/openbox-gnome-fallback.session \
110        %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
111
112
113%find_lang %{name}
114rm -f %{buildroot}%{_libdir}/*.la
115rm -rf %{buildroot}%{_datadir}/doc/%{name}
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}.lang
123%defattr(-,root,root,-)
124%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
125%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
126%dir %{_sysconfdir}/xdg/%{name}/
127%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
128%{_bindir}/gnome-panel-control
129%{_bindir}/gdm-control
130%{_bindir}/%{name}*
131%{_bindir}/obxprop
132%{_bindir}/setlayout
133%{_datadir}/applications/*%{name}.desktop
134%{_datadir}/%{name}
135%{_datadir}/themes/*/
136%{_datadir}/pixmaps/%{name}.png
137%{_datadir}/gnome/wm-properties/
138%{_datadir}/gnome-session/sessions/openbox-gnome.session
139%{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
140%{_datadir}/xsessions/%{name}*.desktop
141%{_libexecdir}/openbox-*
142%{_mandir}/man1/*
143
144%files  libs
145%{_libdir}/libobrender.so.*
146%{_libdir}/libobt.so.*
147
148%files  devel
149%{_includedir}/%{name}/
150%{_libdir}/libobrender.so
151%{_libdir}/libobt.so
152%{_libdir}/pkgconfig/*.pc
153
154
155%post libs -p /sbin/ldconfig
156
157
158%postun libs -p /sbin/ldconfig
159
160
161%changelog
162* Sun Nov 15 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.6.1-1
163- new upstream release
164- changet source archive type gz to xz
165- fixed Source3
166  - deleted unused menu
167- cleaned up spec
168  - renumbered %%{Source} files
169
170* Fri Jul 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.5.2-2
171- fix file list (libs,devel)
172  - remove .so from -libs
173  - remove .so.* from -devel
174
175* Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.2-1
176- new upstream release
177- replaced Source2 to newer from Fedora rawhide
178- added BuildRequires: imlib2-devel, librsvg2-devel
179
180* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-4
181- added Patch3,4,5 from Debian sid
182
183* Sun Apr 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-3
184- replaced Source2 to newer from Fedora rawhide
185
186* Sat Feb 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-2
187- replaced Source2 to newer from Fedora rawhide
188- added Patch2 from Debian sid to fix load xml files
189
190* Fri Aug 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-1
191- new upstream release
192- dropt Patch0,7,10,11
193  - renumbered patches
194- added Source5 from Fedora development
195- improved Source3
196- run autoreconf in %%prep
197
198* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
199- dropt Patch1,3
200- added patch11 from Debian
201
202* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
203- rebuilt with rpm-4.8.1 for pkg-config
204- BuildRequires: libXau-devel
205
206* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
207- new upstream release
208- added Requires: pyxdg
209
210* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
211- new upstream release
212- changed URL and Source0
213- dropt Patch6
214- added BuildRequires: libXfixes-devel, libSM-devel
215- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
216
217* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
218- new upstream release
219- added Patch10 from Fedora
220- added summary(ja) in -devel and -libs
221
222* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
223- new upstream release
224- dropt Patch8
225- Patch9 from Fedora
226
227* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
228- new upstream release
229  - dropt patch2
230  - replaced and renamed Patch0 from Fedora
231
232* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
233- new upstream release
234  - dropt patch4,5
235  - added Patch8 from Fedora
236- added Requires: gnome-menus
237
238* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
239- improved Source3
240  - enabled administration menu (disabled preference menu because included)
241- added Patch6 from Mandriva
242- added Patch7 from Fedora
243- replaced Source1 from Fedora
244
245* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
246- updated Source4
247- added Patch4,5 from Debian
248
249* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
250- changed openbox-libs Group: System Environment/Libraries
251- spec in UTF-8
252
253* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
254- initial build for VineSeed
255
256* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
258
259* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
260- Restore gnome session script (#474143)
261- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
262
263* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
264- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
265- Add application desktop file to allow starting openbox in gnome-session
266  when configured in gconf
267
268* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
269- Don't use --choose-session option in gnome session script
270
271* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
272- Remove field codes from commands in xdg-menu (#452403)
273- Add support for launching applications in xterm to xdg-menu
274
275* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
276- Clean up properties after gdm in session scripts (#444135)
277- Add license to xdg-menu script
278
279* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
280- Drop numdesks patch (#444135)
281
282* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
283- Update to 3.4.7.2
284- Use gnome menus by default (Luke Macken) (#443548)
285- Force setting number of desktops (#444135)
286
287* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
288- Update to 3.4.7.1
289- Don't require /usr/share/themes
290
291* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
292- Update to 3.4.6.1
293
294* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
295- Update to 3.4.6
296
297* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
298- Update to 3.4.5
299
300* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
301- Rebuild
302
303* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
304- Update to 3.4.4
305- Update license tag
306
307* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
308- Update to 3.4.3
309- Package setlayout tool
310
311* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
312- Update to 3.4.2
313
314* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
315- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
316  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
317  Lichvar for the bug report.)
318
319* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
320- Split shared libraries into a -libs subpackage to properly handle multilib
321  setups. (This precludes the further need to %%ghost the byte-compiled
322  themeupdate scripts which was introduced in the previous release.)
323- Fix handling of the startup_notification build conditional. It will actually
324  work properly now. :)
325- Remove the hardcoded RPATH using some sed invocations from the packaging
326  guidelines.
327
328* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
329- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
330  (bug #228379).
331
332* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
333- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
334  by gnome-session in Rawhide and we should not have ownership conflicts with
335  Core packages.
336
337* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
338- Rebuild to pick up unwind info generation fixes in new GCC
339
340* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
341- Allow building with startup-notification as an rpmbuild option (though it is
342  disabled by default as recommended by upstream).
343
344* Sat Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
345- Update to new 3.3.1 from upstream
346
347* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
348- Mass FC6 rebuild
349
350* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
351- Bump release to fix sources tagging issue
352
353* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
354- Update to 3.3 final release from upstream
355- Remove the slew of versioning macros, as it's overkill for this and just adds
356  unneeded complexity to the spec.
357
358* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
359- Add missing BuildRequires: libXxf86vm-devel
360
361* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
362- Unconditionalize the BuildRequires for modular X.org, since it's branched
363  for a specific Fedora release.
364
365* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
366- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
367
368* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
369- Add %%{_datadir}/themes to Requires (#195292)
370
371* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
372- Own all created theme directories (#195292)
373- Fix previous review bug IDs in this %%changelog to point to the recreated
374  review bug (due to recent bugzilla outage)
375
376* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
377- Don't default to an executable xsession script (#195292)
378
379* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
380- Fix versioning to conform to the Extras packaging guidelines
381
382* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
383- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
384  login screen (#195292)
385
386* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
387- Unorphan, rewriting nearly all of the spec file
388- Update to upstream 3.3 RC2
389
390* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
391- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
392- Need to conflict with fluxbox (#422 / #440)
393
394* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
395- Need to own /usr/share/apps/switchdesk (#422)
396
397* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
398- More spec revisions (#422); change make and preserve timestamps
399
400* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
401- Minor spec revisions (#422); add epoch and versions to changelogs
402
403* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
404- Add switchdesk support
405- Add display manager support
406- Fix NLS build on Cambridge
407- Fedora'ize the spec
408
409* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
410- Rev to 2.3.1 release
411- Make go with GCC 3.3
412
413* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
414- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.