source: projects/specs/trunk/o/openbabel/openbabel-vl.spec @ 9748

Revision 9748, 8.4 KB checked in by Takemikaduchi, 9 years ago (diff)

rebuild with ruby-2.2.3

Line 
1%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
3
4Name:             openbabel
5Version:          2.3.2
6Release:          4%{?_dist_release}
7Summary:          Chemistry software file format converter
8Summary(ja):      化学ソフトデータファイル変換プログラム
9License:          GPLv2
10Group:            Applications/Edutainment
11URL:              http://openbabel.sourceforge.net/
12Source:           http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
13
14# fron fedora
15Patch0:         openbabel-2.3.1-gcc47-darwin.patch
16Patch1:         openbabel-rpm.patch
17Patch2:         openbabel-2.3.2-cmake.patch
18Patch3:         openbabel-2.3.1-ruby19-vendorarch.patch
19Patch4:         openbabel-2.3.1-ruby22-remove-deprecated-usage.patch
20
21BuildRoot:        %{_tmppath}/%{name}-%{version}-root
22BuildRequires: inchi-devel
23BuildRequires: libtool
24BuildRequires: libxml2-devel
25BuildRequires: perl
26BuildRequires: python
27BuildRequires: python-devel
28BuildRequires: ruby
29BuildRequires: ruby-devel
30BuildRequires: swig
31BuildRequires: wxGTK-devel
32BuildRequires: zlib-devel
33BuildRequires: cmake
34BuildRequires: eigen2-devel
35
36Distribution:  Vine Linux
37Vendor:       Project Vine
38Packager:     inagaki
39
40%description
41Open Babel is a free, open-source version of the Babel chemistry file
42translation program. Open Babel is a project designed to pick up where
43Babel left off, as a cross-platform program and library designed to
44interconvert between many file formats used in molecular modeling,
45computational chemistry, and many related areas.
46
47Open Babel includes two components, a command-line utility and a C++
48library. The command-line utility is intended to be used as a replacement
49for the original babel program, to translate between various chemical file
50formats. The C++ library includes all of the file-translation code as well
51as a wide variety of utilities to foster development of other open source
52scientific software.
53
54%package devel
55Summary: Development tools for programs which will use the Open Babel library
56Summary(ja): %{name} の開発用ヘッダファイル
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: pkgconfig
60
61%description devel
62The %{name}-devel package includes the header files and libraries
63necessary for developing programs using the Open Babel library.
64
65If you are going to develop programs which will use this library
66you should install %{name}-devel.  You'll also need to have the
67%{name} package installed.
68
69%description devel -l ja
70%{name}の開発用ヘッダファイル
71
72%package -n perl-%{name}
73Summary: Perl wrapper for the Open Babel library
74Summary(ja): Open Babel ライブラリの Perl ラッパー
75Group: Development/Libraries
76Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
77Obsoletes: %{name}-perl < 2.2.0
78Provides: %{name}-perl = %{version}-%{release}
79
80%description -n perl-%{name}
81Perl wrapper for the Open Babel library.
82
83%description -n perl-%{name} -l ja
84Open Babel ライブラリの Perl ラッパーです.
85
86%package -n python-%{name}
87Group: Development/Libraries
88Summary: Python wrapper for the Open Babel library
89Summary(ja): Open Babel ライブラリの Python ラッパー
90Obsoletes: %{name}-python < 2.2.0
91Provides: %{name}-python = %{version}-%{release}
92
93%description -n python-%{name}
94Python wrapper for the Open Babel library.
95
96%description -n python-%{name} -l ja
97Open Babel ライブラリの Python ラッパー
98
99%package -n ruby-%{name}
100Summary: Ruby wrapper for the Open Babel library
101Summary(ja): Open Babel ライブラリの Ruby ラッパー
102Group: Development/Libraries
103Requires: ruby >= 1.8
104Requires: %{name} = %{version}-%{release}
105
106%description -n ruby-%{name}
107Open Babel ライブラリの Ruby ラッパー
108
109%prep
110%setup -q
111%patch0 -p1 -b .gcc47
112%patch1 -p1 -b .rpm
113%patch2 -p1 -b .cmake
114%patch3 -p1 -b .ruby_vendor
115%patch4 -p1 -b .rbconfig
116
117chmod 644 src/formats/{mmcif,fchk}format.cpp
118
119%build
120%cmake \
121        -DOPENBABEL_USE_SYSTEM_INCHI=true \
122        -DPYTHON_BINDINGS:BOOL=ON \
123        -DRUBY_BINDINGS:BOOL=ON \
124        -DPERL_BINDINGS:BOOL=ON \
125    .
126
127make %{?_smp_mflags}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131make install DESTDIR=$RPM_BUILD_ROOT
132
133rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
134
135mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
136mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
137   $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
138   $RPM_BUILD_ROOT%{_libdir}/pybel.py \
139   $RPM_BUILD_ROOT%{python_sitearch}
140
141rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
142rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
143rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
144rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150
151%postun -p /sbin/ldconfig
152
153%files
154%defattr(-,root,root,-)
155%doc AUTHORS COPYING ChangeLog README THANKS
156%doc doc/*.html
157#doc doc/README* doc/babel*.inc doc/dioxin.*
158%doc doc/README* doc/dioxin.*
159%{_bindir}/*
160%{_mandir}/man1/*
161%{_datadir}/%{name}
162%{_libdir}/libopenbabel.so.*
163%{_libdir}/%{name}
164
165%files devel
166%defattr(-,root,root,-)
167%{_includedir}/%{name}-2.0
168%{_libdir}/libopenbabel.so
169%{_libdir}/pkgconfig/*.pc
170
171%files -n perl-%{name}
172%defattr(-,root,root,-)
173%{perl_vendorarch}/Chemistry/OpenBabel.pm
174%dir %{perl_vendorarch}/*/Chemistry/OpenBabel
175%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
176
177%files -n python-%{name}
178%defattr(-,root,root,-)
179%{python_sitearch}/_openbabel.so
180%{python_sitearch}/openbabel.py*
181%{python_sitearch}/pybel.py*
182
183%files -n ruby-%{name}
184%defattr(-,root,root,-)
185%{ruby_vendorarchdir}/openbabel.so
186
187%changelog
188* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-4
189- rebuild with ruby-2.2.3
190- add Patch4 (openbabel-2.3.1-ruby22-remove-deprecated-usage.patch) from fedora
191
192* Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-3
193- add BuildRequires: wxGTK-devel, eigen2-devel
194
195* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
196- rebuilt with ruby 2.1.5 and perl 5.16.3
197
198* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
199- new upstream release
200- add BuildRequires: cmake
201- add Patch0,1,2,3 from fedora
202
203* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
204- rebuilt with rpm-4.8.1 for pkg-config
205
206* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
207- rebuild with python-2.6
208
209* Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
210- <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
211
212* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
213- applied new versioning policy, spec in UTF-8
214- using system inchi package
215- added ruby-%{name} package
216
217* Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
218- Updated to 2.1.0
219
220* Tue May  1 2007  Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
221- built for VineLinux
222
223* Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
224- rebuilt for unwind info generation, broken in gcc-4.1.1-21
225
226* Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
227- .pyo files no longer ghosted
228- fix chicken-and-egg problem when building perl and python bindings
229
230* Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
231- simplified autotools invocation
232- mass rebuild
233
234* Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
235- simplified file lists and permissions
236- removed weird character from inchi summary and description
237- added missing pkgconfig Req: for -devel
238
239* Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
240- updated to 2.0.2
241- dropped GCC4 fix (upstream'd)
242- split off inchi package
243- added python and perl bindings packages
244
245* Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
246- updated to 2.0.0
247- fix compilation with GCC4
248- FE compliance
249
250* Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
251- rebuilt for Fedora 3
252
253* Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
254- Rebuilt with libstdc++.so.6.
255
256* Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
257- 1.100.2
258
259* Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
260- removed *.la
261- don't package static library by default
262
263* Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
264- 1.100.1
265- #2994 fixed; thanks to Alex Ott (ott@) for a pointer
266- spec cleanup (underlibification fixup)
267
268* Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
269- built for ALT Linux
270- based on Mandrake Cooker spec by:
271  * Lenny Cartier <lenny@mandrakesoft.com>
272  * Austin Acton <aacton@yorku.ca>
273- spec cleanup
Note: See TracBrowser for help on using the repository browser.