source: projects/specs/trunk/o/openbabel/openbabel-vl.spec @ 8034

Revision 8034, 7.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild with libboost-1.54.0

Line 
1%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
3
4Name:             openbabel
5Version:          2.3.2
6Release:          1%{?_dist_release}
7Summary:          Chemistry software file format converter
8Summary(ja):      化学ソフトデータファイル変換プログラム
9License:          GPL
10Group:            Applications/Edutainment
11URL:              http://openbabel.sourceforge.net/
12Source:           http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
13
14# fron fedora
15Patch0:                 openbabel-2.3.1-gcc47-darwin.patch
16Patch1:                 openbabel-rpm.patch
17Patch2:                 openbabel-2.3.2-cmake.patch
18Patch3:                 openbabel-2.3.1-ruby19-vendorarch.patch
19
20BuildRoot:        %{_tmppath}/%{name}-%{version}-root
21BuildRequires: inchi-devel
22BuildRequires: libtool
23BuildRequires: libxml2-devel
24BuildRequires: perl
25BuildRequires: python
26BuildRequires: python-devel
27BuildRequires: ruby
28BuildRequires: ruby-devel
29BuildRequires: swig
30#TODO: enable when GUI is functional
31#BuildRequires: wxGTK-devel
32BuildRequires: zlib-devel
33BuildRequires: cmake
34
35Distribution:  Vine Linux
36Vendor:       Project Vine
37Packager:     inagaki
38
39%description
40Open Babel is a free, open-source version of the Babel chemistry file
41translation program. Open Babel is a project designed to pick up where
42Babel left off, as a cross-platform program and library designed to
43interconvert between many file formats used in molecular modeling,
44computational chemistry, and many related areas.
45
46Open Babel includes two components, a command-line utility and a C++
47library. The command-line utility is intended to be used as a replacement
48for the original babel program, to translate between various chemical file
49formats. The C++ library includes all of the file-translation code as well
50as a wide variety of utilities to foster development of other open source
51scientific software.
52
53%package devel
54Summary: Development tools for programs which will use the Open Babel library
55Summary(ja): %{name}の開発用ヘッダファイル
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: pkgconfig
59
60%description devel
61The %{name}-devel package includes the header files and libraries
62necessary for developing programs using the Open Babel library.
63
64If you are going to develop programs which will use this library
65you should install %{name}-devel.  You'll also need to have the
66%{name} package installed.
67
68%description devel -l ja
69%{name}の開発用ヘッダファイル
70
71%package -n perl-%{name}
72Summary: Perl wrapper for the Open Babel library
73Summary(ja): Open Babel ライブラリの Perl ラッパー
74Group: Development/Libraries
75Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
76Obsoletes: %{name}-perl < 2.2.0
77Provides: %{name}-perl = %{version}-%{release}
78
79%description -n perl-%{name}
80Perl wrapper for the Open Babel library.
81
82%description -n perl-%{name} -l ja
83Open Babel ライブラリの Perl ラッパーです.
84
85%package -n python-%{name}
86Group: Development/Libraries
87Summary: Python wrapper for the Open Babel library
88Summary(ja): Open Babel ライブラリの Python ラッパー
89Obsoletes: %{name}-python < 2.2.0
90Provides: %{name}-python = %{version}-%{release}
91
92%description -n python-%{name}
93Python wrapper for the Open Babel library.
94
95%description -n python-%{name} -l ja
96Open Babel ライブラリの Python ラッパー
97
98%package -n ruby-%{name}
99Summary: Ruby wrapper for the Open Babel library
100Summary(ja): Open Babel ライブラリの Ruby ラッパー
101Group: Development/Libraries
102Requires: ruby >= 1.8
103Requires: %{name} = %{version}-%{release}
104
105%description -n ruby-%{name}
106Open Babel ライブラリの Ruby ラッパー
107
108%prep
109%setup -q
110%patch0 -p1 -b .gcc47
111%patch1 -p1 -b .rpm
112%patch2 -p1 -b .cmake
113%patch3 -p1 -b .ruby_vendor
114
115chmod 644 src/formats/{mmcif,fchk}format.cpp
116
117%build
118%cmake \
119        -DOPENBABEL_USE_SYSTEM_INCHI=true \
120        -DPYTHON_BINDINGS:BOOL=ON \
121        -DRUBY_BINDINGS:BOOL=ON \
122        -DPERL_BINDINGS:BOOL=ON \
123    .
124
125make %{?_smp_mflags}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129make install DESTDIR=$RPM_BUILD_ROOT
130
131rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
132
133mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
134mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
135   $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
136   $RPM_BUILD_ROOT%{_libdir}/pybel.py \
137   $RPM_BUILD_ROOT%{python_sitearch}
138
139rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
140rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
141rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
142rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148
149%postun -p /sbin/ldconfig
150
151%files
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING ChangeLog README THANKS
154%doc doc/*.html
155%doc doc/README* doc/babel*.inc doc/dioxin.*
156%{_bindir}/*
157%{_mandir}/man1/*
158%{_datadir}/%{name}
159%{_libdir}/libopenbabel.so.*
160%{_libdir}/%{name}
161
162%files devel
163%defattr(-,root,root,-)
164%{_includedir}/%{name}-2.0
165%{_libdir}/libopenbabel.so
166%{_libdir}/pkgconfig/*.pc
167
168%files -n perl-%{name}
169%defattr(-,root,root,-)
170%{perl_vendorarch}/Chemistry/OpenBabel.pm
171%dir %{perl_vendorarch}/*/Chemistry/OpenBabel
172%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
173
174%files -n python-%{name}
175%defattr(-,root,root,-)
176%{python_sitearch}/_openbabel.so
177%{python_sitearch}/openbabel.py*
178%{python_sitearch}/pybel.py*
179
180%files -n ruby-%{name}
181%defattr(-,root,root,-)
182%{ruby_vendorarchdir}/openbabel.so
183
184%changelog
185* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
186- new upstream release
187- add BuildRequires: cmake
188- add Patch0,1,2,3 from fedora
189
190* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
191- rebuilt with rpm-4.8.1 for pkg-config
192
193* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
194- rebuild with python-2.6
195
196* Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
197- <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
198
199* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
200- applied new versioning policy, spec in UTF-8
201- using system inchi package
202- added ruby-%{name} package
203
204* Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
205- Updated to 2.1.0
206
207* Tue May  1 2007  Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
208- built for VineLinux
209
210* Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
211- rebuilt for unwind info generation, broken in gcc-4.1.1-21
212
213* Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
214- .pyo files no longer ghosted
215- fix chicken-and-egg problem when building perl and python bindings
216
217* Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
218- simplified autotools invocation
219- mass rebuild
220
221* Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
222- simplified file lists and permissions
223- removed weird character from inchi summary and description
224- added missing pkgconfig Req: for -devel
225
226* Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
227- updated to 2.0.2
228- dropped GCC4 fix (upstream'd)
229- split off inchi package
230- added python and perl bindings packages
231
232* Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
233- updated to 2.0.0
234- fix compilation with GCC4
235- FE compliance
236
237* Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
238- rebuilt for Fedora 3
239
240* Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
241- Rebuilt with libstdc++.so.6.
242
243* Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
244- 1.100.2
245
246* Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
247- removed *.la
248- don't package static library by default
249
250* Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
251- 1.100.1
252- #2994 fixed; thanks to Alex Ott (ott@) for a pointer
253- spec cleanup (underlibification fixup)
254
255* Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
256- built for ALT Linux
257- based on Mandrake Cooker spec by:
258  * Lenny Cartier <lenny@mandrakesoft.com>
259  * Austin Acton <aacton@yorku.ca>
260- spec cleanup
Note: See TracBrowser for help on using the repository browser.