source: projects/specs/trunk/o/openbabel/openbabel-vl.spec @ 10568

Revision 10568, 8.6 KB checked in by Takemikaduchi, 8 years ago (diff)

grantlee: update to 0.5.1
others: rebuils with gcc-5.4.0

Line 
1%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
3
4Name:             openbabel
5Version:          2.3.2
6Release:          5%{?_dist_release}
7Summary:          Chemistry software file format converter
8Summary(ja):      化学ソフトデータファイル変換プログラム
9License:          GPLv2
10Group:            Applications/Edutainment
11URL:              http://openbabel.sourceforge.net/
12Source:           http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
13
14# fron fedora
15Patch0:         openbabel-2.3.1-gcc47-darwin.patch
16Patch1:         openbabel-rpm.patch
17Patch2:         openbabel-2.3.2-cmake.patch
18Patch3:         openbabel-2.3.1-ruby19-vendorarch.patch
19Patch4:         openbabel-2.3.1-ruby22-remove-deprecated-usage.patch
20
21Patch10:        openbabel-2.3.2-gcc5.patch
22
23BuildRoot:        %{_tmppath}/%{name}-%{version}-root
24BuildRequires: inchi-devel
25BuildRequires: libtool
26BuildRequires: libxml2-devel
27BuildRequires: perl
28BuildRequires: python
29BuildRequires: python-devel
30BuildRequires: ruby
31BuildRequires: ruby-devel
32BuildRequires: swig
33BuildRequires: wxGTK-devel
34BuildRequires: zlib-devel
35BuildRequires: cmake
36BuildRequires: eigen2-devel
37
38Distribution:  Vine Linux
39Vendor:       Project Vine
40Packager:     inagaki
41
42%description
43Open Babel is a free, open-source version of the Babel chemistry file
44translation program. Open Babel is a project designed to pick up where
45Babel left off, as a cross-platform program and library designed to
46interconvert between many file formats used in molecular modeling,
47computational chemistry, and many related areas.
48
49Open Babel includes two components, a command-line utility and a C++
50library. The command-line utility is intended to be used as a replacement
51for the original babel program, to translate between various chemical file
52formats. The C++ library includes all of the file-translation code as well
53as a wide variety of utilities to foster development of other open source
54scientific software.
55
56%package devel
57Summary: Development tools for programs which will use the Open Babel library
58Summary(ja): %{name} の開発用ヘッダファイル
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: pkgconfig
62
63%description devel
64The %{name}-devel package includes the header files and libraries
65necessary for developing programs using the Open Babel library.
66
67If you are going to develop programs which will use this library
68you should install %{name}-devel.  You'll also need to have the
69%{name} package installed.
70
71%description devel -l ja
72%{name}の開発用ヘッダファイル
73
74%package -n perl-%{name}
75Summary: Perl wrapper for the Open Babel library
76Summary(ja): Open Babel ライブラリの Perl ラッパー
77Group: Development/Libraries
78Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
79Obsoletes: %{name}-perl < 2.2.0
80Provides: %{name}-perl = %{version}-%{release}
81
82%description -n perl-%{name}
83Perl wrapper for the Open Babel library.
84
85%description -n perl-%{name} -l ja
86Open Babel ライブラリの Perl ラッパーです.
87
88%package -n python-%{name}
89Group: Development/Libraries
90Summary: Python wrapper for the Open Babel library
91Summary(ja): Open Babel ライブラリの Python ラッパー
92Obsoletes: %{name}-python < 2.2.0
93Provides: %{name}-python = %{version}-%{release}
94
95%description -n python-%{name}
96Python wrapper for the Open Babel library.
97
98%description -n python-%{name} -l ja
99Open Babel ライブラリの Python ラッパー
100
101%package -n ruby-%{name}
102Summary: Ruby wrapper for the Open Babel library
103Summary(ja): Open Babel ライブラリの Ruby ラッパー
104Group: Development/Libraries
105Requires: ruby >= 1.8
106Requires: %{name} = %{version}-%{release}
107
108%description -n ruby-%{name}
109Open Babel ライブラリの Ruby ラッパー
110
111%prep
112%setup -q
113%patch0 -p1 -b .gcc47
114%patch1 -p1 -b .rpm
115%patch2 -p1 -b .cmake
116%patch3 -p1 -b .ruby_vendor
117%patch4 -p1 -b .rbconfig
118%patch10 -p1 -b .gcc5
119
120chmod 644 src/formats/{mmcif,fchk}format.cpp
121
122%build
123%cmake \
124        -DOPENBABEL_USE_SYSTEM_INCHI=true \
125        -DPYTHON_BINDINGS:BOOL=ON \
126        -DRUBY_BINDINGS:BOOL=ON \
127        -DPERL_BINDINGS:BOOL=ON \
128    .
129
130make %{?_smp_mflags}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134make install DESTDIR=$RPM_BUILD_ROOT
135
136rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
137
138mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
139mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
140   $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
141   $RPM_BUILD_ROOT%{_libdir}/pybel.py \
142   $RPM_BUILD_ROOT%{python_sitearch}
143
144rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
145rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
146rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
147rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root,-)
158%doc AUTHORS COPYING ChangeLog README THANKS
159%doc doc/*.html
160#doc doc/README* doc/babel*.inc doc/dioxin.*
161%doc doc/README* doc/dioxin.*
162%{_bindir}/*
163%{_mandir}/man1/*
164%{_datadir}/%{name}
165%{_libdir}/libopenbabel.so.*
166%{_libdir}/%{name}
167
168%files devel
169%defattr(-,root,root,-)
170%{_includedir}/%{name}-2.0
171%{_libdir}/libopenbabel.so
172%{_libdir}/pkgconfig/*.pc
173
174%files -n perl-%{name}
175%defattr(-,root,root,-)
176%{perl_vendorarch}/Chemistry/OpenBabel.pm
177%dir %{perl_vendorarch}/*/Chemistry/OpenBabel
178%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
179
180%files -n python-%{name}
181%defattr(-,root,root,-)
182%{python_sitearch}/_openbabel.so
183%{python_sitearch}/openbabel.py*
184%{python_sitearch}/pybel.py*
185
186%files -n ruby-%{name}
187%defattr(-,root,root,-)
188%{ruby_vendorarchdir}/openbabel.so
189
190%changelog
191* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-5
192- rebuild with gcc-5.4.0
193- add Patch10 (openbabel-2.3.2-gcc5.patch)
194
195* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-4
196- rebuild with ruby-2.2.3
197- add Patch4 (openbabel-2.3.1-ruby22-remove-deprecated-usage.patch) from fedora
198
199* Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-3
200- add BuildRequires: wxGTK-devel, eigen2-devel
201
202* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
203- rebuilt with ruby 2.1.5 and perl 5.16.3
204
205* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
206- new upstream release
207- add BuildRequires: cmake
208- add Patch0,1,2,3 from fedora
209
210* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
211- rebuilt with rpm-4.8.1 for pkg-config
212
213* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
214- rebuild with python-2.6
215
216* Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
217- <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
218
219* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
220- applied new versioning policy, spec in UTF-8
221- using system inchi package
222- added ruby-%{name} package
223
224* Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
225- Updated to 2.1.0
226
227* Tue May  1 2007  Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
228- built for VineLinux
229
230* Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
231- rebuilt for unwind info generation, broken in gcc-4.1.1-21
232
233* Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
234- .pyo files no longer ghosted
235- fix chicken-and-egg problem when building perl and python bindings
236
237* Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
238- simplified autotools invocation
239- mass rebuild
240
241* Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
242- simplified file lists and permissions
243- removed weird character from inchi summary and description
244- added missing pkgconfig Req: for -devel
245
246* Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
247- updated to 2.0.2
248- dropped GCC4 fix (upstream'd)
249- split off inchi package
250- added python and perl bindings packages
251
252* Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
253- updated to 2.0.0
254- fix compilation with GCC4
255- FE compliance
256
257* Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
258- rebuilt for Fedora 3
259
260* Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
261- Rebuilt with libstdc++.so.6.
262
263* Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
264- 1.100.2
265
266* Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
267- removed *.la
268- don't package static library by default
269
270* Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
271- 1.100.1
272- #2994 fixed; thanks to Alex Ott (ott@) for a pointer
273- spec cleanup (underlibification fixup)
274
275* Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
276- built for ALT Linux
277- based on Mandrake Cooker spec by:
278  * Lenny Cartier <lenny@mandrakesoft.com>
279  * Austin Acton <aacton@yorku.ca>
280- spec cleanup
Note: See TracBrowser for help on using the repository browser.