source: projects/specs/trunk/o/openMotif/openMotif-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The Open Motif runtime components.
2Name: openMotif
3Version: 2.3.0
4Release: 1%{?_dist_release}
5BuildRoot: %{_tmppath}/%{name}-%{version}-root
6License: The Open Group Public License
7Group: System Environment/Libraries
8Source0: ftp://ftp.ics.com/openmotif/2.3/%{version}/openmotif-%{version}.tar.gz
9Source1: xmbind
10# license at http://www.opengroup.org/openmotif/license/
11Source2: OPEN_GROUP_PUBLIC_LICENSE.html
12## not build and install demos (modified for cvs20061112)
13Patch0: openmotif-2.3.0-20061112-no_demos.patch
14## Patch1 is for CVE-2005-3964
15Patch1: openMotif-2.2.3-uil_lib.patch
16## Patch2 is for xorg7
17Patch2: openMotif-2.3.0-rgbtxt.patch
18## change mwvrc dir (modified for cvs20061112)
19Patch3: openmotif-2.3.0-20061112-mwmrc_dir.patch
20## #Patch4 is for xorg7 (modified for cvs20061112)
21Patch4: openmotif-2.3.0-20061112-bindings.patch
22Patch5: openMotif-2.3.0-no_X11R6.patch
23Patch6: openmotif-sentinel.diff
24Patch7: openmotif-unaligned.diff
25
26URL: http://www.motifzone.org/
27BuildPrereq: xorg-x11-devel xorg-x11-xbitmaps
28BuildPrereq: flex byacc automake14
29Obsoletes: %{name}-devel < 2.2.2-0vl5
30Obsoletes: %{name}-demos
31Conflicts: lesstif-clients lesstif-mwm
32
33%description
34The base package for the industry standard
35user interface toolkit for the X Window
36System as enhanced by ICS and others for
37better integration with GNOME and KDE desktop
38environments.  The base package consists of
39the Open Motif runtime components --
40shared libraries and mwm (Motif Window Manager).
41
42%package clients
43Summary: Open Motif clients
44Group: User Interface/X
45Obsoletes: lesstif-clients
46
47%description clients
48Uil and xmbind.
49
50%package devel
51Summary: The Open Motif development libraries and tools.
52Group: Development/Libraries
53PreReq: %{name} = %{version}-%{release}
54Conflicts: lesstif lesstif-devel lesstif-static
55
56%description devel
57The development package includes all of the
58Open Motif header files, archive libraries,
59the UIL (User Interface Language) compiler,
60examples and ICS enhancements for greater
61integration with GNOME and KDE desktop
62environments.
63
64%prep
65%setup -q -n openmotif-%{version}
66cp -f %{SOURCE2} .
67%patch0 -p1
68%patch1 -p1
69%patch2 -p1
70%patch3 -p1
71%patch4 -p1
72%patch5 -p1
73%patch6 -p0
74%patch7 -p0
75
76%build
77unset LANG || :
78libtoolize --force --automake
79aclocal-1.4 -I .
80autoconf
81autoheader
82automake-1.4 --foreign --include-deps --add-missing
83
84%configure  --enable-static
85
86perl -pi -e 's|hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=\"-L\\\$libdir\"|g;' libtool
87export LD_LIBRARY_PATH=`pwd`/lib/Mrm/.libs:`pwd`/lib/Xm/.libs
88make clean
89
90LANG=C make
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95export LD_LIBRARY_PATH=`pwd`/lib/Mrm/.libs:`pwd`/lib/Xm/.libs
96make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install
97
98mkdir -p $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d
99install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/xmbind.sh
100
101rm -f $RPM_BUILD_ROOT%{_bindir}/mwm
102rm -f $RPM_BUILD_ROOT%{_libdir}/X11/system.mwmrc
103rm -f $RPM_BUILD_ROOT%{_mandir}/man1/mwm.1*
104rm -f $RPM_BUILD_ROOT%{_mandir}/man4/mwmrc.4*
105rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/mwm/system.mwmrc
106
107rm $RPM_BUILD_ROOT%{_libdir}/*.la
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(-, root, root)
118%doc BUGREPORT COPYRIGHT.MOTIF LICENSE README RELEASE RELNOTES
119%doc OPEN_GROUP_PUBLIC_LICENSE.html
120%{_includedir}/X11/bitmaps/*
121%{_libdir}/lib*.so.*
122
123%files clients
124%defattr(-,root,root)
125%doc LICENSE OPEN_GROUP_PUBLIC_LICENSE.html
126%{_bindir}/uil
127%{_bindir}/xmbind
128%{_datadir}/X11/bindings
129%{_mandir}/man1/uil.*
130%{_mandir}/man1/xmbind.*
131%{_sysconfdir}/X11/xinit/xinitrc.d/xmbind.sh
132
133%files devel
134%defattr(-, root, root)
135%{_includedir}/Mrm
136%{_includedir}/Xm
137%{_includedir}/uil
138%{_libdir}/*.a
139%{_libdir}/*.so
140%{_mandir}/man3/*
141%{_mandir}/man5/*
142
143%changelog
144* Tue May 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.0-1
145- new upstream release
146- revised patches (from momonga)
147- build with xorg-x11-7.3
148- update BuildPrereq
149- change prefix to /usr
150- change mandir to %%{_mandir}
151- drop demos
152
153* Wed Aug 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
154- added Patch2 and 3 for security fix based on RHEL4
155  * Wed Mar 29 2006 Thomas Woerner <twoerner@redhat.com> 2.2.3-10.RHEL4.1
156  - fixed CVE-2005-3964: libUil buffer overflows (#174814)
157
158* Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.3-0vl5
159- fix library path on x86_64
160  - add --libdir=%%{prefix}/%%{_lib} to %%configure
161  - use %%{prefix}/%%{_lib} instead of %%{prefix}/lib
162-
163* Thu Mar 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl4
164- rebuilt
165
166* Sat Dec  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl3
167- rebuild for VineSeed
168
169* Fri Dec  3 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
170- add patch0 from Fedora Core (CAN-2004-0687-0688)
171- add patch1 from Fedora Core (CAN-2004-0914)
172- add BuildPrereq: autoconf213 automake14 for patch1
173
174* Thu Jun  3 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
175- source upgrade
176- add BuildPrereq: flex byacc
177- add %%postun -p /sbin/ldconfig
178- change configure option
179- use %%{prefix} for files section
180- sprit example code and demo programs to demos package
181- move %%{prefix}/lib/X11/bindings to main package
182- make symlink /usr/include/Mrm for %%{prefix}/include/Mrm
183- make symlink /usr/include/uil for %%{prefix}/include/uil
184- remove %%post devel and %%preun devel
185
186* Wed Apr 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.2-0vl5
187- rebuild with XOrg
188- clean up changelog to use (double-percent) everywhere
189- add BuildPrereq: build-essential XOrg-devel
190- make symlink /usr/include/Xm for %%{prefix}/include/Xm in %%install
191  (not %%post devel section)
192- add Obsoletes: %%{name}-devel < 2.2.2-0vl5
193- add PreReq: %%{name} = %%{version} to openMotif-devel package
194
195* Sat Jan  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.2-0vl4
196- delete Obsoletes: lines
197- add Conflicts: lesstif-clients lesstif-mwm to openMotif package
198- add Conflicts: lesstif(-devel, static) to openMotif-devel package
199
200* Fri Jan  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.2-0vl3
201- rebuild without lesstif package installed
202
203* Fri Jan  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.2-0vl2
204- add %%defattr(-, root, root) in %%files section
205
206* Wed Jan  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.2-0vl1
207- build for VineSeed
208- cleanup spec
209- Obsoletes: lesstif <= 0.91.0-0vl2
210
211* Wed Jan 23 2002 ICS <info@ics.om>
212- Switched build system to AutoConf and updated for new openMotif 2.2
213- widgets. 
214
215* Wed Aug 30 2000 ICS <info@ics.com> 2.1.30-3_ICS
216- Update for the Rev 3 release
217
218* Fri May 19 2000 ICS <info@ics.com> 2.1.bz2.3.bz20-2_ICS
219- Significant overhaul for SRPM distribution
Note: See TracBrowser for help on using the repository browser.