source: projects/specs/trunk/o/odfpy/odfpy-vl.spec @ 5880

Revision 5880, 3.2 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           odfpy
4Version:        0.9.2
5Release:        2%{?_dist_release}
6Summary:        Python library for manipulating OpenDocument files
7
8Group:          Development/Languages
9License:        GPLv2+
10URL:            http://forge.osor.eu/projects/odfpy/
11# This changes every time, most recent downloads are at http://forge.osor.eu/frs/?group_id=33
12Source0:        http://forge.osor.eu/frs/download.php/805/odfpy-0.9.2.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildArch:      noarch
16BuildRequires:  python-devel python-setuptools
17
18Provides:       python-odf
19
20%description
21Odfpy aims to be a complete API for OpenDocument in Python. Unlike
22other more convenient APIs, this one is essentially an abstraction
23layer just above the XML format. The main focus has been to prevent
24the programmer from creating invalid documents. It has checks that
25raise an exception if the programmer adds an invalid element, adds an
26attribute unknown to the grammar, forgets to add a required attribute
27or adds text to an element that doesn't allow it.
28 
29These checks and the API itself were generated from the RelaxNG
30schema, and then hand-edited. Therefore the API is complete and can
31handle all ODF constructions, but could be improved in its
32understanding of data types.
33
34#'
35
36%prep
37%setup -q
38
39
40%build
41CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
42
43
44%install
45%__rm -rf %{buildroot}
46%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
47%__sed -i '/#!\/usr\/bin\/python/d' %{buildroot}%{python_sitelib}/odf/*.py
48
49 
50%clean
51%__rm -rf %{buildroot}
52
53
54%files
55%defattr(-,root,root,-)
56%docdir examples
57%docdir contrib
58%{_bindir}/*
59%{_mandir}/man1/*
60%{python_sitelib}/*egg-info
61%{python_sitelib}/odf
62
63
64%changelog
65* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.2-2
66- rebuild with python-2.7.2
67
68* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.9.2-1
69- initial build based on Fedora development
70
71* Fri Jul 30 2010 Ian Weller <iweller@redhat.com> - 0.9.2-2
72- Fixed previous changelog entry
73
74* Fri Jul 30 2010 Ian Weller <iweller@redhat.com> - 0.9.2-1
75- Update to 0.9.2
76
77* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.9-3
78- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
79
80* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-2
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
82
83* Mon Apr 20 2009 Ian Weller <ianweller@gmail.com> - 0.9-1
84- Update upstream
85
86* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
88
89* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.8-2
90- Rebuild for Python 2.6
91
92* Fri Aug 22 2008 Ian Weller <ianweller@gmail.com> 0.8-1
93- Update upstream
94
95* Tue Jul 15 2008 Ian Weller <ianweller@gmail.com> 0.7-2
96- Change macros
97- Remove license file
98
99* Sun Jul 13 2008 Ian Weller <ianweller@gmail.com> 0.7-1
100- Add COPYING file
101- Use setuptools instead
102- sed out shebangs from module files
103- Other minor fixes
104
105* Sun Jul 13 2008 Paul W. Frields <stickster@gmail.com> - 0.7-0.1
106- Initial RPM package
Note: See TracBrowser for help on using the repository browser.