source: projects/specs/trunk/o/ode/ode-vl.spec @ 10768

Revision 10768, 6.6 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary:        High performance library for simulating rigid body dynamics
2Name:           ode
3Version:        0.11.1
4Release:        3%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        BSD or LGPLv2+
8URL:            http://www.ode.org
9Source0:        http://downloads.sourceforge.net/opende/ode-%{version}.tar.bz2
10# This works around a bug in rpmbuild, where with localbuilds it will pass
11# the machine being build on as host param to configure instead of the machine
12# on which the code will run
13Patch0:         ode-0.10.0-no-pentium-on-i386.patch
14Patch1:         ode-0.11.1-multilib.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires:  libGL-devel
18BuildRequires:  libGLU-devel
19
20%description
21ODE is an open source, high performance library for simulating rigid body
22dynamics. It is fully featured, stable, mature and platform independent with
23an easy to use C/C++ API. It has advanced joint types and integrated collision
24detection with friction. ODE is useful for simulating vehicles, objects in
25virtual reality environments and virtual creatures. It is currently used in
26many computer games, 3D authoring tools and simulation tools.
27
28
29%package        double
30Summary:        Ode physics library compiled with double precision
31Group:          System Environment/Libraries
32
33%description    double
34The %{name}-double package contains a version of the ODE library for simulating
35rigid body dynamics compiled with double precision.
36
37
38%package        devel
39Summary:        Development files for %{name}
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       %{name}-double = %{version}-%{release}
43
44%description    devel
45The %{name}-devel package contains libraries and header files for
46developing applications that use %{name} or %{name}-double.
47
48
49%prep
50%setup -q
51%patch0 -p1
52%patch1 -p1
53# to stop autoxxx from getting regenerated because of our configure patch
54touch -r CHANGELOG.txt configure.in
55# stop rpmlint from complaining about executable files in the debug package
56chmod -x ode/src/stepfast.cpp include/ode/collision_trimesh.h \
57  include/ode/odeconfig.h
58
59
60%build
61%configure --enable-shared --disable-static --enable-double-precision
62make %{?_smp_mflags} X_LIBS=-lX11 \
63    libode_la_LDFLAGS="-release double -version-info 2:1:1"
64sed -i 's|-lode|-lode-double|g' ode-config ode.pc
65mv ode-config ode-double-config
66mv ode.pc ode-double.pc
67mv ode/src/.libs/libode-double.so.1.1.1 .
68make distclean
69
70CFLAGS="%{optflags} -ffast-math"
71CXXFLAGS="%{optflags} -ffast-math"
72%configure --enable-shared --disable-static
73make %{?_smp_mflags} X_LIBS=-lX11
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install DESTDIR=$RPM_BUILD_ROOT
79rm $RPM_BUILD_ROOT%{_libdir}/libode.la
80# DIY libode-double install
81install -m 755 ode-double-config $RPM_BUILD_ROOT%{_bindir}
82install -m 755 libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}
83ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so.1
84ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so
85install -m 644 ode-double.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
86
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%post double -p /sbin/ldconfig
97
98%postun double -p /sbin/ldconfig
99
100
101%files
102%defattr(-,root,root,-)
103%doc CHANGELOG.txt LICENSE*.TXT README.txt
104%{_libdir}/libode.so.1*
105
106%files double
107%defattr(-,root,root,-)
108%doc CHANGELOG.txt LICENSE*.TXT README.txt
109%{_libdir}/libode-double.so.1*
110
111%files devel
112%defattr(-,root,root,-)
113%{_bindir}/%{name}-config
114%{_bindir}/%{name}-double-config
115%{_includedir}/%{name}
116%{_libdir}/libode.so
117%{_libdir}/libode-double.so
118%{_libdir}/pkgconfig/%{name}.pc
119%{_libdir}/pkgconfig/%{name}-double.pc
120
121
122%changelog
123* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 0.11.1-3
124- rebuild with gcc-5.4.0
125
126* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.11.1-2
127- rebuilt on current VineSeed
128- moved double subpackage to System Environment/Libraries Group
129
130* Fri Jan 07 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.1-1
131- initial build for Vine Linux based on fedora development
132
133* Mon Nov  8 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-5
134- Add a -double subpackage providing a version of ode compiled with
135  double precision (#574034)
136
137* Tue Feb 16 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-4
138- Fix FTBFS (#564642)
139
140* Thu Nov 12 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-3
141- Fix multilib conflict in -devel sub package (#507981)
142
143* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.1-2
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
145
146* Mon May 25 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-1
147- New upstream release 0.11.1
148
149* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
151
152* Fri Jan 30 2009 Hans de Goede <hdegoede@redhat.com> 0.11-1
153- New upstream release 0.11
154
155* Mon Sep 15 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.1-1
156- New upstream release 0.10.1 (bz 460033)
157
158* Thu Apr  3 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-4
159- Force proper use of RPM_OPT_FLAGS during build
160
161* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9-3
162- Autorebuild for GCC 4.3
163
164* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-2
165- Drop workaround for stormbaancoureur crash, it is now fixed in
166  stormbaancoureur
167
168* Fri Oct 12 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-1
169- New upstream release 0.9 (final)
170
171* Fri Sep 28 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-0.1.rc1
172- New upstream release 0.9-rc1
173
174* Tue Sep 11 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8.1-0.1.rc1
175- New upstream release 0.8.1-rc1
176
177* Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-2
178- Update License tag for new Licensing Guidelines compliance
179
180* Wed Feb 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-1
181- New upstream release 0.8
182
183* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7-2
184 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
185
186* Fri Sep 22 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.7-1
187- New upstream release 0.7
188
189* Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-3
190- FE6 Rebuild
191
192* Wed Jul  5 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-2
193- Change name from libode to ode
194- Fix soname & /usr/lib64 usage
195- Patch configure to accept our CFLAGS instead of always using its own
196- Patch configure to never activate the generation of asm-code which is then
197  used unconditionally, the build CPU may be very different from the CPU on
198  which the package gets run.
199
200* Sun Jun 18 2006 Hugo Cisneiros <hugo@devin.com.br> 0.6-1
201- Initial RPM release
Note: See TracBrowser for help on using the repository browser.