source: projects/specs/trunk/o/octave/octave-vl.spec @ 12059

Revision 12059, 10.8 KB checked in by ara_t, 5 years ago (diff)

octave: update to 5.1.0

Line 
1%define pkg_name    octave
2%define pkg_version 5.1.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:     GNU Octave -- a high-level language for numerical computations
6Summary(ja): 数値計算のための高級言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License: GPLv3
12Group:   Applications/Edutainment
13URL:     http://www.gnu.org/software/octave/
14Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: gcc-gfortran
19BuildRequires: bison flex gperf texinfo less
20BuildRequires: gnuplot
21BuildRequires: ghostscript-devel
22BuildRequires: mesa-libOSMesa-devel
23BuildRequires: blas-devel lapack-devel
24BuildRequires: pcre-devel
25BuildRequires: readline-devel
26%if %{?_dist_release} == "vl6"
27BuildRequires: arpack
28%endif
29%if %{?_dist_release} >= "vl7"
30BuildRequires: arpack-devel
31%endif
32BuildRequires: curl-devel
33BuildRequires: fftw3-devel
34BuildRequires: fontconfig-devel
35BuildRequires: freetype-devel
36BuildRequires: glpk-devel
37BuildRequires: GraphicsMagick-c++-devel
38BuildRequires: hdf5-devel
39BuildRequires: java-devel
40BuildRequires: qhull-devel
41BuildRequires: qrupdate
42BuildRequires: suitesparse-devel
43BuildRequires: zlib-devel
44BuildRequires: xz-devel
45BuildRequires: libtool-ltdl-devel
46BuildRequires: libXext-devel
47BuildRequires: openssl-devel
48BuildRequires: desktop-file-utils
49BuildRequires: freeglut-devel
50BuildRequires: fltk-devel
51BuildRequires: gl2ps-devel
52%if %{?_dist_release} == "vl6"
53BuildRequires: qt4-devel
54BuildRequires: qscintilla-devel
55%endif
56%if %{?_dist_release} >= "vl7"
57BuildRequires: qt5-qtbase-devel
58BuildRequires: qt5-qttools-devel
59%endif
60BuildRequires: portaudio-devel
61BuildRequires: libsndfile-devel
62BuildRequires: lzip
63
64Requires: ghostscript
65Requires: blas lapack
66Requires: pcre
67Requires: readline
68Requires: mesa-libOSMesa
69Requires: gnuplot
70Requires: arpack
71Requires: curl
72Requires: fftw3
73Requires: fontconfig
74Requires: freetype
75Requires: glpk
76Requires: GraphicsMagick-c++
77Requires: hdf5
78Requires: libqhull
79Requires: qrupdate
80Requires: suitesparse
81Requires: zlib
82Requires: openssl
83Requires: pstoedit epstool transfig
84Requires: freeglut
85Requires: fltk
86Requires: gl2ps
87%if %{?_dist_release} == "vl6"
88Requires: qt4
89Requires: qscintilla
90%endif
91%if %{?_dist_release} >= "vl7"
92Requires: qt5-qtbase
93Requires: qt5-qttools-libs-help
94%endif
95Requires: portaudio
96Requires: libsndfile
97
98Requires(post):   /sbin/install-info
99Requires(postun): /sbin/ldconfig
100Requires(post):   /sbin/ldconfig
101Requires(preun):  /sbin/install-info
102
103Vendor: Project Vine
104Distribution: Vine Linux
105Packager: ara_t
106
107
108%description
109GNU Octave is a high-level language, primarily intended for numerical
110computations. It provides a convenient command line interface for
111solving linear and nonlinear problems numerically, and for performing
112other numerical experiments using a language that is mostly compatible
113with Matlab. It may also be used as a batch-oriented language.
114
115Octave has extensive tools for solving common numerical linear algebra
116problems, finding the roots of nonlinear equations, integrating
117ordinary functions, manipulating polynomials, and integrating ordinary
118differential and differential-algebraic equations. It is easily
119extensible and customizable via user-defined functions written in
120Octave's own language, or using dynamically loaded modules written in
121C++, C, Fortran, or other languages.
122# '
123
124%description -l ja
125GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
126問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
127を行うための使いやすいコマンドライン・インタフェースを備えています。
128バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
129一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
130行うことができます。
131Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
132書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
133
134(注意)
135デフォルトではグラフの描画にOpenGL/fltkを使用してます。
136もし不安定な場合には、
137gnuplotをデフォルトとするために ~/.octaverc に
138graphics_toolkit("gnuplot");
139を追加してから起動して下さい。
140
141
142%prep
143%{__rm} -rf ${RPM_BUILD_ROOT}
144%setup -q
145
146%build
147%{configure} \
148 CPPFLAGS="-I%{_includedir}/pcre" \
149 --with-x \
150 --with-magick=GraphicsMagick \
151 --with-curl-includedir=%{_includedir}/curl \
152 --with-glpk-includedir=%{_includedir}/glpk \
153 --with-qhull-includedir=%{_includedir}/libqhull \
154 --with-amd-includedir=%{_includedir}/suitesparse \
155 --with-camd-includedir=%{_includedir}/suitesparse \
156 --with-colamd-includedir=%{_includedir}/suitesparse \
157 --with-ccolamd-includedir=%{_includedir}/suitesparse \
158 --with-cholmod-includedir=%{_includedir}/suitesparse \
159 --with-cxsparse-includedir=%{_includedir}/suitesparse \
160 --with-umfpack-includedir=%{_includedir}/suitesparse \
161 --enable-java \
162 --with-qt=5
163
164%{__make} %{?_smp_mflags}
165
166
167%install
168%{make_install}
169
170find %{buildroot} -name "*.oct" | xargs strip
171
172# Make library links
173%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
174echo "%{_libdir}/octave-%{version}" > \
175     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
176
177# desktop file
178%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
179 ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
180
181%check
182%{__make} %{?_smp_mflags} check
183
184%clean
185%{__rm} -rf ${RPM_BUILD_ROOT}
186
187
188%post -p %{_syssbindir}/ldconfig
189
190%postun -p %{_syssbindir}/ldconfig
191
192
193%files
194%defattr(-,root,root)
195%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
196%doc examples doc/interpreter/octave.pdf doc/refcard
197%config(noreplace) /etc/ld.so.conf.d/
198%{_bindir}/
199%{_libdir}/octave
200%{_libdir}/pkgconfig/*.pc
201%{_includedir}/octave-%{version}
202%{_datadir}/applications/
203%{_datadir}/icons/
204%{_datadir}/metainfo/
205%{_datadir}/octave
206%{_libexecdir}/octave
207
208
209%changelog
210* Sun Apr 21 2019 Toshiaki Ara <ara_t@384.jp> 5.1.0-1
211- update to 5.1.0
212- drop gui/sound option
213
214* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 4.4.1-3
215- rebuild with gfortran-8.2.0
216
217* Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-2
218- rebuild with qhull-2015.2
219
220* Thu Aug 30 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-1
221- update to 4.4.1
222
223* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-4
224- using qt5 for VineSeed
225  - add configure option: --with-qt=5
226  - add BuildRequires: qt5-qtbase-devel and qt5-qttools-devel
227  - add Requires: qt5-qtbase and qt5-qttools-libs-help
228
229* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-3
230- rebuild with hdf5-1.8.20 for VineSeed
231
232* Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-2
233- add BuildRequires: arpack-devel for VineSeed
234
235* Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
236- update to 4.4.0
237- correct License
238
239* Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
240- update to 4.2.2
241
242* Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
243- rebuild under glpk-4.63
244
245* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
246- update to 4.2.1
247
248* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
249- update to 4.2.0
250- add make check
251- add BuildRequires: lzip
252- change BuildRequires: java-devel
253
254* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
255- update to 4.0.3
256- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
257
258* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
259- update to 4.0.2
260- add BuildRequires: openssl-devel
261- add Requires: openssl
262
263* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
264- update to 4.0.1
265- change dependencies
266
267* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
268- [BTS:0002801] add configure option --with-magick=Magick
269- delete BuildRequires: texlive-collection-texinfo
270- add BuildRequires: texlive-collection-plainextra
271- add BuildRequires: texlive-collection-latexextra
272- add BuildRequires: texlive-collection-fontsrecommended
273-   for VineSeed
274
275* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
276- update to 3.6.4
277- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
278
279* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
280- delete octave from menu (programming)
281
282* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
283- update to 3.6.2
284- correct spec file for version 3.6.2
285- add BuildRequires: pcre-devel fltk-devel
286- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
287- add BuildRequires: gcc-gfortran
288- add BuildRequires: texlive texlive-common texlive-collection-basic
289- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
290- chanfe Group to Applications/Edutainment
291
292* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
293- update to 3.0.2
294- applied new versioning policy, spec in utf-8
295
296* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
297- update to 3.0.0
298
299* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
300- rebuilt for VineSeed
301
302* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
303- update to 2.9.13
304- rebuilt with new toolchain and environment
305
306* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
307- update to 2.0.17
308- rebuild with new toolchains
309- add BuildRequires: gcc295, gcc295-c++
310
311* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
312- ver.up
313
314* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
315- build for Vine Linux 2.1
316
317* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
318- automatically added BuildRequires
319
320* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
321- Macros, BM, add multiple icons sizes
322
323* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
324- strip oct file
325- add menu entry
326 
327* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
328- corrected for new groups
329
330* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
331- mandrake build
332- v2.0.16
333
334* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
335- update to 2.0.13.90
336
337* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
338- repackage in powertools.
339
340* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
341- Add %attr, build as user.
342
343* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
344- Add BuildRoot, installinfo, require gnuplot, description from
345  Octave's web page, update to Octave 2.0.13.
346- Adapt from existing spec file.
347
348* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
349- removed libreadline stuff from the file list
350
351* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
352- changed configure command to put things in $RPM_ARCH-rehat-linux,
353  rather than genereated one... was causing problems between building
354  on i686 build machine.
355
356* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
357- moved buildroot from /tmp to /var/tmp
358
359* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
360- Upgraded to version 2.0.9 and built for glibc system
361
362* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
363- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.