source: projects/specs/trunk/o/octave/octave-vl.spec @ 11600

Revision 11600, 10.8 KB checked in by ara_t, 6 years ago (diff)

octave: update to 4.2.2

Line 
1%define pkg_name    octave
2%define pkg_version 4.2.2
3%define pkg_release 1%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8# %if %{?_dist_release} == "vl6"
9# %define openjdk_ver 1.6.0
10# %endif
11# %if %{?_dist_release} >= "vl7"
12# %define openjdk_ver 1.8.0
13# %endif
14
15
16Summary:     GNU Octave -- a high-level language for numerical computations
17Summary(ja): 数値計算のための高級言語
18Name:        %{pkg_name}
19Version:     %{pkg_version}
20Release:     %{pkg_release}
21
22License: GPL
23Group:   Applications/Edutainment
24URL:     http://www.gnu.org/software/octave/
25# Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.gz
26Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29
30BuildRequires: gcc-gfortran
31BuildRequires: bison flex gperf texinfo less
32BuildRequires: gnuplot
33BuildRequires: ghostscript-devel
34BuildRequires: mesa-libOSMesa-devel
35BuildRequires: blas-devel lapack-devel
36BuildRequires: pcre-devel
37BuildRequires: readline-devel
38BuildRequires: arpack
39BuildRequires: curl-devel
40BuildRequires: fftw3-devel
41BuildRequires: fontconfig-devel
42BuildRequires: freetype-devel
43BuildRequires: glpk-devel
44BuildRequires: GraphicsMagick-c++-devel
45BuildRequires: hdf5-devel
46# BuildRequires: java-%{openjdk_ver}-openjdk-devel
47BuildRequires: java-devel
48BuildRequires: qhull-devel
49BuildRequires: qrupdate
50BuildRequires: suitesparse-devel
51BuildRequires: zlib-devel
52BuildRequires: xz-devel
53BuildRequires: libtool-ltdl-devel
54BuildRequires: libXext-devel
55BuildRequires: openssl-devel
56%if %{gui}
57BuildRequires: desktop-file-utils
58BuildRequires: freeglut-devel
59BuildRequires: fltk-devel
60BuildRequires: gl2ps-devel
61BuildRequires: qt4-devel
62BuildRequires: qscintilla-devel
63%endif
64%if %{sound}
65BuildRequires: portaudio-devel
66BuildRequires: libsndfile-devel
67%endif
68BuildRequires: lzip
69
70Requires: ghostscript
71Requires: blas lapack
72Requires: pcre
73Requires: readline
74Requires: mesa-libOSMesa
75Requires: gnuplot
76Requires: arpack
77Requires: curl
78Requires: fftw3
79Requires: fontconfig
80Requires: freetype
81Requires: glpk
82Requires: GraphicsMagick-c++
83Requires: hdf5
84Requires: qhull
85Requires: qrupdate
86Requires: suitesparse
87Requires: zlib
88Requires: openssl
89Requires: pstoedit epstool transfig
90%if %{gui}
91Requires: freeglut
92Requires: fltk
93Requires: gl2ps
94Requires: qt4
95Requires: qscintilla
96%endif
97%if %{sound}
98Requires: portaudio
99Requires: libsndfile
100%endif
101
102Requires(post):   /sbin/install-info
103Requires(postun): /sbin/ldconfig
104Requires(post):   /sbin/ldconfig
105Requires(preun):  /sbin/install-info
106
107Vendor: Project Vine
108Distribution: Vine Linux
109Packager: ara_t
110
111
112%description
113GNU Octave is a high-level language, primarily intended for numerical
114computations. It provides a convenient command line interface for
115solving linear and nonlinear problems numerically, and for performing
116other numerical experiments using a language that is mostly compatible
117with Matlab. It may also be used as a batch-oriented language.
118
119Octave has extensive tools for solving common numerical linear algebra
120problems, finding the roots of nonlinear equations, integrating
121ordinary functions, manipulating polynomials, and integrating ordinary
122differential and differential-algebraic equations. It is easily
123extensible and customizable via user-defined functions written in
124Octave's own language, or using dynamically loaded modules written in
125C++, C, Fortran, or other languages.
126# '
127
128%description -l ja
129GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
130問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
131を行うための使いやすいコマンドライン・インタフェースを備えています。
132バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
133一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
134行うことができます。
135Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
136書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
137
138%if %{gui}
139(注意)
140デフォルトではグラフの描画にOpenGL/fltkを使用してます。
141もし不安定な場合には、
142gnuplotをデフォルトとするために ~/.octaverc に
143graphics_toolkit("gnuplot");
144を追加してから起動して下さい。
145%endif
146
147
148%prep
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
151
152%build
153%{configure} \
154 CPPFLAGS="-I%{_includedir}/pcre" \
155 --with-x \
156 --with-magick=GraphicsMagick \
157 --with-curl-includedir=%{_includedir}/curl \
158 --with-glpk-includedir=%{_includedir}/glpk \
159 --with-qhull-includedir=%{_includedir}/qhull \
160 --with-amd-includedir=%{_includedir}/suitesparse \
161 --with-camd-includedir=%{_includedir}/suitesparse \
162 --with-colamd-includedir=%{_includedir}/suitesparse \
163 --with-ccolamd-includedir=%{_includedir}/suitesparse \
164 --with-cholmod-includedir=%{_includedir}/suitesparse \
165 --with-cxsparse-includedir=%{_includedir}/suitesparse \
166 --with-umfpack-includedir=%{_includedir}/suitesparse \
167 --enable-java \
168%if !%{gui}
169 --disable-gui \
170 --without-opengl \
171 --without-fltk \
172%endif
173%if !%{sound}
174 --without-sndfile --without-portaudio \
175%endif
176
177%{__make} %{?_smp_mflags}
178
179%install
180%{make_install}
181%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
182
183find %{buildroot} -name "*.oct" | xargs strip
184
185# Make library links
186%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
187echo "%{_libdir}/octave-%{version}" > \
188     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
189
190%if %{gui}
191# Create desktop file
192%{__mv} \
193 ${RPM_BUILD_ROOT}%{_datadir}/applications/www.octave.org-octave.desktop \
194 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
195%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
196 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
197%endif
198
199# rename %{_datadir}/appdata/*
200%{__mv} \
201 ${RPM_BUILD_ROOT}%{_datadir}/appdata/www.octave.org-octave.appdata.xml \
202 ${RPM_BUILD_ROOT}%{_datadir}/appdata/octave.appdata.xml
203
204%check
205%{__make} %{?_smp_mflags} check
206
207%clean
208%{__rm} -rf ${RPM_BUILD_ROOT}
209
210%post
211%{_syssbindir}/ldconfig
212/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
213                   %{_infodir}/octave.info.gz || :
214
215%preun
216if [ "$1" = "0" ]; then
217    /sbin/install-info --delete --info-dir=%{_infodir} \
218                       %{_infodir}/octave.info.gz || :
219fi
220
221%postun -p %{_syssbindir}/ldconfig
222
223
224%files
225%defattr(-,root,root)
226%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
227%doc examples doc/interpreter/octave.p* doc/refcard
228%config(noreplace) /etc/ld.so.conf.d/
229%{_bindir}/
230%{_libdir}/octave
231%{_includedir}/octave-%{version}
232%{_datadir}/appdata/
233%if %{gui}
234%{_datadir}/applications/
235%endif
236%{_datadir}/icons/
237%{_datadir}/octave
238%{_libexecdir}/octave
239%{_mandir}/man*/*
240%{_infodir}/octave*
241%{_infodir}/liboctave.info*
242
243
244%changelog
245* Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
246- update to 4.2.2
247
248* Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
249- rebuild under glpk-4.63
250
251* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
252- update to 4.2.1
253
254* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
255- update to 4.2.0
256- add make check
257- add BuildRequires: lzip
258- change BuildRequires: java-devel
259
260* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
261- update to 4.0.3
262- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
263
264* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
265- update to 4.0.2
266- add BuildRequires: openssl-devel
267- add Requires: openssl
268
269* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
270- update to 4.0.1
271- change dependencies
272
273* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
274- [BTS:0002801] add configure option --with-magick=Magick
275- delete BuildRequires: texlive-collection-texinfo
276- add BuildRequires: texlive-collection-plainextra
277- add BuildRequires: texlive-collection-latexextra
278- add BuildRequires: texlive-collection-fontsrecommended
279-   for VineSeed
280
281* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
282- update to 3.6.4
283- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
284
285* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
286- delete octave from menu (programming)
287
288* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
289- update to 3.6.2
290- correct spec file for version 3.6.2
291- add BuildRequires: pcre-devel fltk-devel
292- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
293- add BuildRequires: gcc-gfortran
294- add BuildRequires: texlive texlive-common texlive-collection-basic
295- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
296- chanfe Group to Applications/Edutainment
297
298* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
299- update to 3.0.2
300- applied new versioning policy, spec in utf-8
301
302* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
303- update to 3.0.0
304
305* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
306- rebuilt for VineSeed
307
308* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
309- update to 2.9.13
310- rebuilt with new toolchain and environment
311
312* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
313- update to 2.0.17
314- rebuild with new toolchains
315- add BuildRequires: gcc295, gcc295-c++
316
317* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
318- ver.up
319
320* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
321- build for Vine Linux 2.1
322
323* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
324- automatically added BuildRequires
325
326* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
327- Macros, BM, add multiple icons sizes
328
329* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
330- strip oct file
331- add menu entry
332 
333* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
334- corrected for new groups
335
336* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
337- mandrake build
338- v2.0.16
339
340* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
341- update to 2.0.13.90
342
343* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
344- repackage in powertools.
345
346* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
347- Add %attr, build as user.
348
349* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
350- Add BuildRoot, installinfo, require gnuplot, description from
351  Octave's web page, update to Octave 2.0.13.
352- Adapt from existing spec file.
353
354* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
355- removed libreadline stuff from the file list
356
357* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
358- changed configure command to put things in $RPM_ARCH-rehat-linux,
359  rather than genereated one... was causing problems between building
360  on i686 build machine.
361
362* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
363- moved buildroot from /tmp to /var/tmp
364
365* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
366- Upgraded to version 2.0.9 and built for glibc system
367
368* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
369- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.