source: projects/specs/trunk/o/octave/octave-vl.spec @ 10923

Revision 10923, 10.6 KB checked in by ara_t, 7 years ago (diff)

octave: update to 4.2.1

RevLine 
[10184]1%define pkg_name    octave
[10923]2%define pkg_version 4.2.1
[10184]3%define pkg_release 1%{?_dist_release}
[521]4
[10184]5%define gui   1
6%define sound 1
[521]7
[10822]8# %if %{?_dist_release} == "vl6"
9# %define openjdk_ver 1.6.0
10# %endif
11# %if %{?_dist_release} >= "vl7"
12# %define openjdk_ver 1.8.0
13# %endif
[521]14
[10184]15
16Summary:     GNU Octave -- a high-level language for numerical computations
[521]17Summary(ja): 数値計算のための高級言語
[10184]18Name:        %{pkg_name}
19Version:     %{pkg_version}
20Release:     %{pkg_release}
21
[521]22License: GPL
[10184]23Group:   Applications/Edutainment
24URL:     http://www.gnu.org/software/octave/
[10822]25# Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.gz
26Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
[521]27
[10184]28Buildroot: %{_tmppath}/%{name}-%{version}-root
29
30BuildRequires: gcc-gfortran
31BuildRequires: bison flex gperf texinfo less
32BuildRequires: gnuplot
33BuildRequires: ghostscript-devel
34BuildRequires: mesa-libOSMesa-devel
35BuildRequires: blas-devel lapack-devel
36BuildRequires: pcre-devel
37BuildRequires: readline-devel
38BuildRequires: arpack
39BuildRequires: curl-devel
40BuildRequires: fftw3-devel
41BuildRequires: fontconfig-devel
42BuildRequires: freetype-devel
43BuildRequires: glpk-devel
44BuildRequires: GraphicsMagick-c++-devel
45BuildRequires: hdf5-devel
[10822]46# BuildRequires: java-%{openjdk_ver}-openjdk-devel
47BuildRequires: java-devel
[10184]48BuildRequires: qhull-devel
49BuildRequires: qrupdate
50BuildRequires: suitesparse-devel
51BuildRequires: zlib-devel
52BuildRequires: xz-devel
53BuildRequires: libtool-ltdl-devel
54BuildRequires: libXext-devel
[10279]55BuildRequires: openssl-devel
[10184]56%if %{gui}
57BuildRequires: desktop-file-utils
58BuildRequires: freeglut-devel
59BuildRequires: fltk-devel
60BuildRequires: gl2ps-devel
61BuildRequires: qt4-devel
62BuildRequires: qscintilla-devel
[521]63%endif
[10184]64%if %{sound}
65BuildRequires: portaudio-devel
66BuildRequires: libsndfile-devel
67%endif
[10822]68BuildRequires: lzip
[521]69
[10184]70Requires: ghostscript
71Requires: blas lapack
72Requires: pcre
73Requires: readline
74Requires: mesa-libOSMesa
75Requires: gnuplot
76Requires: arpack
77Requires: curl
78Requires: fftw3
79Requires: fontconfig
80Requires: freetype
81Requires: glpk
82Requires: GraphicsMagick-c++
83Requires: hdf5
84Requires: qhull
85Requires: qrupdate
86Requires: suitesparse
87Requires: zlib
[10279]88Requires: openssl
[10184]89Requires: pstoedit epstool transfig
90%if %{gui}
91Requires: freeglut
92Requires: fltk
93Requires: gl2ps
94Requires: qt4
95Requires: qscintilla
96%endif
97%if %{sound}
98Requires: portaudio
99Requires: libsndfile
100%endif
101
102Requires(post):   /sbin/install-info
[521]103Requires(postun): /sbin/ldconfig
[10184]104Requires(post):   /sbin/ldconfig
105Requires(preun):  /sbin/install-info
[521]106
107Vendor: Project Vine
108Distribution: Vine Linux
[10184]109Packager: ara_t
[521]110
[10184]111
[521]112%description
113GNU Octave is a high-level language, primarily intended for numerical
114computations. It provides a convenient command line interface for
115solving linear and nonlinear problems numerically, and for performing
116other numerical experiments using a language that is mostly compatible
117with Matlab. It may also be used as a batch-oriented language.
118
119Octave has extensive tools for solving common numerical linear algebra
120problems, finding the roots of nonlinear equations, integrating
121ordinary functions, manipulating polynomials, and integrating ordinary
122differential and differential-algebraic equations. It is easily
123extensible and customizable via user-defined functions written in
124Octave's own language, or using dynamically loaded modules written in
125C++, C, Fortran, or other languages.
[10184]126# '
[521]127
128%description -l ja
129GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
130問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
131を行うための使いやすいコマンドライン・インタフェースを備えています。
132バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
[10184]133一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
134行うことができます。
135Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
136書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
[521]137
[10184]138%if %{gui}
139(注意)
140デフォルトではグラフの描画にOpenGL/fltkを使用してます。
141もし不安定な場合には、
142gnuplotをデフォルトとするために ~/.octaverc に
143graphics_toolkit("gnuplot");
144を追加してから起動して下さい。
145%endif
146
147
[521]148%prep
[10184]149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
[521]151
152%build
[10184]153%{configure} \
154 CPPFLAGS="-I%{_includedir}/pcre" \
155 --with-x \
156 --with-magick=GraphicsMagick \
157 --with-curl-includedir=%{_includedir}/curl \
158 --with-glpk-includedir=%{_includedir}/glpk \
159 --with-qhull-includedir=%{_includedir}/qhull \
160 --with-amd-includedir=%{_includedir}/suitesparse \
161 --with-camd-includedir=%{_includedir}/suitesparse \
162 --with-colamd-includedir=%{_includedir}/suitesparse \
163 --with-ccolamd-includedir=%{_includedir}/suitesparse \
164 --with-cholmod-includedir=%{_includedir}/suitesparse \
165 --with-cxsparse-includedir=%{_includedir}/suitesparse \
166 --with-umfpack-includedir=%{_includedir}/suitesparse \
167 --enable-java \
168%if !%{gui}
169 --disable-gui \
170 --without-opengl \
171 --without-fltk \
[521]172%endif
[10184]173%if !%{sound}
174 --without-sndfile --without-portaudio \
175%endif
[521]176
[10184]177%{__make} %{?_smp_mflags}
[521]178
179%install
[10184]180%{make_install}
181%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
[521]182
183find %{buildroot} -name "*.oct" | xargs strip
184
185# Make library links
[10184]186%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
187echo "%{_libdir}/octave-%{version}" > \
188     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
[521]189
[10184]190%if %{gui}
[521]191# Create desktop file
[10184]192%{__mv} \
193 ${RPM_BUILD_ROOT}%{_datadir}/applications/www.octave.org-octave.desktop \
194 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
195%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
196 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
197%endif
[521]198
[10184]199# rename %{_datadir}/appdata/*
200%{__mv} \
201 ${RPM_BUILD_ROOT}%{_datadir}/appdata/www.octave.org-octave.appdata.xml \
202 ${RPM_BUILD_ROOT}%{_datadir}/appdata/octave.appdata.xml
[521]203
[10822]204%check
205%{__make} %{?_smp_mflags} check
206
[521]207%clean
[10184]208%{__rm} -rf ${RPM_BUILD_ROOT}
[521]209
210%post
[10184]211%{_syssbindir}/ldconfig
[521]212/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
[10279]213                   %{_infodir}/octave.info.gz || :
[521]214
215%preun
216if [ "$1" = "0" ]; then
[10279]217    /sbin/install-info --delete --info-dir=%{_infodir} \
218                       %{_infodir}/octave.info.gz || :
[521]219fi
220
[10184]221%postun -p %{_syssbindir}/ldconfig
[521]222
[10184]223
[521]224%files
225%defattr(-,root,root)
[10184]226%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
227%doc examples doc/interpreter/octave.p* doc/refcard
228%config(noreplace) /etc/ld.so.conf.d/
229%{_bindir}/
230%{_libdir}/octave
[521]231%{_includedir}/octave-%{version}
[10184]232%{_datadir}/appdata/
233%if %{gui}
234%{_datadir}/applications/
235%endif
236%{_datadir}/icons/
[521]237%{_datadir}/octave
238%{_libexecdir}/octave
239%{_mandir}/man*/*
240%{_infodir}/octave*
[10184]241%{_infodir}/liboctave.info*
[521]242
[10184]243
[521]244%changelog
[10923]245* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
246- update to 4.2.1
247
[10822]248* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
249- update to 4.2.0
250- add make check
251- add BuildRequires: lzip
252- change BuildRequires: java-devel
253
[10637]254* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
255- update to 4.0.3
256- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
257
[10279]258* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
259- update to 4.0.2
260- add BuildRequires: openssl-devel
261- add Requires: openssl
262
[10184]263* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
264- update to 4.0.1
265- change dependencies
266
267* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
268- [BTS:0002801] add configure option --with-magick=Magick
269- delete BuildRequires: texlive-collection-texinfo
270- add BuildRequires: texlive-collection-plainextra
271- add BuildRequires: texlive-collection-latexextra
272- add BuildRequires: texlive-collection-fontsrecommended
273-   for VineSeed
274
275* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
276- update to 3.6.4
277- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
278
279* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
280- delete octave from menu (programming)
281
282* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
283- update to 3.6.2
284- correct spec file for version 3.6.2
285- add BuildRequires: pcre-devel fltk-devel
286- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
287- add BuildRequires: gcc-gfortran
288- add BuildRequires: texlive texlive-common texlive-collection-basic
289- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
290- chanfe Group to Applications/Edutainment
291
[521]292* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
293- update to 3.0.2
294- applied new versioning policy, spec in utf-8
295
296* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
297- update to 3.0.0
298
299* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
300- rebuilt for VineSeed
301
302* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
303- update to 2.9.13
304- rebuilt with new toolchain and environment
305
306* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
307- update to 2.0.17
308- rebuild with new toolchains
309- add BuildRequires: gcc295, gcc295-c++
310
311* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
312- ver.up
313
314* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
315- build for Vine Linux 2.1
316
317* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
318- automatically added BuildRequires
319
320* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
321- Macros, BM, add multiple icons sizes
322
323* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
324- strip oct file
325- add menu entry
326 
327* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
328- corrected for new groups
329
330* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
331- mandrake build
332- v2.0.16
333
334* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
335- update to 2.0.13.90
336
337* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
338- repackage in powertools.
339
340* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
341- Add %attr, build as user.
342
343* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
344- Add BuildRoot, installinfo, require gnuplot, description from
345  Octave's web page, update to Octave 2.0.13.
346- Adapt from existing spec file.
347
348* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
349- removed libreadline stuff from the file list
350
351* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
352- changed configure command to put things in $RPM_ARCH-rehat-linux,
353  rather than genereated one... was causing problems between building
354  on i686 build machine.
355
356* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
357- moved buildroot from /tmp to /var/tmp
358
359* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
360- Upgraded to version 2.0.9 and built for glibc system
361
362* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
363- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.