source: projects/specs/trunk/o/ocaml/ocaml-vl.spec @ 3717

Revision 3717, 10.0 KB checked in by inagaki, 13 years ago (diff)

update: ocaml, facile

Line 
1Name: ocaml
2Summary: The Objective Caml compiler and programming environment
3Summary(ja): Objective Caml コンパイラとプログラミング環境
4Version: 3.12.0
5Release: 1%{?_dist_release}
6Source0: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-%{version}.tar.bz2
7Source1: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.html.tar.gz
8Source2: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.ps.gz
9Source3: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.info.tar.gz
10Source4: ocaml-info-entry
11
12# Vine Source(s)
13Source10: caml-mode-install.sh
14Source11: caml-mode-remove.sh
15
16License: QPL/LGPL
17Group: Development/Languages
18URL: http://caml.inria.fr/
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: ncurses-devel gdbm-devel emacsen
22BuildRequires: libX11-devel
23BuildRequires: tk tcl expect thread
24Requires(post): install-info
25Requires(preun): install-info
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30Packager: inagaki
31
32%define debug_package %{nil}
33
34%description
35Objective Caml is a high-level, strongly-typed, functional and
36object-oriented programming language from the ML family of languages.
37
38This package comprises two batch compilers (a fast bytecode compiler
39and an optimizing native-code compiler), an interactive toplevel system,
40parsing tools (Lex,Yacc,Camlp4), a replay debugger, a documentation generator,
41and a comprehensive library.
42
43%description -l ja
44Object Caml は ML 系言語の方言で、高水準で強い型付けを備えた関数型と
45オブジェクト指向を併せ持ったプログラミング言語です。
46このパッケージには、2 つのバッチコンパイラ (コンパイル速度が高速な
47バイトコードコンパイラと最適化を行なうネイティブコードコンパイラ)、
48トップレベル対話環境、構文解析ツール (Lex, Yac, Camlp4)、リプレイ
49デバッガ、ドキュメント生成ツール、そして広範囲に渡るライブラリが含まれて
50います。
51
52%package labltk
53Summary: Tk bindings for Objective Caml
54Summary(ja): Objective Caml の Tk バインディング
55Group: Development/Languages
56Requires: ocaml = %{version}-%{release}
57Requires: tk tcl
58Obsoletes: labltk <= %{version}
59
60%description labltk
61A library for interfacing Objective Caml with the scripting language
62Tcl/Tk. It include the OCamlBrowser code editor / library browser.
63
64%package camlp4
65Summary: Pre-Processor-Pretty-Printer for OCaml
66Group: Development/Languages
67Requires: ocaml = %{version}-%{release}
68Obsoletes: camlp4 <= %{version}
69
70%description camlp4
71Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
72file and printing some result on standard output.
73
74%package mode
75Summary: Emacs mode for Objective Caml
76Summary(ja): Objective Caml の Emacs mode
77Group: Applications/Editors/Emacs
78Requires: ocaml = %{version}-%{release}
79Requires(post): emacs, emacsen-common
80Requires(preun): emacs, emacsen-common
81Obsoletes: ocaml-emacs <= %{version}
82
83%description mode
84Emacs mode for Objective Caml.
85
86%description -l ja mode
87Objective Caml 用の Emacs mode です.
88
89
90%prep
91%setup -q -T -b 0
92%setup -q -T -D -a 1
93%setup -q -T -D -a 3
94cp %{SOURCE2} refman.ps.gz
95cp %{SOURCE4} infoman/ocaml-info-entry
96
97%build
98./configure -cc "%{__cc} %{optflags}" -with-pthread \
99    -bindir %{_bindir} \
100    -libdir %{_libdir}/ocaml \
101    -mandir %{_mandir} \
102    -prefix %{_prefix}
103make world opt opt.opt
104(cd infoman; gzip -cd ocaml.info.gz >> ocaml-info-entry; mv ocaml-info-entry  ocaml.info; gzip -f ocaml.info)
105# for dumpobj, objinfo
106(cd tools; make dumpobj; make objinfo; cd ..)
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111make install BINDIR=$RPM_BUILD_ROOT%{_bindir} LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml MANDIR=$RPM_BUILD_ROOT%{_mandir}
112
113mv $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
114sed -e "s|^%{buildroot}||" $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig > $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf
115rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
116(mkdir -p $RPM_BUILD_ROOT%{_infodir}; cd infoman; cp ocaml*.gz $RPM_BUILD_ROOT%{_infodir})
117# for dumpobj, objinfo
118(cd tools; install dumpobj objinfo $RPM_BUILD_ROOT%{_bindir})
119
120# for Emacs Lisp
121make -C emacs install install-ocamltags BINDIR=$RPM_BUILD_ROOT%{_bindir} \
122    EMACSDIR=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/caml-mode
123
124# emacsen-common-ize
125mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/install
126mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/remove
127%_installemacsenscript caml-mode %{SOURCE10}
128
129%_removeemacsenscript  caml-mode %{SOURCE11}
130
131
132# Disable build root strip policy:
133# executables generated by ocamlc -custom MUST NOT BE STRIPPED
134# But now that we have dynamic loading of C code, none of the executables
135# in the distribution is generated by ocamlc -custom, so leave default.
136# %define __spec_install_post /usr/lib/rpm/brp-compress
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post
142/sbin/install-info %{_infodir}/ocaml.info %{_infodir}/dir
143
144%post mode
145if [ "$1" = 2 ]; then
146    %_emacsenPackageRemove caml-mode
147
148fi
149
150%_addemacsenlist caml-mode
151
152%_emacsenPackageInstall caml-mode
153
154%preun
155if [ $1 = 0 ]; then
156    /sbin/install-info --delete %{_infodir}/ocaml.info %{_infodir}/dir
157fi
158
159%preun mode
160if [ "$1" = 0 ]; then
161    %_emacsenPackageRemove caml-mode
162   
163    %_removeemacsenlist caml-mode
164
165fi
166
167
168%files
169%defattr(-, root, root)
170%doc README LICENSE refman.ps.gz htmlman
171%{_bindir}/*
172%{_mandir}/man1/*
173%{_mandir}/man3/*
174%{_libdir}/ocaml
175%{_infodir}/*
176### in ocaml-camlp4
177%exclude %{_bindir}/camlp4*
178%exclude %{_bindir}/mkcamlp4
179%exclude %{_libdir}/ocaml/camlp4/
180### in ocaml-labltk
181%exclude %{_bindir}/labltk
182%exclude %{_bindir}/ocamlbrowser
183%exclude %{_libdir}/ocaml/labltk/
184%exclude %{_libdir}/ocaml/stublibs/dlllabltk.so
185### in ocaml-mode
186%exclude %{_bindir}/ocamltags
187
188%files camlp4
189%defattr(-, root, root, 0755)
190%{_bindir}/camlp4*
191%{_bindir}/mkcamlp4
192%dir %{_libdir}/ocaml/
193%{_libdir}/ocaml/camlp4/
194
195%files labltk
196%defattr(-, root, root, 0755)
197%doc otherlibs/labltk/examples_*tk
198%{_bindir}/labltk
199%{_bindir}/ocamlbrowser
200%dir %{_libdir}/ocaml/
201%dir %{_libdir}/ocaml/stublibs/
202%{_libdir}/ocaml/labltk/
203%{_libdir}/ocaml/stublibs/dlllabltk.so
204
205%files mode
206%defattr(-, root, root, 0755)
207%doc emacs/README
208%{_bindir}/ocamltags
209%dir %{_datadir}/emacs/
210%dir %{_datadir}/emacs/site-lisp/caml-mode
211%{_datadir}/emacs/site-lisp/caml-mode/*.el
212#{_datadir}/emacs/site-lisp/caml-mode/*.elc
213%{_prefix}/lib/emacsen-common/packages/install/caml-mode
214%{_prefix}/lib/emacsen-common/packages/remove/caml-mode
215
216
217%changelog
218* Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.12.0-1
219- new upstream release
220
221* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.0-2
222- rebuilt with new tool chain
223
224* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.0-1
225- new upstream release
226- spec in UTF-8
227
228* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl5
229- new upstream release for VineSeed
230
231* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl4
232- new upstream release
233
234* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.1-0vl1
235- new upstream release
236
237* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl2
238- rebuilt with VineSeed
239
240* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl1
241- new upstream release
242
243* Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl2
244- rebuilt for VinePlus/4.0
245
246* Mon Nov 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl1
247- new upstream release
248
249* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.2-0vl4
250- changed ocaml-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
251
252* Wed Aug 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> - 3.09.2-0vl3
253- add BuildRequires: XOrg-devel, ncurses-devel, gdbm-devel, emacsen
254- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
255
256* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl2
257- rebuilt for VineSeed Plus
258
259* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl1
260- new upstream release
261
262* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl3
263- rebuilt for VineSeed Plus
264
265* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl2
266- rebuilt for VinePlus/3.0
267- added BuildRequires: expect, thread
268
269* Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl1
270- new upstream release
271
272* Sat Nov  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl2
273- rebuild for VineSeed Plus
274
275* Thu Nov  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl1
276- new upstream release
277
278* Tue Oct 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl3
279- rebuild with VineSeed Plus
280
281* Mon Oct 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl2
282- rebuild with VinePlus/3.0
283- added dumpobj, objinfo
284
285* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl1
286- new upstream release
287- split to caml4p, labltk, mode packages
288
289* Thu Mar 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.3-0vl1
290- new upstream release
291
292* Sat Dec  4 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.2-0vl1
293- new upstream release
294
295* Fri Oct 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.1-0vl1
296- new upstream release
297
298* Fri Aug 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl4
299- fixed typo based on 3.08.0-0vl3
300  * Thu Aug 12 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl3
301  - Modified typo: %%descriptin -l ja into %description -l ja
302
303* Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl3
304- rebuild for VinePlus/3.0 and VineSeedPlus
305- updated Japanese description
306- merged VinePlus/2.6 spec file
307  * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl2
308  - Modified the character code of this file into euc-jp.
309  * Tue Jul 21 2004 by IKEDA Katsumi <ikeda@rg8.so-net.ne.jp> 3.08.0-0vl1
310  - new upstream release.
311  - Modified Copyright.
312  - Added Summary(ja), %%descriptin -l ja, Prereq and %%clean.
313  - Added %%post and %%preun for running /sbin/install-info.
314
315* Wed Apr  7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.07-2vl2
316- rebuild for VineSeed
317- s/Copyright/License/
318
319* Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
320- 3.07-2vl1
321- Modified %Vendor and %BuildRoot.
322- Add %Distribution.
Note: See TracBrowser for help on using the repository browser.