source: projects/specs/trunk/o/ocaml/ocaml-vl.spec @ 835

Revision 835, 10.1 KB checked in by owa, 14 years ago (diff)

rebuilt with new tool chain

Line 
1Name: ocaml
2Summary: The Objective Caml compiler and programming environment
3Summary(ja): Objective Caml コンパイラとプログラミング環境
4Version: 3.11.0
5Release: 2%{?_dist_release}
6Source0: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-%{version}.tar.bz2
7Source1: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.html.tar.gz
8Source2: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.ps.gz
9Source3: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.10-refman.info.tar.gz
10Source4: ocaml-info-entry
11
12# Vine Source(s)
13Source10: caml-mode-install.sh
14Source11: caml-mode-remove.sh
15
16License: QPL/LGPL
17Group: Development/Languages
18URL: http://caml.inria.fr/
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: ncurses-devel gdbm-devel emacsen
22BuildRequires: libX11-devel
23BuildRequires: tk tcl expect thread
24Requires(post,preun): install-info
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29Packager: inagaki
30
31%define debug_package %{nil}
32
33%description
34Objective Caml is a high-level, strongly-typed, functional and
35object-oriented programming language from the ML family of languages.
36
37This package comprises two batch compilers (a fast bytecode compiler
38and an optimizing native-code compiler), an interactive toplevel system,
39parsing tools (Lex,Yacc,Camlp4), a replay debugger, a documentation generator,
40and a comprehensive library.
41
42%description -l ja
43Object Caml は ML 系言語の方言で、高水準で強い型付けを備えた関数型と
44オブジェクト指向を併せ持ったプログラミング言語です。
45このパッケージには、2 つのバッチコンパイラ (コンパイル速度が高速な
46バイトコードコンパイラと最適化を行なうネイティブコードコンパイラ)、
47トップレベル対話環境、構文解析ツール (Lex, Yac, Camlp4)、リプレイ
48デバッガ、ドキュメント生成ツール、そして広範囲に渡るライブラリが含まれて
49います。
50
51%package labltk
52Summary: Tk bindings for Objective Caml
53Summary(ja): Objective Caml の Tk バインディング
54Group: Development/Languages
55Requires: ocaml = %{version}-%{release}
56Requires: tk tcl
57Obsoletes: labltk <= %{version}
58
59%description labltk
60A library for interfacing Objective Caml with the scripting language
61Tcl/Tk. It include the OCamlBrowser code editor / library browser.
62
63%package camlp4
64Summary: Pre-Processor-Pretty-Printer for OCaml
65Group: Development/Languages
66Requires: ocaml = %{version}-%{release}
67Obsoletes: camlp4 <= %{version}
68
69%description camlp4
70Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
71file and printing some result on standard output.
72
73%package mode
74Summary: Emacs mode for Objective Caml
75Summary(ja): Objective Caml の Emacs mode
76Group: Applications/Editors/Emacs
77Requires: ocaml = %{version}-%{release}
78Prereq: emacs, emacsen-common
79Obsoletes: ocaml-emacs <= %{version}
80
81%description mode
82Emacs mode for Objective Caml.
83
84%description -l ja mode
85Objective Caml 用の Emacs mode です.
86
87
88%prep
89%setup -q -T -b 0
90%setup -q -T -D -a 1
91%setup -q -T -D -a 3
92cp %{SOURCE2} refman.ps.gz
93cp %{SOURCE4} infoman/ocaml-info-entry
94
95%build
96./configure -cc "%{__cc} %{optflags}" -with-pthread \
97    -bindir %{_bindir} \
98    -libdir %{_libdir}/ocaml \
99    -mandir %{_mandir} \
100    -prefix %{_prefix}
101make world opt opt.opt
102(cd infoman; gzip -cd ocaml.info.gz >> ocaml-info-entry; mv ocaml-info-entry  ocaml.info; gzip -f ocaml.info)
103# for dumpobj, objinfo
104(cd tools; make dumpobj; make objinfo; cd ..)
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make install BINDIR=%{buildroot}%{_bindir} LIBDIR=%{buildroot}%{_libdir}/ocaml MANDIR=%{buildroot}%{_mandir}
110
111mv %{buildroot}%{_libdir}/ocaml/ld.conf %{buildroot}%{_libdir}/ocaml/ld.conf.orig
112sed -e "s|^%{buildroot}||" %{buildroot}%{_libdir}/ocaml/ld.conf.orig > %{buildroot}%{_libdir}/ocaml/ld.conf
113rm -f %{buildroot}%{_libdir}/ocaml/ld.conf.orig
114(mkdir -p %{buildroot}%{_infodir}; cd infoman; cp ocaml*.gz %{buildroot}%{_infodir})
115# for dumpobj, objinfo
116(cd tools; install dumpobj objinfo %{buildroot}%{_bindir})
117
118# for Emacs Lisp
119make -C emacs install install-ocamltags BINDIR=%{buildroot}%{_bindir} \
120    EMACSDIR=%{buildroot}%{_datadir}/emacs/site-lisp/caml-mode
121
122# emacsen-common-ize
123mkdir -p $RPM_BUILD_ROOT/%{_prefix}/lib/emacsen-common/packages/install
124mkdir -p $RPM_BUILD_ROOT/%{_prefix}/lib/emacsen-common/packages/remove
125%_installemacsenscript caml-mode %{SOURCE10}
126
127%_removeemacsenscript  caml-mode %{SOURCE11}
128
129
130# Disable build root strip policy:
131# executables generated by ocamlc -custom MUST NOT BE STRIPPED
132# But now that we have dynamic loading of C code, none of the executables
133# in the distribution is generated by ocamlc -custom, so leave default.
134# %define __spec_install_post /usr/lib/rpm/brp-compress
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post
140/sbin/install-info %{_infodir}/ocaml.info %{_infodir}/dir
141
142%post mode
143if [ "$1" = 2 ]; then
144    %_emacsenPackageRemove caml-mode
145
146fi
147
148%_addemacsenlist caml-mode
149
150%_emacsenPackageInstall caml-mode
151
152%preun
153if [ $1 = 0 ]; then
154    /sbin/install-info --delete %{_infodir}/ocaml.info %{_infodir}/dir
155fi
156
157%preun mode
158if [ "$1" = 0 ]; then
159    %_emacsenPackageRemove caml-mode
160   
161    %_removeemacsenlist caml-mode
162
163fi
164
165
166%files
167%defattr(-, root, root)
168%doc README LICENSE refman.ps.gz htmlman
169%{_bindir}/*
170%{_mandir}/man1/*
171%{_mandir}/man3/*
172%{_libdir}/ocaml
173%{_infodir}/*
174### in ocaml-camlp4
175%exclude %{_bindir}/camlp4*
176%exclude %{_bindir}/mkcamlp4
177#exclude %{_bindir}/ocpp
178%exclude %{_libdir}/ocaml/camlp4/
179#exclude %{_mandir}/man1/camlp4*
180#exclude %{_mandir}/man1/mkcamlp4*
181#exclude %{_mandir}/man1/ocpp*
182### in ocaml-labltk
183%exclude %{_bindir}/labltk
184%exclude %{_bindir}/ocamlbrowser
185%exclude %{_libdir}/ocaml/labltk/
186%exclude %{_libdir}/ocaml/stublibs/dlllabltk.so
187%exclude %{_libdir}/ocaml/stublibs/dlltkanim.so
188### in ocaml-mode
189%exclude %{_bindir}/ocamltags
190
191%files camlp4
192%defattr(-, root, root, 0755)
193%{_bindir}/camlp4*
194%{_bindir}/mkcamlp4
195#{_bindir}/ocpp
196%dir %{_libdir}/ocaml/
197%{_libdir}/ocaml/camlp4/
198#{_mandir}/man1/camlp4*
199#{_mandir}/man1/mkcamlp4*
200#{_mandir}/man1/ocpp*
201
202%files labltk
203%defattr(-, root, root, 0755)
204%doc otherlibs/labltk/examples_*tk
205%{_bindir}/labltk
206%{_bindir}/ocamlbrowser
207%dir %{_libdir}/ocaml/
208%dir %{_libdir}/ocaml/stublibs/
209%{_libdir}/ocaml/labltk/
210%{_libdir}/ocaml/stublibs/dlllabltk.so
211%{_libdir}/ocaml/stublibs/dlltkanim.so
212
213%files mode
214%defattr(-, root, root, 0755)
215%doc emacs/README
216%{_bindir}/ocamltags
217%dir %{_datadir}/emacs/
218%dir %{_datadir}/emacs/site-lisp/caml-mode
219%{_datadir}/emacs/site-lisp/caml-mode/*.el
220#{_datadir}/emacs/site-lisp/caml-mode/*.elc
221%{_prefix}/lib/emacsen-common/packages/install/caml-mode
222%{_prefix}/lib/emacsen-common/packages/remove/caml-mode
223
224
225%changelog
226* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.0-2
227- rebuilt with new tool chain
228
229* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.0-1
230- new upstream release
231- spec in UTF-8
232
233* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl5
234- new upstream release for VineSeed
235
236* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl4
237- new upstream release
238
239* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.1-0vl1
240- new upstream release
241
242* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl2
243- rebuilt with VineSeed
244
245* Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl1
246- new upstream release
247
248* Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl2
249- rebuilt for VinePlus/4.0
250
251* Mon Nov 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl1
252- new upstream release
253
254* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.2-0vl4
255- changed ocaml-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
256
257* Wed Aug 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> - 3.09.2-0vl3
258- add BuildRequires: XOrg-devel, ncurses-devel, gdbm-devel, emacsen
259- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
260
261* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl2
262- rebuilt for VineSeed Plus
263
264* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl1
265- new upstream release
266
267* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl3
268- rebuilt for VineSeed Plus
269
270* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl2
271- rebuilt for VinePlus/3.0
272- added BuildRequires: expect, thread
273
274* Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl1
275- new upstream release
276
277* Sat Nov  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl2
278- rebuild for VineSeed Plus
279
280* Thu Nov  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl1
281- new upstream release
282
283* Tue Oct 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl3
284- rebuild with VineSeed Plus
285
286* Mon Oct 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl2
287- rebuild with VinePlus/3.0
288- added dumpobj, objinfo
289
290* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl1
291- new upstream release
292- split to caml4p, labltk, mode packages
293
294* Thu Mar 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.3-0vl1
295- new upstream release
296
297* Sat Dec  4 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.2-0vl1
298- new upstream release
299
300* Fri Oct 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.1-0vl1
301- new upstream release
302
303* Fri Aug 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl4
304- fixed typo based on 3.08.0-0vl3
305  * Thu Aug 12 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl3
306  - Modified typo: %%descriptin -l ja into %description -l ja
307
308* Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl3
309- rebuild for VinePlus/3.0 and VineSeedPlus
310- updated Japanese description
311- merged VinePlus/2.6 spec file
312  * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl2
313  - Modified the character code of this file into euc-jp.
314  * Tue Jul 21 2004 by IKEDA Katsumi <ikeda@rg8.so-net.ne.jp> 3.08.0-0vl1
315  - new upstream release.
316  - Modified Copyright.
317  - Added Summary(ja), %%descriptin -l ja, Prereq and %%clean.
318  - Added %%post and %%preun for running /sbin/install-info.
319
320* Wed Apr  7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.07-2vl2
321- rebuild for VineSeed
322- s/Copyright/License/
323
324* Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
325- 3.07-2vl1
326- Modified %Vendor and %BuildRoot.
327- Add %Distribution.
Note: See TracBrowser for help on using the repository browser.