source: projects/specs/trunk/o/ocaml-ounit/ocaml-ounit-vl.spec @ 9594

Revision 9594, 6.5 KB checked in by inagaki, 9 years ago (diff)

2015-06-11 Ryoichi INAGAKI <ryo1@…>

  • llvm: updated
  • mesa: rebuilt
  • ocaml-ctypes, ocaml-ounit: new


Line 
1%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
2
3Name:           ocaml-ounit
4Version:        2.0.0
5Release:        13%{?_dist_release}
6Summary:        Unit test framework for OCaml
7
8License:        MIT
9Group:          Development/Tools
10URL:            http://ounit.forge.ocamlcore.org/
11
12Source0:        http://forge.ocamlcore.org/frs/download.php/1258/ounit-%{version}.tar.gz
13ExcludeArch:    sparc64 s390 s390x
14
15BuildRequires:  ocaml >= 3.10.0
16BuildRequires:  ocaml-findlib
17#BuildRequires:  ocaml-ocamldoc
18# This may have been required by < 2.0.0, but doesn't seem to be
19# needed for newer versions.
20#BuildRequires:  ocaml-camlp4-devel
21
22
23%description
24OUnit is a unit test framework for OCaml. It allows one to easily
25create unit-tests for OCaml code. It is based on HUnit, a unit testing
26framework for Haskell. It is similar to JUnit, and other xUnit testing
27frameworks.
28
29
30%package        devel
31Summary:        Development files for %{name}
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description    devel
36The %{name}-devel package contains libraries and signature files for
37developing applications that use %{name}.
38
39
40%prep
41%setup -q -n ounit-%{version}
42sh ./configure --destdir $RPM_BUILD_ROOT
43
44
45%build
46make all
47make doc
48
49
50%install
51rm -rf $RPM_BUILD_ROOT
52export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
53mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
54make install
55
56# Remove this, reinstall it properly with a %%doc rule below.
57rm -rf $RPM_BUILD_ROOT/usr/local/share/doc
58
59%check
60make test
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%doc LICENSE.txt
67%{_libdir}/ocaml/oUnit
68%if %opt
69%exclude %{_libdir}/ocaml/oUnit/*.a
70%exclude %{_libdir}/ocaml/oUnit/*.cmxa
71%endif
72%exclude %{_libdir}/ocaml/oUnit/*.mli
73
74
75%files devel
76%doc LICENSE.txt README.txt
77%doc _build/src/api-ounit.docdir/*
78%if %opt
79%{_libdir}/ocaml/oUnit/*.a
80%{_libdir}/ocaml/oUnit/*.cmxa
81%endif
82%{_libdir}/ocaml/oUnit/*.mli
83
84
85%changelog
86* Wed May 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.0-13
87- Initial build for VineLinux
88
89* Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-12
90- Bump release and rebuild.
91
92* Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-11
93- ocaml-4.02.1 rebuild.
94
95* Mon Jan 26 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-10
96- Fix Source URL.
97- Rebuild against OCaml to fix "make inconsistent assumptions over
98  implementation Arg".
99
100* Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-9
101- ocaml-4.02.0 final rebuild.
102
103* Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-8
104- ocaml-4.02.0+rc1 rebuild.
105
106* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-7
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
108
109* Fri Aug 01 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-6
110- ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
111
112* Thu Jul 17 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-5
113- OCaml 4.02.0 beta rebuild.
114
115* Mon Jul 14 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-4
116- Remove workaround for code gen bug and try building against
117  possibly fixed compiler.
118
119* Sun Jul 13 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-3
120- Add workaround for code generator bug on ARM (RHBZ#1119049).
121
122* Sat Jul 12 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-1
123- New upstream version 2.0.0.
124- Remove BR on camlp4.
125
126* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-9
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
128
129* Fri Feb 14 2014 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-8
130- Rebuild for updated Arg module (RHBZ#1065447).
131
132* Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-7
133- Rebuild for OCaml 4.01.0.
134- Enable debuginfo.
135
136* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-6
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
138
139* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
141
142* Fri Oct 19 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-4
143- Rebuild for OCaml 4.00.1.
144- Clean up the spec file.
145
146* Sat Jul 28 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-3
147- Bump and rebuild against new OCaml 4.00.0 official release.
148
149* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
151
152* Sat Jun 30 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-1
153- New upstream version 1.1.2, fixed for OCaml 4.00.0.
154
155* Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-6
156- Rebuild for OCaml 4.00.0.
157
158* Mon May 14 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-5
159- Bump release and rebuild for new OCaml on ARM.
160
161* Fri Jan 06 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-4
162- Rebuild for OCaml 3.12.1.
163
164* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-3
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
166
167* Wed Jan  5 2011 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-2
168- New upstream version 1.1.0.
169- Project has moved to new upstream URL and Source0.
170- Rebuild for OCaml 3.12.0.
171- New build system:
172    + doesn't need 'make allopt'
173    + DESTDIR logic changed (see OASIS bug 852)
174    + docdir moved
175- LICENSE and README files renamed.
176- BR camlp4.
177
178* Wed Dec 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-7
179- Rebuild for OCaml 3.11.2.
180
181* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-6
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
183
184* Sat May 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-5
185- Rebuild for OCaml 3.11.1
186
187* Thu Apr 16 2009 S390x secondary arch maintainer <fedora-s390x@lists.fedoraproject.org>
188- ExcludeArch sparc64, s390, s390x as we don't have OCaml on those archs
189  (added sparc64 per request from the sparc maintainer)
190
191* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-4
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
193
194* Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-3
195- Rebuild for OCaml 3.11.0+rc1.
196
197* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-2
198- Rebuild for OCaml 3.11.0
199
200* Sun Aug 31 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-1
201- New upstream version 1.0.3.
202
203* Mon May 12 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-2
204- License is MIT.
205
206* Sat May  3 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-1
207- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.