source: projects/specs/trunk/o/ocaml-facile/ocaml-facile-vl.spec @ 9296

Revision 9296, 4.9 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • ledit: rebuilt
  • ocaml, ocaml-findlib: updated
  • ocaml-camlp4, ocaml-labltk: split from ocaml
  • ocaml-camlp5, pcaml-facile: updated and renamed


Line 
1%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
2%global debug_package %{nil}
3%global _default_patch_fuzz 2
4
5Name:          ocaml-facile
6Version:       1.1
7Release:       31%{?_dist_release}
8Summary:       OCaml library for constraint programming
9Summary(ja):   制約プログラミング向けの OCaml ライブラリ
10Summary(fr):   Librairie OCaml de programmation par contraintes
11
12License:       LGPLv2+
13Group:         System Environment/Libraries
14URL:           http://www.recherche.enac.fr/log/facile/
15
16Source0:       http://www.recherche.enac.fr/log/facile/distrib/facile-%{version}.tar.gz
17
18# makefile fixes by Steffen Joeris <white@debian.org>:
19# * only build and install native binaries if ocamlopt is available
20# * install .mli files
21Patch0:        facile-1.1-makefile-fixes.patch
22
23# Fix for OCaml 4.00.0.
24Patch1:        ocaml-facile-ocaml-4.patch
25
26BuildRoot:     %{_tmppath}/%{name}-%{version}-root
27BuildRequires: ocaml >= 3.02
28BuildRequires: ocaml-findlib-devel
29Obsoletes:     facile < %{version}-%{release}
30Provides:      facile = %{version}-%{release}
31
32Vendor:        Project Vine
33Distribution:  Vine Linux
34Packager:      inagaki
35
36%description
37FaCiLe is a constraint programming library on integer and integer set finite
38domains written in OCaml. It offers all usual facilities to create and
39manipulate finite domain variables, arithmetic expressions and constraints
40(possibly non-linear), built-in global constraints (difference, cardinality,
41sorting etc.) and search and optimization goals. FaCiLe allows as well to build
42easily user-defined constraints and goals (including recursive ones), making
43pervasive use of OCaml higher-order functionals to provide a simple and flexible
44interface for the user. As FaCiLe is an OCaml library and not "yet another
45language", the user benefits from type inference and strong typing discipline,
46high level of abstraction, modules and objects system, as well as native code
47compilation efficiency, garbage collection and replay debugger, all features of
48OCaml (among many others) that allow to prototype and experiment quickly:
49modeling, data processing and interface are implemented with the same powerful
50and efficient language.
51
52%package        devel
53Summary:        Development files for %{name}
54Summary(ja):    %{name} の開発用ファイル
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57
58%description    devel
59The %{name}-devel package contains libraries and signature files for
60developing applications that use %{name}.
61
62
63%prep
64%setup -q -n facile-%{version}
65%patch0 -p1 -b .makefile-fixes
66%patch1 -p1 -b .ocaml4
67
68%build
69# This is not autoconf, but a simple custom configure script.
70# The --faciledir directory is only used for "make install".
71./configure --faciledir $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
77make install
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%check
83make check
84
85%files
86%defattr(-,root,root)
87%doc LICENSE README
88%{_libdir}/ocaml/facile/
89%if %opt
90%exclude %{_libdir}/ocaml/facile/*.a
91%exclude %{_libdir}/ocaml/facile/*.cmxa
92%endif
93%exclude %{_libdir}/ocaml/facile/*.mli
94
95%files devel
96%if %opt
97%{_libdir}/ocaml/facile/*.a
98%{_libdir}/ocaml/facile/*.cmxa
99%endif
100%{_libdir}/ocaml/facile/*.mli
101
102
103%changelog
104* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1-31
105- changed package name
106- rebuilt with ocaml 4.02.1
107- split development files into devel subpackage
108
109* Tue May 15 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-13
110- rebuilt with ocaml-3.12.1
111
112* Sat Jun 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-12
113- rebuild with ocaml-3.12.0
114
115* Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-11
116- rebuilt with ocaml-3.12.0
117- added Japanese summary
118- added Vendor and Distribution tag
119
120* Sun Sep 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1-10
121- rebuilt with ocaml-3.11.0 (x86_64 has not built with ocaml-3.11.0)
122
123* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-9
124- rebuilt with ocaml-3.11.0
125
126* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-8
127- rebuild with ocaml-3.10.2
128
129* Thu Feb  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.2
130- rebuild with ocaml-3.10.1 on Vine4.2
131
132* Thu Feb  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl7
133- rebuild with ocaml-3.10.1
134
135* Tue Oct 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.1
136- rebuild with ocaml-3.10.0 on Vine4.1
137
138* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-0vl6
139- rebuild with ocaml-3.10.0
140
141* Thu Jun 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1-0vl5
142- rebuild with ocaml-3.09.2 on VineSeed
143
144* Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
145- rebuild with ocaml-3.09.1 on VineSeed
146
147* Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
148- rebuild with ocaml-3.09.1 on Vine3.2
149
150* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
151- rebuild for VineSeed
152
153* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
154- initial release
Note: See TracBrowser for help on using the repository browser.