source: projects/specs/trunk/o/ocaml-camlpdf/ocaml-camlpdf-vl.spec @ 11617

Revision 11617, 1.4 KB checked in by ara_t, 6 years ago (diff)

ocaml-camlpdf: initial build

Line 
1%define pkg_name    camlpdf
2%define pkg_version 2.2
3%define patchlevel  1
4%define pkg_release 1%{?_dist_release}
5
6Summary: OCaml library for reading, writing and modifying PDF files
7Name:    ocaml-%{pkg_name}
8Version: %{pkg_version}.p%{patchlevel}
9Release: %{pkg_release}
10
11License: LGPL v2.1+
12Group:   Development/Languages
13URL:     https://github.com/johnwhitington/camlpdf
14
15Source0: camlpdf-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
16# Source0: camlpdf-%{pkg_version}.tar.gz
17
18BuildRequires: ocaml
19BuildRequires: ocaml-findlib
20
21Requires: ocaml
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26
27%description
28OCaml library for reading, writing and modifying PDF files
29
30%prep
31%{__rm} -rf ${RPM_BUILD_ROOT}
32%setup -q -n %{pkg_name}-%{pkg_version}-patchlevel%{patchlevel}
33# %setup -q
34
35%build
36%{__make}
37
38%install
39INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
40MYCONF=my.conf
41touch ${MYCONF}
42%{__mkdir_p} ${INSTALLDIR}
43
44%{__make} install \
45 OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR} -ldconf ${MYCONF}"
46
47%clean
48%{__rm} -rf ${RPM_BUILD_ROOT}
49
50%post
51echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
52
53%preun
54%{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
55 %{_libdir}/ocaml/ld.conf
56
57
58%files
59%doc doc/camlpdf/html examples
60%doc Changes LICENSE README.md introduction_to_camlpdf.pdf
61%{_libdir}/ocaml/camlpdf
62
63
64%changelog
65* Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2.p1
66- initial build for Vine Linux
67
Note: See TracBrowser for help on using the repository browser.