source: projects/specs/trunk/o/ocaml-camlp5/ocaml-camlp5-vl.spec @ 9296

Revision 9296, 4.1 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • ledit: rebuilt
  • ocaml, ocaml-findlib: updated
  • ocaml-camlp4, ocaml-labltk: split from ocaml
  • ocaml-camlp5, pcaml-facile: updated and renamed


Line 
1%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
2%if !%{opt}
3%global debug_package %{nil}
4%endif
5
6Name:           ocaml-camlp5
7Summary:        Classical version of camlp4 OCaml preprocessor
8Summary(ja):    Camlp4 OCaml プリプロセッサの古典的な実装
9Version:        6.12
10Release:        1%{?_dist_release}
11
12License:        BSD
13Group:          Development/Languages
14URL:            http://camlp5.gforge.inria.fr/
15
16Source0:        http://camlp5.gforge.inria.fr/distrib/src/camlp5-%{version}.tgz
17# Kill -warn-error A
18Patch0:         camlp5-6.11-kill-warn-error.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  ocaml
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       inagaki
26
27%global __ocaml_requires_opts -i Asttypes -i Parsetree -i Pa_extend
28%global __ocaml_provides_opts -i Dynlink -i Dynlinkaux -i Pa_extend
29
30%description
31Camlp5 is a preprocessor-pretty-printer of OCaml.
32
33It is the continuation of the classical camlp4 with new features.
34
35OCaml 3.10 and above have an official camlp4 which is incompatible
36with classical (<= 3.09) versions.  You can find that in the
37ocaml-camlp4 package.
38
39
40%package        devel
41Summary:        Development files for %{name}
42Summary(ja):    %{name} の開発用ファイル
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45
46%description    devel
47The %{name}-devel package contains libraries and signature files for
48developing applications that use %{name}.
49
50
51%prep
52%setup -q -n camlp5-%{version}
53%patch0 -p1
54
55# Build with debug information
56sed -i 's,WARNERR="",WARNERR="-g",' configure
57sed -i 's,-linkall,& -g,g' top/Makefile
58for fil in compile/compile.sh $(find . -name Makefile); do
59  sed -i 's,\$[({]OCAMLN[})]c,& -g,;s,\$[({]OCAMLN[})]opt,& -g,;s,LINKFLAGS=,&-g ,' $fil
60done
61
62
63%build
64./configure
65%if %opt
66# For ppc64 we need a larger stack than default to compile some files
67# because the stages in the OCaml compiler are not mutually tail
68# recursive.
69%ifarch ppc64 ppc64le
70ulimit -a
71ulimit -Hs 65536
72ulimit -Ss 65536
73%endif
74make world.opt
75%else
76make world
77%endif
78make -C doc/htmlp
79
80%install
81if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
82mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml
83mkdir -p $RPM_BUILD_ROOT%{_bindir}
84mkdir -p $RPM_BUILD_ROOT%{_mandir}
85make install \
86  LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
87  OLIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
88  BINDIR=$RPM_BUILD_ROOT%{_bindir} \
89  MANDIR=$RPM_BUILD_ROOT%{_mandir}
90cp -p etc/META $RPM_BUILD_ROOT%{_libdir}/ocaml/camlp5
91rm -f doc/html/.cvsignore doc/htmlp/{.cvsignore,*.sh,Makefile,html2*}
92
93%clean
94if [ -d $RPM_BUILD_ROOT ]; then %{__rm} -rf $RPM_BUILD_ROOT; fi
95
96%files
97%defattr (-,root,root)
98%doc README LICENSE
99%{_libdir}/ocaml/camlp5
100%if %opt
101%exclude %{_libdir}/ocaml/camlp5/*.a
102%exclude %{_libdir}/ocaml/camlp5/*.cmxa
103%exclude %{_libdir}/ocaml/camlp5/*.cmx
104%endif
105%exclude %{_libdir}/ocaml/camlp5/*.mli
106
107%files devel
108%doc CHANGES ICHANGES DEVEL UPGRADING doc/html
109%if %opt
110%{_libdir}/ocaml/camlp5/*.a
111%{_libdir}/ocaml/camlp5/*.cmxa
112%{_libdir}/ocaml/camlp5/*.cmx
113%endif
114%{_libdir}/ocaml/camlp5/*.mli
115%{_bindir}/camlp5*
116%{_bindir}/mkcamlp5*
117%{_bindir}/ocpp5
118%{_mandir}/man1/*
119
120%changelog
121* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 6.12-1
122- changed package name
123- updated to 6.12
124- built with ocaml 4.02.1
125- split development files into devel subpackage
126
127* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 6.11-1
128- new upstream release
129
130* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> - 5.11-2
131- rebuilt with new tool chain and ocaml 3.11.0-2
132
133* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.11-1
134- new upstream release
135- built with ocaml 3.11.0
136- added Packager tag
137
138* Sun Aug  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.08-1
139- new upstream release
140- built with ocaml 3.10.2
141
142* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.07-0vl2
143- rebuilt for VineSeed
144
145* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.07-0vl1
146- new upstream release
147- rebuilt with Ocaml 3.10.1
148
149* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> - 5.00-0vl2
150- added option libdir to configure
151
152* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.00-0vl1
153- initial package for Vine Linux
Note: See TracBrowser for help on using the repository browser.