source: projects/specs/trunk/o/ocaml-camlp5/ocaml-camlp5-vl.spec @ 9297

Revision 9297, 4.3 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • ocaml-camlp5, ocaml-labltk: fixed spec


Line 
1%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
2%if !%{opt}
3%global debug_package %{nil}
4%endif
5
6Name:           ocaml-camlp5
7Summary:        Classical version of camlp4 OCaml preprocessor
8Summary(ja):    Camlp4 OCaml プリプロセッサの古典的な実装
9Version:        6.12
10Release:        2%{?_dist_release}
11
12License:        BSD
13Group:          Development/Languages
14URL:            http://camlp5.gforge.inria.fr/
15
16Source0:        http://camlp5.gforge.inria.fr/distrib/src/camlp5-%{version}.tgz
17# Kill -warn-error A
18Patch0:         camlp5-6.11-kill-warn-error.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  ocaml
22Obsoletes:      camlp5 < %{version}-%{release}
23Provides:       camlp5 = %{version}-%{release}
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27Packager:       inagaki
28
29%global __ocaml_requires_opts -i Asttypes -i Parsetree -i Pa_extend
30%global __ocaml_provides_opts -i Dynlink -i Dynlinkaux -i Pa_extend
31
32%description
33Camlp5 is a preprocessor-pretty-printer of OCaml.
34
35It is the continuation of the classical camlp4 with new features.
36
37OCaml 3.10 and above have an official camlp4 which is incompatible
38with classical (<= 3.09) versions.  You can find that in the
39ocaml-camlp4 package.
40
41
42%package        devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発用ファイル
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47
48%description    devel
49The %{name}-devel package contains libraries and signature files for
50developing applications that use %{name}.
51
52
53%prep
54%setup -q -n camlp5-%{version}
55%patch0 -p1
56
57# Build with debug information
58sed -i 's,WARNERR="",WARNERR="-g",' configure
59sed -i 's,-linkall,& -g,g' top/Makefile
60for fil in compile/compile.sh $(find . -name Makefile); do
61  sed -i 's,\$[({]OCAMLN[})]c,& -g,;s,\$[({]OCAMLN[})]opt,& -g,;s,LINKFLAGS=,&-g ,' $fil
62done
63
64
65%build
66./configure
67%if %opt
68# For ppc64 we need a larger stack than default to compile some files
69# because the stages in the OCaml compiler are not mutually tail
70# recursive.
71%ifarch ppc64 ppc64le
72ulimit -a
73ulimit -Hs 65536
74ulimit -Ss 65536
75%endif
76make world.opt
77%else
78make world
79%endif
80make -C doc/htmlp
81
82%install
83if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
84mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml
85mkdir -p $RPM_BUILD_ROOT%{_bindir}
86mkdir -p $RPM_BUILD_ROOT%{_mandir}
87make install \
88  LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
89  OLIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
90  BINDIR=$RPM_BUILD_ROOT%{_bindir} \
91  MANDIR=$RPM_BUILD_ROOT%{_mandir}
92cp -p etc/META $RPM_BUILD_ROOT%{_libdir}/ocaml/camlp5
93rm -f doc/html/.cvsignore doc/htmlp/{.cvsignore,*.sh,Makefile,html2*}
94
95%clean
96if [ -d $RPM_BUILD_ROOT ]; then %{__rm} -rf $RPM_BUILD_ROOT; fi
97
98%files
99%defattr (-,root,root)
100%doc README LICENSE
101%{_libdir}/ocaml/camlp5
102%if %opt
103%exclude %{_libdir}/ocaml/camlp5/*.a
104%exclude %{_libdir}/ocaml/camlp5/*.cmxa
105%exclude %{_libdir}/ocaml/camlp5/*.cmx
106%endif
107%exclude %{_libdir}/ocaml/camlp5/*.mli
108
109%files devel
110%doc CHANGES ICHANGES DEVEL UPGRADING doc/html
111%if %opt
112%{_libdir}/ocaml/camlp5/*.a
113%{_libdir}/ocaml/camlp5/*.cmxa
114%{_libdir}/ocaml/camlp5/*.cmx
115%endif
116%{_libdir}/ocaml/camlp5/*.mli
117%{_bindir}/camlp5*
118%{_bindir}/mkcamlp5*
119%{_bindir}/ocpp5
120%{_mandir}/man1/*
121
122%changelog
123* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 6.12-2
124- added Obsoletes and Provides tag
125
126* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 6.12-1
127- changed package name
128- updated to 6.12
129- built with ocaml 4.02.1
130- split development files into devel subpackage
131
132* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 6.11-1
133- new upstream release
134
135* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> - 5.11-2
136- rebuilt with new tool chain and ocaml 3.11.0-2
137
138* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.11-1
139- new upstream release
140- built with ocaml 3.11.0
141- added Packager tag
142
143* Sun Aug  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.08-1
144- new upstream release
145- built with ocaml 3.10.2
146
147* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.07-0vl2
148- rebuilt for VineSeed
149
150* Wed Feb  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.07-0vl1
151- new upstream release
152- rebuilt with Ocaml 3.10.1
153
154* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> - 5.00-0vl2
155- added option libdir to configure
156
157* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.00-0vl1
158- initial package for Vine Linux
Note: See TracBrowser for help on using the repository browser.