source: projects/specs/trunk/o/ocaml-camlp4/ocaml-camlp4-vl.spec @ 9296

Revision 9296, 4.1 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • ledit: rebuilt
  • ocaml, ocaml-findlib: updated
  • ocaml-camlp4, ocaml-labltk: split from ocaml
  • ocaml-camlp5, pcaml-facile: updated and renamed


Line 
1%define        ocaml_version 4.02.1
2%define        sup 2
3
4#ifarch %{ocaml_native_compiler}
5#global native_compiler 1
6#else
7#global native_compiler 0
8#endif
9
10Summary:       Pre-Processor-Pretty-Printer for OCaml
11Summary(ja):   OCaml 用プリプロセッサ、プリティプリンタ
12Name:          ocaml-camlp4
13Version:       %{ocaml_version}%{?sup:.%{sup}}
14Release:       1%{?_dist_release}
15
16Group:         Development/Languages
17License:       LGPLv2+ with exceptions
18URL:           https://github.com/ocaml/camlp4
19
20Source0:       https://github.com/ocaml/camlp4/archive/%{ocaml_version}%{?sup:+%{sup}}.tar.gz
21
22BuildRoot:     %{_tmppath}/%{name}-%{version}-root
23# This package used to be part of the upstream compiler.  We still
24# need to keep it in lock step with the compiler, so whenever a new
25# compiler is released we will also update this package also.
26BuildRequires: ocaml = %{ocaml_version}
27Requires:      ocaml(runtime) = %{ocaml_version}
28#Requires:     ocaml-runtime = %{version}
29
30%description
31Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
32file and printing some result on standard output.
33
34This package contains the runtime files.
35
36
37%package devel
38Summary:       Development files of Pre-Processor-Pretty-Printer for OCaml
39Summary(ja):   %{name} の開発用ファイル
40Group:         Development/Libraries
41Requires:      %{name} = %{version}-%{release}
42
43
44%description devel
45Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
46file and printing some result on standard output.
47
48This package contains the development files.
49
50
51%prep
52%setup -q -n camlp4-%{ocaml_version}%{?sup:-%{sup}}
53
54
55%build
56./configure
57# Incompatible with parallel builds:
58unset MAKEFLAGS
59#%if !%{native_compiler}
60#make byte
61#%else
62make all
63#%endif
64
65
66%install
67mkdir -p $RPM_BUILD_ROOT%{_bindir}
68mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/camlp4
69make install \
70  BINDIR=$RPM_BUILD_ROOT%{_bindir} \
71  LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
72  PKGDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/camlp4
73
74
75%files
76%doc README.md LICENSE
77%dir %{_libdir}/ocaml/camlp4
78%{_libdir}/ocaml/camlp4/*.cmi
79%{_libdir}/ocaml/camlp4/*.cma
80%{_libdir}/ocaml/camlp4/*.cmo
81%dir %{_libdir}/ocaml/camlp4/Camlp4Filters
82%{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmi
83%{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmo
84%dir %{_libdir}/ocaml/camlp4/Camlp4Parsers
85%{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmo
86%{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmi
87%dir %{_libdir}/ocaml/camlp4/Camlp4Printers
88%{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmi
89%{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmo
90%dir %{_libdir}/ocaml/camlp4/Camlp4Top
91%{_libdir}/ocaml/camlp4/Camlp4Top/*.cmi
92%{_libdir}/ocaml/camlp4/Camlp4Top/*.cmo
93
94
95%files devel
96%doc LICENSE
97%{_bindir}/camlp4*
98%{_bindir}/mkcamlp4
99#if %{native_compiler}
100%{_libdir}/ocaml/camlp4/*.a
101%{_libdir}/ocaml/camlp4/*.cmxa
102%{_libdir}/ocaml/camlp4/*.cmx
103%{_libdir}/ocaml/camlp4/*.o
104%{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmx
105%{_libdir}/ocaml/camlp4/Camlp4Filters/*.o
106%{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmx
107%{_libdir}/ocaml/camlp4/Camlp4Parsers/*.o
108%{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmx
109%{_libdir}/ocaml/camlp4/Camlp4Printers/*.o
110%{_libdir}/ocaml/camlp4/Camlp4Top/*.cmx
111%{_libdir}/ocaml/camlp4/Camlp4Top/*.o
112#endif
113
114
115%changelog
116* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.02.1.2-1
117- Initial build for Vine Linux (splitted from ocaml package)
118- as of 4.02.1+2
119
120* Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.7.git87c6a6b0
121- ocaml-4.02.0 final rebuild.
122
123* Fri Aug 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.6.git87c6a6b0
124- ocaml-4.02.0+rc1 rebuild.
125
126* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.02.0-0.5.git87c6a6b0
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
128
129* Fri Aug 01 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.4.git87c6a6b0
130- ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
131
132* Sat Jul 19 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.3.git87c6a6b0
133- OCaml 4.02.0 beta rebuild.
134
135* Wed Jul 16 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.2
136- Initial packaging of new out-of-tree ocaml-camlp4.
Note: See TracBrowser for help on using the repository browser.