source: projects/specs/trunk/o/obexftp/obexftp-vl.spec @ 9078

Revision 9078, 10.8 KB checked in by inagaki, 9 years ago (diff)

2014-11-11 Ryoichi INAGAKI <ryo1@…>

  • libbtctl: added patch
  • obex-data-server, obexftp, openobex: updated


Line 
1%define python_sitearch %(python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
2%define ruby_vendorarch %(ruby -r rbconfig -e 'print RbConfig::CONFIG["vendorarchdir"]')
3
4Name: obexftp
5Summary: Tool to access devices via the OBEX protocol
6Summary(ja): OBEX プロトコルを使用する機器にアクセスするためのツール
7Version: 0.24
8Release: 1%{?_dist_release}
9License: GPLv2+
10Group: Applications/Communications
11URL: http://openobex.triq.net/
12
13Source: http://dl.sourceforge.net/project/openobex/obexftp/0.24/obexftp-0.24-Source.tar.gz
14Patch0: obexftp-norpath.patch
15# From upstream git, fixes fuse apps not being installed
16Patch1: %{name}-0.24-fuse.patch
17# From OpenSUSE, thanks: fix pkgconfig to require bluez not bluetooth
18Patch2: %{name}-pkgconfig_requires.patch
19# From OpenSUSE, thanks: fix python install path
20Patch3: %{name}-0.24-fix-absurd-install-path.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: asciidoc
24BuildRequires: cmake
25BuildRequires: bluez-libs-devel
26BuildRequires: fuse-devel
27BuildRequires: gettext-devel
28BuildRequires: openobex-devel
29BuildRequires: perl(ExtUtils::MakeMaker)
30BuildRequires: python-devel
31BuildRequires: ruby-devel
32BuildRequires: swig
33BuildRequires: tcl
34BuildRequires: xmlto
35
36#----------------------------------------------------------------------------
37%description
38The overall goal of this project is to make mobile devices featuring the OBEX
39protocol and adhering to the OBEX FTP standard accessible by an open source
40implementation. The common usage for ObexFTP is to access your mobile phones
41memory to  store and retrieve e.g. your phonebook, logos, ringtones, music,
42 pictures and alike.
43
44%description -l ja
45このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
46
47ObexFTPの共通の使い方
48お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
49
50#----------------------------------------------------------------------------
51%package -n fuse-%{name}
52Summary: FUSE based filesystem using ObexFTP
53Group: Applications/Communications
54Requires: %{name} = %{version}-%{release}
55
56%description -n fuse-%{name}
57This package provides a FUSE based filesystem using Obex protocol as backend.
58
59#----------------------------------------------------------------------------
60%package -n python-%{name}
61Summary: Python library to access devices via the OBEX protocol
62Summary(ja): OBEX プロトコルを使って機器を扱う Python ライブラリ
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description -n python-%{name}
67The overall goal of this project is to make mobile devices featuring the OBEX
68protocol and adhering to the OBEX FTP standard accessible by an open source
69implementation. The common usage for ObexFTP is to access your mobile phones
70memory to  store and retrieve e.g. your phonebook, logos, ringtones, music,
71 pictures and alike.
72
73%description -n python-%{name} -l ja
74このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
75
76ObexFTP の共通の使い方
77お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
78(このパッケージは Python 向けライブラリです)
79
80#----------------------------------------------------------------------------
81%package -n perl-%{name}
82Summary: Perl library to access devices via the OBEX protocol
83Summary(ja): OBEX プロトコルを使って機器を扱う Perl ライブラリ
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
87Provides: perl-OBEXFTP = %{version}-%{release}
88
89%description -n perl-%{name}
90The overall goal of this project is to make mobile devices featuring the OBEX
91protocol and adhering to the OBEX FTP standard accessible by an open source
92implementation. The common usage for ObexFTP is to access your mobile phones
93memory to  store and retrieve e.g. your phonebook, logos, ringtones, music,
94 pictures and alike.
95
96%description -n perl-%{name} -l ja
97このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
98
99ObexFTPの共通の使い方
100お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
101(このパッケージは perl 向けライブラリです)
102
103#----------------------------------------------------------------------------
104%package -n ruby-%{name}
105Summary: Ruby library to access devices via the OBEX protocol
106Summary(ja): OBEX プロトコルを使って機器を扱う Ruby ライブラリ
107Group: Development/Libraries
108Requires: %{name} = %{version}-%{release}
109
110%description -n ruby-%{name}
111The overall goal of this project is to make mobile devices featuring the OBEX
112protocol and adhering to the OBEX FTP standard accessible by an open source
113implementation. The common usage for ObexFTP is to access your mobile phones
114memory to  store and retrieve e.g. your phonebook, logos, ringtones, music,
115 pictures and alike.
116
117%description -n ruby-%{name} -l ja
118このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
119
120ObexFTPの共通の使い方
121お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
122(このパッケージは ruby 向けライブラリです)
123
124#----------------------------------------------------------------------------
125%package devel
126Summary: Header files and libraries for %{name}
127Summary(ja): OBEX-FTP の開発用ヘッダーファイル
128Group: Development/Libraries
129Requires: %{name} = %{version}-%{release}
130Requires: bluez-libs-devel
131Requires: openobex-devel
132Requires: pkgconfig
133
134%description devel
135This package contains libraries and header files for developing applications
136that use %{name}.
137
138%description devel -l ja
139このパッケージには、%{name} を使用するアプリケーションを開発するためのライブラリ及びヘッダファイルが含まれています。
140
141#----------------------------------------------------------------------------
142%prep
143%setup -q -n %{name}-%{version}-Source
144%patch0 -p1 -b .norpath
145%patch1 -p1 -b .fuse
146%patch2 -p1 -b .pkgconfig
147%patch3 -p1 -b .pythonpath
148
149%build
150mkdir -p %{_target_platform}
151pushd %{_target_platform}
152%cmake -DCMAKE_SKIP_RPATH=YES ..
153
154# fix xmlto option to build man pages
155sed -i 's|\/usr\/bin\/xmlto |\/usr\/bin\/xmlto --skip-validation |g' doc/CMakeFiles/doc.dir/build.make
156
157popd
158
159make %{?_smp_mflags} -C %{_target_platform}
160make %{?_smp_mflags} doc -C %{_target_platform}
161
162%install
163rm -rf $RPM_BUILD_ROOT
164
165make install -C %{_target_platform} \
166     DESTDIR=$RPM_BUILD_ROOT \
167     RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_vendorarch}
168chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
169
170# rm $RPM_BUILD_ROOT%{_libdir}/*.la
171rm -f  $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
172rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
173
174
175%clean
176rm -rf $RPM_BUILD_ROOT
177
178%post -p /sbin/ldconfig
179%postun -p /sbin/ldconfig
180
181%files
182%defattr(-, root, root, -)
183%doc AUTHORS ChangeLog NEWS README THANKS TODO
184%{_bindir}/obexftp
185%{_bindir}/obexftpd
186%{_libdir}/*.so.*
187%{_mandir}/man1/obexftp.1*
188%{_mandir}/man1/obexftpd.1*
189
190%files devel
191%defattr(-, root, root, -)
192%{_includedir}/bfb/
193%{_includedir}/multicobex/
194%{_includedir}/obexftp/
195%{_libdir}/*.so
196%{_libdir}/pkgconfig/obexftp.pc
197
198%files -n fuse-%{name}
199%{_bindir}/obexautofs
200%{_bindir}/obexfs
201
202%files -n python-%{name}
203%defattr(-, root, root, -)
204%{python_sitearch}/_obexftp.so*
205%{python_sitearch}/obexftp.py*
206
207%files -n perl-%{name}
208%defattr(-, root, root, -)
209%{perl_vendorarch}/OBEXFTP.pm
210%dir %{perl_vendorarch}/*/OBEXFTP
211%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
212
213%files -n ruby-%{name}
214%defattr(-, root, root, -)
215%{ruby_vendorarch}/obexftp.so
216
217
218#----------------------------------------------------------------------------
219# Maintainers: babasaki@mindgear.org
220#
221#----------------------------------------------------------------------------
222%changelog
223* Tue Nov 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.24-1
224- updaed to 0.24
225- added fuse-obexftp subpackage
226- built with openobex 1.7,1 and perl 5.16.3
227
228* Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.23-2
229- rebuild with perl-5.12.3
230
231* Sat Dec 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.23-1
232- new upstream release
233- removed Requires: ruby(abi) (= 1.8) <BTS:799>
234
235* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22-4
236- rebuild (ruby-obexftp subpackage not uploaded on i386/x86_64 yet)
237
238* Fri Oct 24 2008 Seiichirou Babasaki 0.22-3
239- change %{perl_sitearch} -> %{perl_vendorarch}
240- added "# Maintainers: " comments.
241- changed UTF-8 encode at obexftp.vs.spec
242- Updated specfile
243
244* Wed Oct 2 2008 Seiichirou Babasaki 0.22-2
245- change %{perl_vendorarch} -> %{perl_sitearch}
246- Updated specfile
247
248* Wed Jan 16 2008 Seiichirou Babasaki 0.20-0.5_2-1
249- Import obexftp - Packager: Babasaki
250- Updated specfile
251
252#----------------------------------------------------------------------------
253* Thu Sep 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.5.rc7
254- updated to 0.22-rc7
255- added pkgconfig file
256- make perl BR more specific
257
258* Mon Aug 27 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.4.rc6
259- rebuilt for BuildID
260- updated license tag
261
262* Mon Aug 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.3.rc6
263- updated to 0.22-rc6
264- added ruby bindings (patch by Andy Shevchenko)
265- dropped upstreamed patch
266- added missing BRs for F7+
267
268* Mon Mar 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.2.pre4
269- fix segfault in obexftpd (patch by Jan Kratochvil), closes (#230991)
270
271* Fri Mar 23 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.1.pre4
272- updated to 0.22-pre4
273- updated patches
274
275* Fri Jan 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-3
276- add missing disttag
277
278* Thu Jan 25 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-2
279- added missing defattr
280- require openobex-devel > 1.2
281- added missing MODULE_COMPAT Requires: to perl subpackage
282- renamed subpackages to perl/python-obexftp
283- fixed rpaths
284
285* Mon Jan 01 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-1
286- updated to 0.20
287
288* Sun Jan 29 2006 Dag Wieers <dag@wieers.com> - 0.18-1
289- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.