source: projects/specs/trunk/o/obaq/obaq-vl.spec @ 521

Revision 521, 1.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ruby     /usr/bin/ruby
2%define rlibdir  %(%{ruby} -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
3
4Summary: Object oriented framework for BAtch and Queue processing
5Name: obaq
6Version: 0.6.1
7Release: 1%{?_dist_release}
8License: GPL
9Group: Development/Languages
10Source0: http://www.brain-tokyo.jp/~research/koutetu/obaq/%{name}-%{version}.tar.gz
11Patch0: obaq-0.6.1-ruby186.diff
12URL: http://www.brain-tokyo.jp/~research/koutetu/
13Prefix: /usr
14BuildArch: noarch
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: ruby ruby-devel
17Requires: ruby >= 1.8.1
18
19%description
20Object oriented framework for BAtch and Queue processing - OBAQ provides
21some features:
22  * to generate HTML texts by using Ruby.
23  * logging facility like log4j.
24  * SQL wrappers for PostgreSQL.
25  * to add options to objects by using outer rc-files.
26  * environmental acquisition.
27
28%prep
29
30%setup -q
31%patch0 -p0 -b .ruby18
32
33%build
34
35%install
36rm -rf ${RPM_BUILD_ROOT}
37mkdir -p ${RPM_BUILD_ROOT}%{rlibdir}
38
39# installing binaries ...
40make install \
41  PREFIX=${RPM_BUILD_ROOT}%{_prefix} \
42  SITE_DIR=${RPM_BUILD_ROOT}%{rlibdir}
43
44%clean
45rm -rf ${RPM_BUILD_ROOT}
46
47%files
48%defattr(-, root, root)
49%{_bindir}/html2obaq
50%{_bindir}/obaqsql
51%{_bindir}/obaq
52%{rlibdir}/obaq
53%doc ChangeLog
54%doc test
55%doc sample
56
57%changelog
58* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.1-1vl5
59- applied new versioning policy
60
61* Sun Apr 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl4
62- update patch0 for ruby-1.8.6
63
64* Fri Mar  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl3
65- add patch0 to support ruby-1.8
66
67* Sun Feb 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl2
68- rebuild with ruby-1.8.1
69
70* Sun Jun 16 2002 akira yamada <akira@vinelinux.org> 0.6.1-0vl1
71- Initial packaging.
Note: See TracBrowser for help on using the repository browser.