source: projects/specs/trunk/nonfree/self-build-zsnes/self-build-zsnes-vl.spec @ 4181

Revision 4181, 5.8 KB checked in by munepi, 13 years ago (diff)

updated {,self-build-}zsnes-vl.spec

Line 
1%define pkgname zsnes
2%define name    self-build-%{pkgname}
3%define version 1.51
4%define release 3%{?_dist_release}
5
6%define srcversion %(echo "%{version}src" | %{__sed} 's/\\.//')
7
8%define sourceurl0      http://prdownloads.sourceforge.net/%{pkgname}/%{pkgname}%{srcversion}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source101:      zsnes-1.51-Makefile.in.FIX.BROKENESS.patch
17Source102:      zsnes-1.51-FORTIFY_SOURCE.patch
18Source103:      zsnes-1.51-gcc43.patch
19Source104:      zsnes-1.51-pulseaudio.patch
20
21License:        GPLv2
22Group:          Restricted Software
23
24Requires(post):         self-build-setup
25
26Requires:       SDL >= 1.2.0
27Requires:       hicolor-icon-theme
28Requires(post):         automake
29Requires(post):         nasm >= 0.98
30Requires(post):         zlib >= 1.1.0
31Requires(post):         libpng >= 1.2.0
32Requires(post):         SDL-devel >= 1.2.0
33Requires(post):         zlib-devel >= 1.1.0
34Requires(post):         libpng-devel >= 1.2.0
35Requires(post):         ncurses-devel
36Requires(post):         libao-devel
37Requires(post):         desktop-file-utils
38%if %{?_dist_release} != "vl4"
39Requires:       mesa-libGL
40Requires(post):         xorg-x11-devel
41Requires(post):         mesa-libGL-devel
42%else
43Requires:       XOrg-gl
44Requires(post):         XOrg-devel
45Requires(post):         XOrg-gl-devel
46%endif
47
48BuildRoot:      %{_tmppath}/%{name}-%{version}-root
49ExclusiveArch:  %{ix86}
50
51Packager:       munepi
52
53%description
54ZSNES is one of Super Nintendo Entertainment System (SNES) emulators.
55
56If you install this package, it automaticaly downloads source
57code ,compile it, and create rpm packages of %{pkgname}-%{version}.
58And the created rpm packages are automatically installed
59if installation is executed by apt-get command or synaptic
60package manager.
61
62[Note]
63This package requires many other packages to compile
64targetsoftware. So it consume more disk space than usual.
65Also installation takes logner time because of compilation.
66(This will take a few minutes to quarter or half of an hour,
67depends on building environment)
68
69[About self-build package]
70For some kind of software, distributing of binary package
71may viorate the patent or law. Therefore we chose self-build
72packge, create binary package on your machine, for such kind
73of softwares instead of distributing binary package.
74
75Please obey the national law when you use the created binary
76packages. And if you want to use the softwares using patented
77thechnology, it may be required to get a permission, make an
78agreement or purchas a license. Please consider it with your
79purpose or way of use and take appropriate action.
80
81%description -l ja
82ZSNESはスーパーファミコンエミュレーターの1つです。
83
84このパッケージをインストールすると、自動的にソースコードを
85ダウンロードしてコンパイルし、%{pkgname}-%{version}
86の rpm パッケージを作成します。
87また apt-get コマンドや synaptic パッケージマネージャから実行
88した場合は、作成された rpm パッケージのインストールも自動的に
89行います。
90
91[注意]
92コンパイルに必要な多くの関連パッケージを要求するので通常より
93ディスクの領域を多く消費します。
94またインストール時にコンパイルを行うため、通常より時間がかか
95る場合があります。(環境にもよりますが数分から数十分程度)
96
97[self-build パッケージについて]
98ソフトウェアによってはバイナリパッケージの配布が特許や法律に
99違反する可能性があるものがあります。その為、このような問題が
100懸念されるソフトウェアについてはバイナリパッケージを直接配布
101せずに、ユーザの環境でバイナリを作成する self-build パッケー
102ジという方法を採っています。
103
104作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
105アのライセンス、および利用する国の各種法令に従ってください。
106また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
107センスの購入などが必要となる場合がありますので、利用する目的
108や形態に応じて各自で判断し適切な対応を取ってください。
109
110
111%prep
112[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
113
114%install
115%{__rm} -rf ${RPM_BUILD_ROOT}
116%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
117%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119%{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120%{__install} -m 644 %{SOURCE103} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121%{__install} -m 644 %{SOURCE104} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122
123
124%clean
125%{__rm} -rf ${RPM_BUILD_ROOT}
126
127%posttrans
128/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
129
130%files
131%defattr(-,root,root)
132%{_datadir}/%{name}/*
133
134%changelog
135* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.51-3
136- applied zsnes-1.51-gcc43.patch, zsnes-1.51-pulseaudio.patch
137
138* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.51-2
139- avoided to execute self-build-rpm.sh on RPM transaction
140  - moved %%post actions to %%posttrans
141
142* Mon Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.51-1
143- make self-build package from zsnes-1.51-0vl2.nosrc.rpm
144 - applied new versioning policy
145 - spec in utf8
146 - dropped NoSource: 0
147 - applied zsnes-1.51-Makefile.in.FIX.BROKENESS.patch,
148   zsnes-1.51-FORTIFY_SOURCE.patch
149 #, zsnes-1.51-gcc43.patch
150 - added Requires: hicolor-icon-theme
151   BuildRequires: automake ncurses-devel libao-devel desktop-file-utils
152 - For vl5, added Requires: mesa-libGL
153   BuildRequires: xorg-x11-devel mesa-libGL-devel
154 - fixed ExclusiveArch: %{ix86}
155
156### end of file
Note: See TracBrowser for help on using the repository browser.