source: projects/specs/trunk/nonfree/self-build-xvidcore/xvidcore-vl.spec @ 620

Revision 620, 2.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define name xvidcore
2%define version 1.2.1
3%define release 4%{?_dist_release}
4
5Summary: Free reimplementation of the OpenDivX video codec
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source: http://downloads.xvid.org/downloads/%{name}-%{version}.tar.bz2
10License: XVID (GPL with specific restrictions)
11URL: http://www.xvid.org/
12Group: System Environment/Libraries
13
14#Requires:
15%ifarch %{ix86}
16BuildRequires: nasm
17%endif
18%ifarch x86_64
19BuildRequires: yasm
20%endif
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23%description
24Free reimplementation of the OpenDivX video codec. You can play OpenDivX
25and DivX4 videos with it, as well as encode compatible files.
26
27%package devel
28Summary: Development files for the XviD video codec
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33This package contains header files, static library and API
34documentation for the XviD video codec.
35
36%prep
37%setup -q -n %{name}
38
39%build
40cd build/generic
41
42%configure
43make %{?_smp_mflags}
44
45%install
46rm -rf %{buildroot}
47cd build/generic
48%makeinstall
49rm $RPM_BUILD_ROOT%{_libdir}/libxvidcore.a
50cd $RPM_BUILD_ROOT%{_libdir}
51chmod 755 libxvidcore.so*
52/sbin/ldconfig -n .
53ln -s libxvidcore.so.? libxvidcore.so
54
55%post -p /sbin/ldconfig
56
57%postun -p /sbin/ldconfig
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(-,root,root,-)
64%doc LICENSE README AUTHORS ChangeLog TODO
65%{_libdir}/libxvidcore.so.*
66
67%files devel
68%defattr(-,root,root,-)
69%doc CodingStyle examples/
70%{_includedir}/xvid.h
71%{_libdir}/libxvidcore.so
72
73%changelog
74* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-4
75- change release to sync with self-build-xvidcore
76
77* Fri Jun 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-3
78- change release to sync with self-build-xvidcore
79
80* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-2
81- change release to sync with self-build-xvidcore
82
83* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-1
84- new upstream release
85- dropped xvidcore-1.1.3_bitstream.patch
86
87* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-3
88- spec in utf8
89
90* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.1.3-2
91- release +1 to sync with self-build-xvidcore
92
93* Fri Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-1vl4
94- build with new versioning policy
95- apply xvidcore-1.1.3_bitstream.patch
96
97* Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-0vl1
98- initial build for Vine Linux 4.2
99
100### end of file
Note: See TracBrowser for help on using the repository browser.