source: projects/specs/trunk/nonfree/self-build-xvidcore/self-build-xvidcore-vl.spec @ 620

Revision 620, 5.3 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname xvidcore
2%define name    self-build-%{pkgname}
3%define version 1.2.1
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://downloads.xvid.org/downloads/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPL
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21%ifarch %{ix86}
22Requires(post):         nasm
23%endif
24%ifarch x86_64
25Requires(post):         yasm
26%endif
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Packager:       munepi
31
32%description
33xvidcore is the free reimplementation of the OpenDivX video codec.
34
35If you install this package, it automaticaly downloads source
36code ,compile it, and create rpm packages of %{pkgname}-%{version}.
37And the created rpm packages are automatically installed
38if installation is executed by apt-get command or synaptic
39package manager.
40
41[Note]
42This package requires many other packages to compile
43targetsoftware. So it consume more disk space than usual.
44Also installation takes logner time because of compilation.
45(This will take a few minutes to quarter or half of an hour,
46depends on building environment)
47
48[About self-build package]
49For some kind of software, distributing of binary package
50may viorate the patent or law. Therefore we chose self-build
51packge, create binary package on your machine, for such kind
52of softwares instead of distributing binary package.
53
54Please obey the national law when you use the created binary
55packages. And if you want to use the softwares using patented
56thechnology, it may be required to get a permission, make an
57agreement or purchas a license. Please consider it with your
58purpose or way of use and take appropriate action.
59
60%description -l ja
61xvidcore は OpenDivX プロジェクトによるビデオコーデックを
62オープンソースで開発継続されているものです。
63
64このパッケージをインストールすると、自動的にソースコードを
65ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
66パッケージを作成します。
67また apt-get コマンドや synaptic パッケージマネージャから実行
68した場合は、作成された rpm パッケージのインストールも自動的に
69行います。
70
71[注意]
72コンパイルに必要な多くの関連パッケージを要求するので通常より
73ディスクの領域を多く消費します。
74またインストール時にコンパイルを行うため、通常より時間がかか
75る場合があります。(環境にもよりますが数分から数十分程度)
76
77[self-build パッケージについて]
78ソフトウェアによってはバイナリパッケージの配布が特許や法律に
79違反する可能性があるものがあります。その為、このような問題が
80懸念されるソフトウェアについてはバイナリパッケージを直接配布
81せずに、ユーザの環境でバイナリを作成する self-build パッケー
82ジという方法を採っています。
83
84作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
85アのライセンス、および利用する国の各種法令に従ってください。
86また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
87センスの購入などが必要となる場合がありますので、利用する目的
88や形態に応じて各自で判断し適切な対応を取ってください。
89
90
91%prep
92[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 10000
104/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
105                                 %{pkgname}-devel-%{version}-%{release}
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}
110
111%changelog
112* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-4
113- renamed %%{Source0} to xvidcore-vl.spec
114
115* Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-3
116- dropped BuildArch: noarch
117  (because if BuildArch: noarch, %%ifarch is invalid)
118
119* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-2
120- added BuildArch: noarch
121- avoided to execute self-build-rpm.sh on RPM transaction
122  - moved %%post actions to %%posttrans
123
124* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-1
125- new upstream release
126- dropped xvidcore-1.1.3_bitstream.patch
127
128* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-3
129- spec in utf8
130
131* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.1.3-2
132- run pre-allocate-rpm.sh in %%post
133- set PreReq: self-build-setup >= 0.8
134
135* Fri Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-1vl4
136- build with new versioning policy
137- apply xvidcore-1.1.3_bitstream.patch
138
139* Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-0vl1
140- initial build for Vine Linux 4.2
141
142### end of file
Note: See TracBrowser for help on using the repository browser.