source: projects/specs/trunk/nonfree/self-build-xvidcore/self-build-xvidcore-vl.spec @ 4176

Revision 4176, 5.6 KB checked in by munepi, 13 years ago (diff)

updated self-build-xvidcore

Line 
1%define pkgname xvidcore
2%define name    self-build-%{pkgname}
3%define version 1.3.2
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://downloads.xvid.org/downloads/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires(post):         nasm >= 2.0
22
23BuildArch:      noarch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Packager:       munepi
27
28%description
29xvidcore is the free reimplementation of the OpenDivX video codec.
30
31If you install this package, it automaticaly downloads source
32code ,compile it, and create rpm packages of %{pkgname}-%{version}.
33And the created rpm packages are automatically installed
34if installation is executed by apt-get command or synaptic
35package manager.
36
37[Note]
38This package requires many other packages to compile
39targetsoftware. So it consume more disk space than usual.
40Also installation takes logner time because of compilation.
41(This will take a few minutes to quarter or half of an hour,
42depends on building environment)
43
44[About self-build package]
45For some kind of software, distributing of binary package
46may viorate the patent or law. Therefore we chose self-build
47packge, create binary package on your machine, for such kind
48of softwares instead of distributing binary package.
49
50Please obey the national law when you use the created binary
51packages. And if you want to use the softwares using patented
52thechnology, it may be required to get a permission, make an
53agreement or purchas a license. Please consider it with your
54purpose or way of use and take appropriate action.
55
56%description -l ja
57xvidcore は OpenDivX プロジェクトによるビデオコーデックを
58オープンソースで開発継続されているものです。
59
60このパッケージをインストールすると、自動的にソースコードを
61ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
62パッケージを作成します。
63また apt-get コマンドや synaptic パッケージマネージャから実行
64した場合は、作成された rpm パッケージのインストールも自動的に
65行います。
66
67[注意]
68コンパイルに必要な多くの関連パッケージを要求するので通常より
69ディスクの領域を多く消費します。
70またインストール時にコンパイルを行うため、通常より時間がかか
71る場合があります。(環境にもよりますが数分から数十分程度)
72
73[self-build パッケージについて]
74ソフトウェアによってはバイナリパッケージの配布が特許や法律に
75違反する可能性があるものがあります。その為、このような問題が
76懸念されるソフトウェアについてはバイナリパッケージを直接配布
77せずに、ユーザの環境でバイナリを作成する self-build パッケー
78ジという方法を採っています。
79
80作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
81アのライセンス、および利用する国の各種法令に従ってください。
82また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
83センスの購入などが必要となる場合がありますので、利用する目的
84や形態に応じて各自で判断し適切な対応を取ってください。
85
86
87%prep
88[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
89
90%install
91%{__rm} -rf ${RPM_BUILD_ROOT}
92%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
93%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
94
95%clean
96%{__rm} -rf ${RPM_BUILD_ROOT}
97
98%posttrans
99/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 34000
100/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
101                                 %{pkgname}-devel-%{version}-%{release}
102
103%files
104%defattr(-,root,root)
105%{_datadir}/%{name}
106
107%changelog
108* Sat Jun 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.2-1
109- new upstream release
110- dropped upstreamed noexec stack patch
111
112* Sat Dec 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
113- added BuildArch: noarch
114- updated xvidcore-vl.spec
115  - new upstream release
116  - applied a rebase noexec-stack patch from RPM Fusion development
117
118* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-4
119- renamed %%{Source0} to xvidcore-vl.spec
120
121* Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-3
122- dropped BuildArch: noarch
123  (because if BuildArch: noarch, %%ifarch is invalid)
124
125* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-2
126- added BuildArch: noarch
127- avoided to execute self-build-rpm.sh on RPM transaction
128  - moved %%post actions to %%posttrans
129
130* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-1
131- new upstream release
132- dropped xvidcore-1.1.3_bitstream.patch
133
134* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-3
135- spec in utf8
136
137* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.1.3-2
138- run pre-allocate-rpm.sh in %%post
139- set PreReq: self-build-setup >= 0.8
140
141* Fri Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-1vl4
142- build with new versioning policy
143- apply xvidcore-1.1.3_bitstream.patch
144
145* Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-0vl1
146- initial build for Vine Linux 4.2
147
148### end of file
Note: See TracBrowser for help on using the repository browser.