source: projects/specs/trunk/nonfree/self-build-xine-lib-extras/self-build-xine-lib-extras-vl.spec @ 7786

Revision 7786, 6.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define pkgname xine-lib-extras
2%define source_name xine-lib
3##########################
4## %define For pre-allocate-rpm.sh
5
6Summary:        Package to automatically build %{pkgname} rpm package
7Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
8Name:           self-build-%{pkgname}
9Version:        1.1.21
10Release:        1%{?_dist_release}
11License:        GPLv2
12Group:          Restricted Software
13
14Source0:        %{pkgname}-vl.spec
15
16%define sourceurl http://ftp.jaist.ac.jp/pub/sourceforge/x/xi/xine/%{source_name}/%{version}/%{source_name}-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildArch: noarch
20Requires(post): self-build-setup
21
22# (build)requies of target package.
23Requires(post): xine-lib = %{version}
24%if %{?_dist_release} == "vl4"
25Requires(post): XOrg-devel
26Requires(post): XOrg-gl-devel
27%else
28Requires(post): libX11-devel
29Requires(post): libXv-devel
30Requires(post): libXinerama-devel
31Requires(post): libXvMC-devel
32Requires(post): libGLU-devel
33Requires(post): libxcb-devel
34%endif
35# Video
36# Audio
37Requires(post):  self-build-faad2
38Requires(post):  pkgconfig
39Requires(post):  libtool-ltdl-devel
40Requires(post):  vine-release >= 4.2-1vl4
41
42Provides: self-build-xine-lib-faad = %{version}-%{release}
43Obsoletes: self-build-xine-lib-faad
44
45%description
46addtional plugins for xine
47
48If you install this package, it automaticaly downloads source
49code, compile it, and create rpm packages of
50%{pkgname}-%{version}.
51And the created rpm packages are automatically installed
52if installation is executed by apt-get command or synaptic
53package manager.
54
55
56[Note]
57This package requires many other packages to compile
58targetsoftware. So it consume more disk space than usual.
59Also installation takes logner time because of compilation.
60(This will take a few minutes to quarter or half of an hour,
61depends on building environment)
62
63[About self-build package]
64For some kind of software, distributing of binary package
65may viorate the patent or law. Therefore we chose self-build
66packge, create binary package on your machine, for such kind
67of softwares instead of distributing binary package.
68
69Please obey the national law when you use the created binary
70packages. And if you want to use the softwares using patented
71thechnology, it may be required to get a permission, make an
72agreement or purchas a license. Please consider it with your
73purpose or way of use and take appropriate action.
74
75%description -l ja
76このパッケージには  xine 向けの追加プラグインが含まれています。
77
78このパッケージをインストールすると、自動的にソースコードを
79ダウンロードしてコンパイルし、%{pkgname}-%{version}
80の rpm パッケージを作成します。
81また apt-get コマンドや synaptic パッケージマネージャから実行
82した場合は、作成された rpm パッケージのインストールも自動的に
83行います。
84
85
86[注意]
87コンパイルに必要な多くの関連パッケージを要求するので通常より
88ディスクの領域を多く消費します。
89またインストール時にコンパイルを行うため、通常より時間がかか
90る場合があります。(環境にもよりますが数分から数十分程度)
91
92[self-build パッケージについて]
93ソフトウェアによってはバイナリパッケージの配布が特許や法律に
94違反する可能性があるものがあります。その為、このような問題が
95懸念されるソフトウェアについてはバイナリパッケージを直接配布
96せずに、ユーザの環境でバイナリを作成する self-build パッケー
97ジという方法を採っています。
98
99作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
100アのライセンス、および利用する国の各種法令に従ってください。
101また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
102センスの購入などが必要となる場合がありますので、利用する目的
103や形態に応じて各自で判断し適切な対応を取ってください。
104
105
106%install
107%{__rm} -rf ${RPM_BUILD_ROOT}
108%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
109%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114%posttrans
115/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl}
116
117#/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname_2}-%{version_2}-%{release_2} \
118#                                 %{pkgname_2}-devel-%{version_2}-%{release_2}
119%files
120%defattr(-,root,root)
121%{_datadir}/%{name}
122
123%changelog
124* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.21-1
125- new upstream release
126
127* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.19-1
128- new upstream release
129
130* Fri Mar 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.18.1-1
131- new upstream release
132- built with new toolchain
133
134* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.16.3-2
135- added BuildArch: noarch
136- avoided to execute self-build-rpm.sh on RPM transaction
137  - moved %%post actions to %%posttrans
138
139* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.16.3-1
140- new upstream release with security fix
141  - Fix another possible int overflow in the 4XM demuxer.
142    (ref. TKADV2009-004, CVE-2009-0385)
143  - Fix an integer overflow in the Quicktime demuxer.
144
145* Sun Mar  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.16.2-3
146- removed BuildRequires: faad2-devel
147- updated URL
148
149* Wed Feb 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.16.2-2
150- fixed Provides and Obsoletes
151
152* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.16.2-1
153- new upstream release
154- changed Group to Restricted Software
155
156* Wed Feb 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.16.1-1
157- new upstream release
158
159* Sun Feb 08 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.15-7
160- changed name xine-lib-extras
161
162* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.15-6
163- spec in utf8
164- add the list of all PreReq: packages in self-build-xine-lib-faad.spec
165  to BuildRequires: in xine-lib-faad.spec
166
167* Sun Sep 28 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.1.15-5
168- Typo Fixes(xine-lib-faad.spec)
169* Sun Sep 28 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.1.15-4
170- drop self-build-faac(PreReq)
171- drop pre-allocate-rpm.sh
172* Mon Sep 22 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.1.15-3
173- add: pre-allocate-rpm.sh
174* Tue Sep 16 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.1.15-2
175- devel package to add prereq.
176- Drop BuildRequires.
177- Add prereq: faad2-devel, self-build-faac
178* Sun Aug 24 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.1.15-1
179- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.