source: projects/specs/trunk/nonfree/self-build-xbmc/xbmc-vl.spec @ 2635

Revision 2635, 6.8 KB checked in by kazutaka, 13 years ago (diff)

livbdpau-devel を Vine 5でも要求するように変更

Line 
1Summary:        XBMC is a free Media Center
2Summary(ja):    XBMC メディアセンター
3Name:           xbmc
4Version:        10.0
5Release:        3%{?_dist_release}
6Source0:        %{name}-%{version}.tar.gz
7Source1:        %{name}.desktop
8#i18n
9#Source10:      xbmc-9.11-langinfo.xml
10Source11:       xbmc-10.0-strings.xml
11Source12:       xbmc-10.0-Confluence-strings.xml
12#lircd patch
13#Patch0:                xbmc-9.11-lircd.patch
14# change default locale and font
15Patch1:         xbmc-10.0-default-locale.patch
16License:        GPL
17Group:          Applications/Multimedia
18URL:            http://xbmc.org/
19
20Requires:       lsb
21Requires:       python-imaging
22Requires:       pysqlite
23Requires:       hicolor-icon-theme
24Requires(post):  desktop-file-utils
25Requires(postun):desktop-file-utils
26
27BuildRequires:  MySQL-devel
28BuildRequires:  SDL_image-devel
29BuildRequires:  SDL_mixer-devel
30BuildRequires:  alsa-lib-devel
31BuildRequires:  avahi-devel
32BuildRequires:  bzip2-devel
33BuildRequires:  cmake
34BuildRequires:  curl-devel
35BuildRequires:  cvs
36BuildRequires:  dbus-devel
37BuildRequires:  desktop-file-utils
38BuildRequires:  enca-devel
39BuildRequires:  flac-devel
40BuildRequires:  fontconfig-devel
41BuildRequires:  fribidi-devel
42BuildRequires:  glew-devel
43BuildRequires:  gperf
44BuildRequires:  hal-devel
45BuildRequires:  jasper-devel
46BuildRequires:  libXinerama-devel
47BuildRequires:  libXmu-devel
48BuildRequires:  libXrandr-devel
49BuildRequires:  libXtst-devel
50BuildRequires:  libboost-devel
51BuildRequires:  libcdio-devel
52BuildRequires:  expat-devel
53BuildRequires:  libjpeg-devel
54BuildRequires:  libmicrohttpd-devel
55BuildRequires:  libmms-devel
56BuildRequires:  libmodplug-devel
57BuildRequires:  libogg-devel
58BuildRequires:  libpng-devel
59BuildRequires:  libsamplerate-devel
60BuildRequires:  libsmbclient-devel
61BuildRequires:  libtiff-devel
62BuildRequires:  libvorbis-devel
63BuildRequires:  nasm
64BuildRequires:  openssl-devel
65BuildRequires:  lzo-devel
66BuildRequires:  pcre-devel
67BuildRequires:  pulseaudio-libs-devel
68BuildRequires:  sqlite3-devel
69BuildRequires:  unzip
70BuildRequires:  wavpack-devel
71BuildRequires:  zlib-devel
72BuildRequires:  self-build-faac
73BuildRequires:  self-build-faad2
74BuildRequires:  self-build-libmad
75BuildRequires:  self-build-libmpeg2
76BuildRequires:  libvdpau-devel
77BuildRoot:      %{_tmppath}/%{name}-%{version}-root
78
79Packager:       kazutaka
80
81%description
82XBMC is an award-winning free and open source (GPL) software media player
83and entertainment hub for digital media.
84
85Currently XBMC can be used to play almost all popular audio and video formats
86around. It was designed for network playback, so you can stream your multimedia
87from anywhere in the house or directly from the internet using practically any
88protocol available. Use your media as-is: XBMC can play CDs and DVDs directly
89from the disk or image file, almost all popular archive formats from your hard
90drive, and even files inside ZIP and RAR archives. It will even scan all of
91your media and automatically create a personalized library complete with box
92covers, descriptions, and fanart. There are playlist and slideshow functions,
93a weather forecast feature and many audio visualizations. Once installed,
94your computer will become a fully functional multimedia jukebox.
95
96%description -l ja
97XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
98デジタルメディア向けのメディアプレイヤー/メディアセンターです。
99
100XBMC は一般的な形式のビデオやオーディオファイルであれば、その殆ど
101を再生できます。またネットワークを介した再生にも対応しており、
102ホームLAN やインターネットを経由したストリーミングも利用できます。
103
104また、XBMC は CD や DVD を直接再生できるだけでなく、ハードディスク
105上のディスクイメージや一般的なアーカイブ、ZIP や RAR アーカイブ等で
106あってもそのまま利用できます。
107
108XBMC は PC 上のメディアファイルをスキャンして、自動的にライブラリ
109を構築し、カバーアートや説明、ファンアート等を付加してくれます。
110その他にも、プレイリストやスライドショー、天気予報、オーディオの
111ビジュアライゼーション機能等を備えています。
112
113XBMC をインストールすれば、あなたの PC は多機能なマルチメディア
114ジュークボックスに生まれ変わります。
115
116
117%prep
118%setup -q
119%patch1 -p1 -b .default-locale
120
121#setup language files
122#%{__cp} -f %{SOURCE10} language/Japanese/langinfo.xml
123%{__cp} -f %{SOURCE11} language/Japanese/strings.xml
124%{__mkdir} addons/skin.confluence/language/Japanese
125%{__cp} -f %{SOURCE12} addons/skin.confluence/language/Japanese/strings.xml
126
127%build
128%ifarch x86_64
129LIBS="-L/usr/lib64/mysql $LIBS"
130%else
131LIBS="-L/usr/lib/mysql $LIBS"
132%endif
133
134export LIBS
135
136./bootstrap
137%configure --disable-debug \
138           --disable-ccache \
139           --enable-pulse \
140           --enable-dvdcss \
141           --enable-vdpau  \
142           --enable-mid \
143           --with-lirc-device=%{_localstatedir}/run/lirc/lircd \
144           --docdir=%{_docdir}/%{name}-%{version}
145
146%{__make} %{?_smp_mflags}
147
148
149%install
150%{__rm} -rf $RPM_BUILD_ROOT
151%{__make} install DESTDIR=$RPM_BUILD_ROOT
152
153#install man pages
154%{__mkdir_p} $RPM_BUILD_ROOT/%{_mandir}/man1
155%{__cp} docs/manpages/* $RPM_BUILD_ROOT/%{_mandir}/man1
156gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man1/*
157
158# Install desktop file
159desktop-file-install --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE1}
160
161
162%post
163update-desktop-database %{_datadir}/applications>& /dev/null ||:
164touch --no-create %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
167fi
168
169%postun
170update-desktop-database %{_datadir}/applications>& /dev/null ||:
171touch --no-create %{_datadir}/icons/hicolor
172if [ -x /usr/bin/gtk-update-icon-cache ]; then
173  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
174fi
175
176
177%clean
178%{__rm} -rf $RPM_BUILD_ROOT
179
180
181%files
182%defattr(-,root,root)
183%doc %{_docdir}/%{name}-%{version}
184%{_bindir}/%{name}
185%{_bindir}/%{name}-standalone
186%{_datadir}/%{name}
187%{_datadir}/applications/%{name}.desktop
188%{_datadir}/xsessions/XBMC.desktop
189%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
190%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
191%{_libdir}/%{name}
192%{_mandir}/man1/*
193
194%changelog
195* Fri Feb 04 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-3
196- delete build_vine5 macro: libvdpau is now available on 5.2
197
198* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-2
199- add --disable-ccache option (<BTS:VineLinux:1100>)
200- update Patch1 to change default timezone
201
202* Tue Jan 18 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
203- new upstream release
204- drop patch0: use configure option to specity lirc device)
205- drop Source10: included in upstream
206- update Source11 & 12: japanese translation
207- add Souce1: xbmc.desktop with japanese description
208
209* Sat Jan 02 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9.11-1
210- initial build for Vine Linux
211- add patch0: change lircd socket location
212- add Source10-12: japanese translation & langinfo
Note: See TracBrowser for help on using the repository browser.