source: projects/specs/trunk/nonfree/self-build-xbmc/xbmc-vl.spec @ 2597

Revision 2597, 6.8 KB checked in by kazutaka, 13 years ago (diff)

リポジトリに追加

Line 
1%define build_vine5 0
2
3%if "%{?_dist_release}" == "vl5"
4%define build_vine5 1
5%endif
6
7Summary:        XBMC is a free Media Center
8Summary(ja):    XBMC メディアセンター
9Name:           xbmc
10Version:        10.0
11Release:        2%{?_dist_release}
12Source0:        %{name}-%{version}.tar.gz
13Source1:        %{name}.desktop
14#i18n
15#Source10:      xbmc-9.11-langinfo.xml
16Source11:       xbmc-10.0-strings.xml
17Source12:       xbmc-10.0-Confluence-strings.xml
18#lircd patch
19#Patch0:                xbmc-9.11-lircd.patch
20# change default locale and font
21Patch1:         xbmc-10.0-default-locale.patch
22License:        GPL
23Group:          Applications/Multimedia
24URL:            http://xbmc.org/
25
26Requires:       lsb
27Requires:       python-imaging
28Requires:       pysqlite
29Requires:       hicolor-icon-theme
30Requires(post):  desktop-file-utils
31Requires(postun):desktop-file-utils
32
33BuildRequires:  MySQL-devel
34BuildRequires:  SDL_image-devel
35BuildRequires:  SDL_mixer-devel
36BuildRequires:  alsa-lib-devel
37BuildRequires:  avahi-devel
38BuildRequires:  bzip2-devel
39BuildRequires:  cmake
40BuildRequires:  curl-devel
41BuildRequires:  cvs
42BuildRequires:  dbus-devel
43BuildRequires:  desktop-file-utils
44BuildRequires:  enca-devel
45BuildRequires:  flac-devel
46BuildRequires:  fontconfig-devel
47BuildRequires:  fribidi-devel
48BuildRequires:  glew-devel
49BuildRequires:  gperf
50BuildRequires:  hal-devel
51BuildRequires:  jasper-devel
52BuildRequires:  libXinerama-devel
53BuildRequires:  libXmu-devel
54BuildRequires:  libXrandr-devel
55BuildRequires:  libXtst-devel
56BuildRequires:  libboost-devel
57BuildRequires:  libcdio-devel
58BuildRequires:  expat-devel
59BuildRequires:  libjpeg-devel
60BuildRequires:  libmicrohttpd-devel
61BuildRequires:  libmms-devel
62BuildRequires:  libmodplug-devel
63BuildRequires:  libogg-devel
64BuildRequires:  libpng-devel
65BuildRequires:  libsamplerate-devel
66BuildRequires:  libsmbclient-devel
67BuildRequires:  libtiff-devel
68BuildRequires:  libvorbis-devel
69BuildRequires:  nasm
70BuildRequires:  openssl-devel
71BuildRequires:  lzo-devel
72BuildRequires:  pcre-devel
73BuildRequires:  pulseaudio-libs-devel
74BuildRequires:  sqlite3-devel
75BuildRequires:  unzip
76BuildRequires:  wavpack-devel
77BuildRequires:  zlib-devel
78BuildRequires:  self-build-faac
79BuildRequires:  self-build-faad2
80BuildRequires:  self-build-libmad
81BuildRequires:  self-build-libmpeg2
82%if !%{build_vine5}
83BuildRequires:  libvdpau-devel
84%endif
85BuildRoot:      %{_tmppath}/%{name}-%{version}-root
86
87Packager:       kazutaka
88
89%description
90XBMC is an award-winning free and open source (GPL) software media player
91and entertainment hub for digital media.
92
93Currently XBMC can be used to play almost all popular audio and video formats
94around. It was designed for network playback, so you can stream your multimedia
95from anywhere in the house or directly from the internet using practically any
96protocol available. Use your media as-is: XBMC can play CDs and DVDs directly
97from the disk or image file, almost all popular archive formats from your hard
98drive, and even files inside ZIP and RAR archives. It will even scan all of
99your media and automatically create a personalized library complete with box
100covers, descriptions, and fanart. There are playlist and slideshow functions,
101a weather forecast feature and many audio visualizations. Once installed,
102your computer will become a fully functional multimedia jukebox.
103
104%description -l ja
105XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
106デジタルメディア向けのメディアプレイヤー/メディアセンターです。
107
108XBMC は一般的な形式のビデオやオーディオファイルであれば、その殆ど
109を再生できます。またネットワークを介した再生にも対応しており、
110ホームLAN やインターネットを経由したストリーミングも利用できます。
111
112また、XBMC は CD や DVD を直接再生できるだけでなく、ハードディスク
113上のディスクイメージや一般的なアーカイブ、ZIP や RAR アーカイブ等で
114あってもそのまま利用できます。
115
116XBMC は PC 上のメディアファイルをスキャンして、自動的にライブラリ
117を構築し、カバーアートや説明、ファンアート等を付加してくれます。
118その他にも、プレイリストやスライドショー、天気予報、オーディオの
119ビジュアライゼーション機能等を備えています。
120
121XBMC をインストールすれば、あなたの PC は多機能なマルチメディア
122ジュークボックスに生まれ変わります。
123
124
125%prep
126%setup -q
127%patch1 -p1 -b .default-locale
128
129#setup language files
130#%{__cp} -f %{SOURCE10} language/Japanese/langinfo.xml
131%{__cp} -f %{SOURCE11} language/Japanese/strings.xml
132%{__mkdir} addons/skin.confluence/language/Japanese
133%{__cp} -f %{SOURCE12} addons/skin.confluence/language/Japanese/strings.xml
134
135%build
136%ifarch x86_64
137LIBS="-L/usr/lib64/mysql $LIBS"
138%else
139LIBS="-L/usr/lib/mysql $LIBS"
140%endif
141
142export LIBS
143
144./bootstrap
145%configure --disable-debug \
146           --disable-ccache \
147           --enable-pulse \
148           --enable-dvdcss \
149           --enable-vdpau  \
150           --enable-mid \
151           --with-lirc-device=%{_localstatedir}/run/lirc/lircd \
152           --docdir=%{_docdir}/%{name}-%{version}
153
154%{__make} %{?_smp_mflags}
155
156
157%install
158%{__rm} -rf $RPM_BUILD_ROOT
159%{__make} install DESTDIR=$RPM_BUILD_ROOT
160
161#install man pages
162%{__mkdir_p} $RPM_BUILD_ROOT/%{_mandir}/man1
163%{__cp} docs/manpages/* $RPM_BUILD_ROOT/%{_mandir}/man1
164gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man1/*
165
166# Install desktop file
167desktop-file-install --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE1}
168
169
170%post
171update-desktop-database %{_datadir}/applications>& /dev/null ||:
172touch --no-create %{_datadir}/icons/hicolor
173if [ -x /usr/bin/gtk-update-icon-cache ]; then
174  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
175fi
176
177%postun
178update-desktop-database %{_datadir}/applications>& /dev/null ||:
179touch --no-create %{_datadir}/icons/hicolor
180if [ -x /usr/bin/gtk-update-icon-cache ]; then
181  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
182fi
183
184
185%clean
186%{__rm} -rf $RPM_BUILD_ROOT
187
188
189%files
190%defattr(-,root,root)
191%doc %{_docdir}/%{name}-%{version}
192%{_bindir}/%{name}
193%{_bindir}/%{name}-standalone
194%{_datadir}/%{name}
195%{_datadir}/applications/%{name}.desktop
196%{_datadir}/xsessions/XBMC.desktop
197%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
198%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
199%{_libdir}/%{name}
200%{_mandir}/man1/*
201
202%changelog
203* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-2
204- add --disable-ccache option (<BTS:VineLinux:1100>)
205- update Patch1 to change default timezone
206
207* Tue Jan 18 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
208- new upstream release
209- drop patch0: use configure option to specity lirc device)
210- drop Source10: included in upstream
211- update Source11 & 12: japanese translation
212- add Souce1: xbmc.desktop with japanese description
213
214* Sat Jan 02 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9.11-1
215- initial build for Vine Linux
216- add patch0: change lircd socket location
217- add Source10-12: japanese translation & langinfo
Note: See TracBrowser for help on using the repository browser.