source: projects/specs/trunk/nonfree/self-build-xbmc/self-build-xbmc-vl.spec @ 4236

Revision 4236, 6.5 KB checked in by shaolin, 13 years ago (diff)
  • self-build-xbmc: new upstream release
Line 
1%define pkgname xbmc
2%define name    self-build-%{pkgname}
3
4%define sourceurl http://mirrors.xbmc.org/releases/source/%{pkgname}-%{version}.tar.gz
5
6Summary:        Package to automatically build %{pkgname} rpm package
7Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
8Name:           %{name}
9Version:        10.1
10Release:        1%{?_dist_release}
11Source0:        %{pkgname}-vl.spec
12Source1:        %{pkgname}.desktop
13Source2:        %{pkgname}-%{version}-strings.xml
14Source3:        %{pkgname}-%{version}-Confluence-strings.xml
15Source4:        %{pkgname}-%{version}-default-locale.patch
16
17License:        GPL
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.8
21
22# (build)requies of target package.
23Requires(post): lsb
24Requires(post): python-imaging
25Requires(post): pysqlite
26Requires(post): hicolor-icon-theme
27Requires(post): desktop-file-utils
28
29Requires(post): MySQL-devel
30Requires(post): SDL_image-devel
31Requires(post): SDL_mixer-devel
32Requires(post): alsa-lib-devel
33Requires(post): avahi-devel
34Requires(post): bzip2-devel
35Requires(post): cmake
36Requires(post): curl-devel
37Requires(post): cvs
38Requires(post): dbus-devel
39Requires(post): desktop-file-utils
40Requires(post): enca-devel
41Requires(post): flac-devel
42Requires(post): fontconfig-devel
43Requires(post): fribidi-devel
44Requires(post): glew-devel
45Requires(post): gperf
46Requires(post): hal-devel
47Requires(post): jasper-devel
48Requires(post): libXinerama-devel
49Requires(post): libXmu-devel
50Requires(post): libXrandr-devel
51Requires(post): libXtst-devel
52Requires(post): libboost-devel
53Requires(post): libcdio-devel
54Requires(post): expat-devel
55Requires(post): libjpeg-devel
56Requires(post): libmicrohttpd-devel
57Requires(post): libmms-devel
58Requires(post): libmodplug-devel
59Requires(post): libogg-devel
60Requires(post): libpng-devel
61Requires(post): libsamplerate-devel
62Requires(post): libsmbclient-devel
63Requires(post): libtiff-devel
64Requires(post): libvorbis-devel
65Requires(post): nasm
66Requires(post): openssl-devel
67Requires(post): lzo-devel
68Requires(post): pcre-devel
69Requires(post): pulseaudio-libs-devel
70Requires(post): sqlite3-devel
71Requires(post): unzip
72Requires(post): wavpack-devel
73Requires(post): zlib-devel
74Requires(post): self-build-faac
75Requires(post): self-build-faad2
76Requires(post): self-build-libmad
77Requires(post): self-build-libmpeg2
78Requires(post): libvdpau-devel
79
80BuildRoot:      %{_tmppath}/%{name}-%{version}-root
81
82Packager:       kazutaka, shaolin
83
84%description
85XBMC is an award-winning free and open source (GPL) software
86media player and entertainment hub for digital media.
87
88If you install this package, it automaticaly downloads source
89code ,compile it, and create rpm packages of %{pkgname}-%{version}.
90And the created rpm packages are automatically installed
91if installation is executed by apt-get command or synaptic
92package manager.
93
94[Note]
95This package requires many other packages to compile
96targetsoftware. So it consume more disk space than usual.
97Also installation takes logner time because of compilation.
98(This will take a few minutes to quarter or half of an hour,
99depends on building environment)
100
101[About self-build package]
102For some kind of software, distributing of binary package
103may viorate the patent or law. Therefore we chose self-build
104packge, create binary package on your machine, for such kind
105of softwares instead of distributing binary package.
106
107Please obey the national law when you use the created binary
108packages. And if you want to use the softwares using patented
109thechnology, it may be required to get a permission, make an
110agreement or purchas a license. Please consider it with your
111purpose or way of use and take appropriate action.
112
113%description -l ja
114XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
115デジタルメディア向けのメディアプレイヤー/メディアセンターです。
116
117このパッケージをインストールすると、自動的にソースコードを
118ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
119パッケージを作成します。
120また apt-get コマンドや synaptic パッケージマネージャから実行
121した場合は、作成された rpm パッケージのインストールも自動的に
122行います。
123
124[注意]
125コンパイルに必要な多くの関連パッケージを要求するので通常より
126ディスクの領域を多く消費します。
127またインストール時にコンパイルを行うため、通常より時間がかか
128る場合があります。(環境にもよりますが数分から数十分程度)
129
130[self-build パッケージについて]
131ソフトウェアによってはバイナリパッケージの配布が特許や法律に
132違反する可能性があるものがあります。その為、このような問題が
133懸念されるソフトウェアについてはバイナリパッケージを直接配布
134せずに、ユーザの環境でバイナリを作成する self-build パッケー
135ジという方法を採っています。
136
137作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
138アのライセンス、および利用する国の各種法令に従ってください。
139また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
140センスの購入などが必要となる場合がありますので、利用する目的
141や形態に応じて各自で判断し適切な対応を取ってください。
142
143%prep
144[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
145
146%install
147%{__rm} -rf ${RPM_BUILD_ROOT}
148%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
151%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
152%{__install} -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
153%{__install} -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
154
155
156%clean
157%{__rm} -rf ${RPM_BUILD_ROOT}
158
159
160%posttrans
161/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 2447000
162
163
164%files
165%defattr(-,root,root)
166%{_datadir}/%{name}
167
168
169%changelog
170* Wed Jun 29 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 10.1-1
171- new upstream release
172
173* Fri Feb 04 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-3
174- delete build_vine5 macro: libvdpau is now available on 5.2
175
176* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-2
177- add --disable-ccache option (<BTS:VineLinux:1100>)
178- update Source4 to change default timezone
179
180* Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
181- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.