source: projects/specs/trunk/nonfree/self-build-xbmc/self-build-xbmc-vl.spec @ 2598

Revision 2598, 6.5 KB checked in by kazutaka, 13 years ago (diff)
  • add --disable-ccache option (<BTS:VineLinux:1100>)
  • update Patch1 to change default timezone
Line 
1%define pkgname xbmc
2%define name    self-build-%{pkgname}
3%define version 10.0
4%define release 2%{?_dist_release}
5
6%define sourceurl http://mirrors.xbmc.org/releases/source/%{pkgname}-%{version}.tar.gz
7
8%define build_vine5 0
9
10%if "%{?_dist_release}" == "vl5"
11%define build_vine5 1
12%endif
13
14
15Summary:        Package to automatically build %{pkgname} rpm package
16Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
17Name:           %{name}
18Version:        %{version}
19Release:        %{release}
20Source0:        %{pkgname}-vl.spec
21Source1:        %{pkgname}.desktop
22Source2:        %{pkgname}-%{version}-strings.xml
23Source3:        %{pkgname}-%{version}-Confluence-strings.xml
24Source4:        %{pkgname}-%{version}-default-locale.patch
25
26License:        GPL
27Group:          Restricted Software
28
29Requires(post):         self-build-setup >= 0.8
30
31# (build)requies of target package.
32Requires(post): lsb
33Requires(post): python-imaging
34Requires(post): pysqlite
35Requires(post): hicolor-icon-theme
36Requires(post): desktop-file-utils
37
38Requires(post): MySQL-devel
39Requires(post): SDL_image-devel
40Requires(post): SDL_mixer-devel
41Requires(post): alsa-lib-devel
42Requires(post): avahi-devel
43Requires(post): bzip2-devel
44Requires(post): cmake
45Requires(post): curl-devel
46Requires(post): cvs
47Requires(post): dbus-devel
48Requires(post): desktop-file-utils
49Requires(post): enca-devel
50Requires(post): flac-devel
51Requires(post): fontconfig-devel
52Requires(post): fribidi-devel
53Requires(post): glew-devel
54Requires(post): gperf
55Requires(post): hal-devel
56Requires(post): jasper-devel
57Requires(post): libXinerama-devel
58Requires(post): libXmu-devel
59Requires(post): libXrandr-devel
60Requires(post): libXtst-devel
61Requires(post): libboost-devel
62Requires(post): libcdio-devel
63Requires(post): expat-devel
64Requires(post): libjpeg-devel
65Requires(post): libmicrohttpd-devel
66Requires(post): libmms-devel
67Requires(post): libmodplug-devel
68Requires(post): libogg-devel
69Requires(post): libpng-devel
70Requires(post): libsamplerate-devel
71Requires(post): libsmbclient-devel
72Requires(post): libtiff-devel
73Requires(post): libvorbis-devel
74Requires(post): nasm
75Requires(post): openssl-devel
76Requires(post): lzo-devel
77Requires(post): pcre-devel
78Requires(post): pulseaudio-libs-devel
79Requires(post): sqlite3-devel
80Requires(post): unzip
81Requires(post): wavpack-devel
82Requires(post): zlib-devel
83Requires(post): self-build-faac
84Requires(post): self-build-faad2
85Requires(post): self-build-libmad
86Requires(post): self-build-libmpeg2
87%if !%{build_vine5}
88Requires(post): libvdpau-devel
89%endif
90
91BuildRoot:      %{_tmppath}/%{name}-%{version}-root
92
93Packager:       kazutaka
94
95%description
96XBMC is an award-winning free and open source (GPL) software
97media player and entertainment hub for digital media.
98
99If you install this package, it automaticaly downloads source
100code ,compile it, and create rpm packages of %{pkgname}-%{version}.
101And the created rpm packages are automatically installed
102if installation is executed by apt-get command or synaptic
103package manager.
104
105[Note]
106This package requires many other packages to compile
107targetsoftware. So it consume more disk space than usual.
108Also installation takes logner time because of compilation.
109(This will take a few minutes to quarter or half of an hour,
110depends on building environment)
111
112[About self-build package]
113For some kind of software, distributing of binary package
114may viorate the patent or law. Therefore we chose self-build
115packge, create binary package on your machine, for such kind
116of softwares instead of distributing binary package.
117
118Please obey the national law when you use the created binary
119packages. And if you want to use the softwares using patented
120thechnology, it may be required to get a permission, make an
121agreement or purchas a license. Please consider it with your
122purpose or way of use and take appropriate action.
123
124%description -l ja
125XBMC はいくつもの賞を受賞したフリーでオープンソース (GPL) な、
126デジタルメディア向けのメディアプレイヤー/メディアセンターです。
127
128このパッケージをインストールすると、自動的にソースコードを
129ダウンロードしてコンパイ���し、%{pkgname}-%{version} の rpm
130パッケージを作成します。
131また apt-get コマンドや synaptic パッケージマネージャから実行
132した場合は、作成された rpm パッケージのインストールも自動的に
133行います。
134
135[注意]
136コンパイルに必要な多くの関連パッケージを要求するので通常より
137ディスクの領域を多く消費します。
138またインストール時にコンパイルを行うため、通常より時間がかか
139る場合があります。(環境にもよりますが数分から数十分程度)
140
141[self-build パッケージについて]
142ソフトウェアによってはバイナリパッケージの配布が特許や法律に
143違反する可能性があるものがあります。その為、このような問題が
144懸念されるソフトウェアについてはバイナリパッケージを直接配布
145せずに、ユーザの環境でバイナリを作成する self-build パッケー
146ジという方法を採っています。
147
148作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
149アのライセンス、および利用する国の各種法令に従ってください。
150また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
151センスの購入などが必要となる場合がありますので、利用する目的
152や形態に応じて各自で判断し適切な対応を取ってください。
153
154%prep
155[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
156
157%install
158%{__rm} -rf ${RPM_BUILD_ROOT}
159%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
160%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
161%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
162%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
163%{__install} -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
164%{__install} -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
165
166
167%clean
168%{__rm} -rf ${RPM_BUILD_ROOT}
169
170
171%posttrans
172/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 2447000
173
174
175%files
176%defattr(-,root,root)
177%{_datadir}/%{name}
178
179
180%changelog
181* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-2
182- add --disable-ccache option (<BTS:VineLinux:1100>)
183- update Source4 to change default timezone
184
185* Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 10.0-1
186- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.