source: projects/specs/trunk/nonfree/self-build-x264/x264-vl.spec @ 10524

Revision 10524, 6.1 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1%global snapshot_date   20160122
2%global snapshot_time   2245
3%global branch          stable
4
5Summary: Library for encoding and decoding H264/AVC video streams
6Name: x264
7Version: 0.148
8Release: 2.%{snapshot_date}%{?_dist_release}
9License: GPLv2+
10Group: System Environment/Libraries
11URL: http://www.videolan.org/developers/x264.html
12Source: http://download.videolan.org/pub/x264/snapshots/%{name}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
13BuildRequires: yasm >= 1.0.0
14# gpac-devel package provided by self-build-gpac
15# in self-build-%{name}.spec as PreReq.
16#BuildRequires: gpac-devel
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Provides:       libx264 = %{version}
21Obsoletes:      libx264 < %{version}
22Obsoletes:      x264 < %{version}, x264-devel < %{version}
23
24
25%description
26x264 is a free library for encoding H264/AVC video streams, written from
27scratch.
28
29This package also contains the frontend.
30
31%package devel
32Summary: Development files for the x264 library
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: pkgconfig
36
37%description devel
38x264 is a free library for encoding H264/AVC video streams, written from
39scratch.
40
41This package contains the development files.
42
43%prep
44%setup -q -n %{name}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}
45
46%build
47./configure \
48    --host=%{_target_platform} \
49    --prefix=%{_prefix} \
50    --exec-prefix=%{_exec_prefix} \
51    --bindir=%{_bindir} \
52    --includedir=%{_includedir} \
53    --libdir=%{_libdir} \
54    --extra-cflags="$RPM_OPT_FLAGS" \
55    \
56    %{?_with_visualize:--enable-visualize} \
57    %{!?_with_libavformat:--disable-lavf} \
58    %{!?_with_ffmpegsource:--disable-ffms} \
59    --enable-debug \
60    --enable-shared \
61    --system-libx264 \
62    --enable-pic \
63    ;
64
65
66%{__make} %{?_smp_mflags}
67
68%install
69%{__rm} -rf %{buildroot}
70%{__make} DESTDIR=%{buildroot} install
71
72
73%clean
74%{__rm} -rf %{buildroot}
75
76%post -p /sbin/ldconfig
77
78%postun -p /sbin/ldconfig
79
80
81%files
82%defattr(644, root, root, 0755)
83%doc AUTHORS COPYING
84%attr(755,root,root) %{_bindir}/x264
85%{_libdir}/libx264.so.*
86
87%files devel
88%defattr(644, root, root, 0755)
89%doc doc/*
90%{_includedir}/x264.h
91%{_includedir}/x264_config.h
92%{_libdir}/libx264.so
93%{_libdir}/pkgconfig/%{name}.pc
94
95
96
97%changelog
98* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.148-2.20160122
99- rebuild with libcdio-0.93
100
101* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.148-1.20160122
102- updated source snapshot 20160122 stable branch (ABI 0.148)
103
104* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-5.20141218
105- rebuilt
106
107* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-4.20141218
108- rebuild
109
110* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-3.20141218
111- rebuild
112
113* Sun Jan 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-2.20141218
114- Obsoletes: self-build-x264 < %{version}
115
116* Fri Dec 26 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-1.20141218
117- updated source snapshot 20141218 stable branch (ABI 0.142)
118
119* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.136-1.20130927
120- updated source snapshot 20130927 stable branch (ABI 0.136)
121
122* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.129-1.20130118
123- updated source snapshot 20130118 stable branch (ABI 0.129)
124
125* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.124-1.20120525
126- updated source snapshot 20120525 stable branch (ABI 0.124)
127- changed release number; upstream have release numbers at least on stable branch
128
129* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
130- updated source snapshot 20111216 stable branch (ABI 0.119)
131
132* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
133- updated source snapshot 20111013 stable branch (ABI 0.116)
134
135* Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
136- change release to sync with self-build-x264
137
138* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
139- updated source snapshot 20110322 (ABI 0.114)
140
141* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
142- updated source snapshot 20100625
143
144* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
145- change release to sync with self-build-x264
146
147* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
148- updated source snapshot 20100216
149- applied to link x264 binary to the shared library from RPM Fusion development
150
151* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
152- changed Source0: to http://www.videolan.org/pub/videolan/x264/snapshots
153
154* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
155- change release to sync with self-build-x264
156
157* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
158- 20090522 snapshot
159  - updated x264-vine.patch
160
161* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
162- corrected release number
163
164* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
165- added configure options: --enable-mp4-output
166- added BuildRequires: gpac-devel
167
168* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
169- change release to sync with self-build-x264
170
171* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
172- 20090110 snapshot
173
174* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
175- fixed License: GPLv2+
176- added BuildRequires: gettext
177- source updated
178- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
179  and added x264-vine.patch
180#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
181
182* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
183- spec in utf8
184
185* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
186- apply new versioning policy
187
188* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
189- initial build for Vine Linux 4.2
190
191* Sun Jan 20 2008 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.57-0.r721vlmp1
192- update to SVN r721
193
194* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.56-0.r667vlmp1
195- initial build for Vine Linux 4.1
196
197### end of file
Note: See TracBrowser for help on using the repository browser.