source: projects/specs/trunk/nonfree/self-build-x264/self-build-x264-vl.spec @ 9663

Revision 9663, 8.4 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%global snapshot_date   20141218
2%global snapshot_time   2245
3%global branch          stable
4
5%global pkgname         x264
6%global name            self-build-%{pkgname}
7%global version         0.142
8%global release         5.%{snapshot_date}%{?_dist_release}
9
10#define sourceurl0      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
11%define sourceurl0      http://download.videolan.org/pub/x264/snapshots/%{pkgname}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
12
13Summary:        Package to automatically build %{pkgname} rpm package
14Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
15Name:           %{name}
16Version:        %{version}
17Release:        %{release}
18Source0:        %{pkgname}-vl.spec
19
20License:        GPLv2+
21Group:          Restricted Software
22
23Obsoletes:      x264 < %{version}, x264-devel < %{version}
24Obsoletes:      self-build-x264 < %{version}
25
26Requires(post):         self-build-setup >= 0.9.9
27
28# (build)requies of target package.
29Requires(post): yasm
30Requires(post): self-build-gpac >= 0.5.0
31
32BuildArch:      noarch
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Packager:       munepi
36
37%description
38x264 is a free library for encoding H264/AVC video streams, written from
39scratch.
40
41If you install this package, it automaticaly downloads source
42code ,compile it, and create rpm packages of %{pkgname}-%{version}.
43And the created rpm packages are automatically installed
44if installation is executed by apt-get command or synaptic
45package manager.
46
47[Note]
48This package requires many other packages to compile
49targetsoftware. So it consume more disk space than usual.
50Also installation takes logner time because of compilation.
51(This will take a few minutes to quarter or half of an hour,
52depends on building environment)
53
54[About self-build package]
55For some kind of software, distributing of binary package
56may viorate the patent or law. Therefore we chose self-build
57packge, create binary package on your machine, for such kind
58of softwares instead of distributing binary package.
59
60Please obey the national law when you use the created binary
61packages. And if you want to use the softwares using patented
62thechnology, it may be required to get a permission, make an
63agreement or purchas a license. Please consider it with your
64purpose or way of use and take appropriate action.
65
66%description -l ja
67x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
68コードするためのフリーなライブラリです.
69
70このパッケージをインストールすると、自動的にソースコードを
71ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
72パッケージを作成します。
73また apt-get コマンドや synaptic パッケージマネージャから実行
74した場合は、作成された rpm パッケージのインストールも自動的に
75行います。
76
77[注意]
78コンパイルに必要な多くの関連パッケージを要求するので通常より
79ディスクの領域を多く消費します。
80またインストール時にコンパイルを行うため、通常より時間がかか
81る場合があります。(環境にもよりますが数分から数十分程度)
82
83[self-build パッケージについて]
84ソフトウェアによってはバイナリパッケージの配布が特許や法律に
85違反する可能性があるものがあります。その為、このような問題が
86懸念されるソフトウェアについてはバイナリパッケージを直接配布
87せずに、ユーザの環境でバイナリを作成する self-build パッケー
88ジという方法を採っています。
89
90作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
91アのライセンス、および利用する国の各種法令に従ってください。
92また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
93センスの購入などが必要となる場合がありますので、利用する目的
94や形態に応じて各自で判断し適切な対応を取ってください。
95
96%prep
97[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
98
99
100%install
101%{__rm} -rf ${RPM_BUILD_ROOT}
102%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104
105%clean
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108%posttrans
109/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 24000
110/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
111                                 %{pkgname}-devel-%{version}-%{release}
112
113%files
114%defattr(-,root,root)
115%{_datadir}/%{name}
116
117%changelog
118* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-5.20141218
119- rebuilt
120
121* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-4.20141218
122- rebuild
123
124* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-3.20141218
125- rebuild
126
127* Sun Jan 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-2.20141218
128- Obsoletes: self-build-x264 < %{version}
129
130* Fri Dec 26 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-1.20141218
131- updated source snapshot 20141218 stable branch (ABI 0.142)
132
133* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.136-1.20130927
134- updated source snapshot 20130927 stable branch (ABI 0.136)
135
136* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.129-1.20130118
137- updated source snapshot 20130118 stable branch (ABI 0.129)
138
139* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.124-1.20120525
140- updated source snapshot 20120525 stable branch (ABI 0.124)
141- changed release number; upstream have release numbers at least on stable branch
142
143* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
144- updated source snapshot 20111216 stable branch (ABI 0.119)
145
146* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
147- updated source snapshot 20111013 stable branch (ABI 0.116)
148
149* Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
150- changed to depend on %%{version} for Obsoletes: x264
151- added BuildArch: noarch
152
153* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
154- updated source snapshot 20110322
155
156* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
157- updated source snapshot 20100625
158
159* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
160- renamed %%{Source0} to x264-vl.spec
161
162* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
163- updated source snapshot 20100216
164- applied to link x264 binary to the shared library from RPM Fusion development
165
166* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
167- changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
168- check version between original spec and self-build spec in %%prep
169
170* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
171- dropped BuildArch: noarch
172
173* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
174- 20090522 snapshot
175  - updated x264-vine.patch
176- added BuildArch: noarch
177- avoided to execute self-build-rpm.sh on RPM transaction
178  - moved %%post actions to %%posttrans
179
180* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
181- corrected release number in x264.spec
182
183* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
184- enable asm on x86/x86_64 arch. (fix typo?)
185
186* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
187- added PreReq: self-build-gpac
188
189* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
190- dropped PreReq: nasm for x86
191- added PreReq: yasm for x86
192
193* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
194- 20090110 snapshot
195
196* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
197- fixed License: GPLv2+
198- added BuildRequires: gettext
199- source updated
200- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
201  and added x264-vine.patch
202#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
203
204* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
205- spec in utf8
206
207* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
208- run pre-allocate-rpm.sh in %%post
209- set PreReq: self-build-setup >= 0.8
210- apply new versioning policy
211
212* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
213- initial build for Vine Linux 4.2
214
215### end of file
Note: See TracBrowser for help on using the repository browser.