source: projects/specs/trunk/nonfree/self-build-x264/self-build-x264-vl.spec @ 615

Revision 615, 6.9 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname x264
2%define name    self-build-%{pkgname}
3%define version 0.0.0
4%define date    20100216
5%define time    2245
6%define release 13.%{date}%{?_dist_release}
7
8#define sourceurl0      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
9%define sourceurl0      http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
10
11Summary:        Package to automatically build %{pkgname} rpm package
12Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
13Name:           %{name}
14Version:        %{version}
15Release:        %{release}
16Source0:        %{pkgname}-vl.spec
17Source1:        %{pkgname}.desktop
18Source111:      %{pkgname}-shared.patch
19Source112:      %{pkgname}-nostrip.patch
20
21License:        GPLv2+
22Group:          Restricted Software
23
24Requires(post):         self-build-setup >= 0.9.9
25
26# (build)requies of target package.
27%ifarch x86_64 %{ix86}
28Requires(post): yasm
29%endif
30Requires(post): self-build-gpac
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34Packager:       munepi
35
36%description
37x264 is a free library for encoding H264/AVC video streams, written from
38scratch.
39
40If you install this package, it automaticaly downloads source
41code ,compile it, and create rpm packages of %{pkgname}-%{version}.
42And the created rpm packages are automatically installed
43if installation is executed by apt-get command or synaptic
44package manager.
45
46[Note]
47This package requires many other packages to compile
48targetsoftware. So it consume more disk space than usual.
49Also installation takes logner time because of compilation.
50(This will take a few minutes to quarter or half of an hour,
51depends on building environment)
52
53[About self-build package]
54For some kind of software, distributing of binary package
55may viorate the patent or law. Therefore we chose self-build
56packge, create binary package on your machine, for such kind
57of softwares instead of distributing binary package.
58
59Please obey the national law when you use the created binary
60packages. And if you want to use the softwares using patented
61thechnology, it may be required to get a permission, make an
62agreement or purchas a license. Please consider it with your
63purpose or way of use and take appropriate action.
64
65%description -l ja
66x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
67コードするためのフリーなライブラリです.
68
69このパッケージをインストールすると、自動的にソースコードを
70ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
71パッケージを作成します。
72また apt-get コマンドや synaptic パッケージマネージャから実行
73した場合は、作成された rpm パッケージのインストールも自動的に
74行います。
75
76[注意]
77コンパイルに必要な多くの関連パッケージを要求するので通常より
78ディスクの領域を多く消費します。
79またインストール時にコンパイルを行うため、通常より時間がかか
80る場合があります。(環境にもよりますが数分から数十分程度)
81
82[self-build パッケージについて]
83ソフトウェアによってはバイナリパッケージの配布が特許や法律に
84違反する可能性があるものがあります。その為、このような問題が
85懸念されるソフトウェアについてはバイナリパッケージを直接配布
86せずに、ユーザの環境でバイナリを作成する self-build パッケー
87ジという方法を採っています。
88
89作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
90アのライセンス、および利用する国の各種法令に従ってください。
91また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
92センスの購入などが必要となる場合がありますので、利用する目的
93や形態に応じて各自で判断し適切な対応を取ってください。
94
95%prep
96[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
97
98
99%install
100%{__rm} -rf ${RPM_BUILD_ROOT}
101%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104%{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105%{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
106
107%clean
108%{__rm} -rf ${RPM_BUILD_ROOT}
109
110%posttrans
111/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 10000
112/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
113                                 %{pkgname}-devel-%{version}-%{release}
114
115%files
116%defattr(-,root,root)
117%{_datadir}/%{name}
118
119%changelog
120* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
121- renamed %%{Source0} to x264-vl.spec
122
123* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
124- updated source snapshot 20100216
125- applied to link x264 binary to the shared library from RPM Fusion development
126
127* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
128- changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
129- check version between original spec and self-build spec in %%prep
130
131* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
132- dropped BuildArch: noarch
133
134* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
135- 20090522 snapshot
136  - updated x264-vine.patch
137- added BuildArch: noarch
138- avoided to execute self-build-rpm.sh on RPM transaction
139  - moved %%post actions to %%posttrans
140
141* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
142- corrected release number in x264.spec
143
144* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
145- enable asm on x86/x86_64 arch. (fix typo?)
146
147* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
148- added PreReq: self-build-gpac
149
150* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
151- dropped PreReq: nasm for x86
152- added PreReq: yasm for x86
153
154* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
155- 20090110 snapshot
156
157* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
158- fixed License: GPLv2+
159- added BuildRequires: gettext
160- source updated
161- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
162  and added x264-vine.patch
163#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
164
165* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
166- spec in utf8
167
168* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
169- run pre-allocate-rpm.sh in %%post
170- set PreReq: self-build-setup >= 0.8
171- apply new versioning policy
172
173* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
174- initial build for Vine Linux 4.2
175
176### end of file
Note: See TracBrowser for help on using the repository browser.