source: projects/specs/trunk/nonfree/self-build-x264/self-build-x264-vl.spec @ 5297

Revision 5297, 7.7 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%global snapshot_date   20111216
2%global snapshot_time   2245
3%global branch          stable
4
5%global pkgname         x264
6%global name            self-build-%{pkgname}
7%global version         0.0.0
8%global release         18.%{snapshot_date}%{?_dist_release}
9
10#define sourceurl0      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
11%define sourceurl0      http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
12
13Summary:        Package to automatically build %{pkgname} rpm package
14Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
15Name:           %{name}
16Version:        %{version}
17Release:        %{release}
18Source0:        %{pkgname}-vl.spec
19Source1:        %{pkgname}.desktop
20Source111:      %{pkgname}-shared.patch
21Source112:      %{pkgname}-nostrip.patch
22
23License:        GPLv2+
24Group:          Restricted Software
25
26Obsoletes:      x264 < %{version}-%{release}
27Obsoletes:      self-build-x264 < %{version}-%{release}
28
29Requires(post):         self-build-setup >= 0.9.9
30
31# (build)requies of target package.
32Requires(post): yasm
33Requires(post): self-build-gpac
34
35BuildArch:      noarch
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37
38Packager:       munepi
39
40%description
41x264 is a free library for encoding H264/AVC video streams, written from
42scratch.
43
44If you install this package, it automaticaly downloads source
45code ,compile it, and create rpm packages of %{pkgname}-%{version}.
46And the created rpm packages are automatically installed
47if installation is executed by apt-get command or synaptic
48package manager.
49
50[Note]
51This package requires many other packages to compile
52targetsoftware. So it consume more disk space than usual.
53Also installation takes logner time because of compilation.
54(This will take a few minutes to quarter or half of an hour,
55depends on building environment)
56
57[About self-build package]
58For some kind of software, distributing of binary package
59may viorate the patent or law. Therefore we chose self-build
60packge, create binary package on your machine, for such kind
61of softwares instead of distributing binary package.
62
63Please obey the national law when you use the created binary
64packages. And if you want to use the softwares using patented
65thechnology, it may be required to get a permission, make an
66agreement or purchas a license. Please consider it with your
67purpose or way of use and take appropriate action.
68
69%description -l ja
70x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
71コードするためのフリーなライブラリです.
72
73このパッケージをインストールすると、自動的にソースコードを
74ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
75パッケージを作成します。
76また apt-get コマンドや synaptic パッケージマネージャから実行
77した場合は、作成された rpm パッケージのインストールも自動的に
78行います。
79
80[注意]
81コンパイルに必要な多くの関連パッケージを要求するので通常より
82ディスクの領域を多く消費します。
83またインストール時にコンパイルを行うため、通常より時間がかか
84る場合があります。(環境にもよりますが数分から数十分程度)
85
86[self-build パッケージについて]
87ソフトウェアによってはバイナリパッケージの配布が特許や法律に
88違反する可能性があるものがあります。その為、このような問題が
89懸念されるソフトウェアについてはバイナリパッケージを直接配布
90せずに、ユーザの環境でバイナリを作成する self-build パッケー
91ジという方法を採っています。
92
93作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
94アのライセンス、および利用する国の各種法令に従ってください。
95また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
96センスの購入などが必要となる場合がありますので、利用する目的
97や形態に応じて各自で判断し適切な対応を取ってください。
98
99%prep
100[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
106%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
107%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
108%{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
109%{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
110
111%clean
112%{__rm} -rf ${RPM_BUILD_ROOT}
113
114%posttrans
115/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 19000
116/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
117                                 %{pkgname}-devel-%{version}-%{release}
118
119%files
120%defattr(-,root,root)
121%{_datadir}/%{name}
122
123%changelog
124* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
125- updated source snapshot 20111216 stable branch (ABI 0.119)
126
127* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
128- updated source snapshot 20111013 stable branch (ABI 0.116)
129
130* Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
131- changed to depend on %%{version} for Obsoletes: x264
132- added BuildArch: noarch
133
134* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
135- updated source snapshot 20110322
136
137* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
138- updated source snapshot 20100625
139
140* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
141- renamed %%{Source0} to x264-vl.spec
142
143* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
144- updated source snapshot 20100216
145- applied to link x264 binary to the shared library from RPM Fusion development
146
147* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
148- changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
149- check version between original spec and self-build spec in %%prep
150
151* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
152- dropped BuildArch: noarch
153
154* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
155- 20090522 snapshot
156  - updated x264-vine.patch
157- added BuildArch: noarch
158- avoided to execute self-build-rpm.sh on RPM transaction
159  - moved %%post actions to %%posttrans
160
161* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
162- corrected release number in x264.spec
163
164* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
165- enable asm on x86/x86_64 arch. (fix typo?)
166
167* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
168- added PreReq: self-build-gpac
169
170* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
171- dropped PreReq: nasm for x86
172- added PreReq: yasm for x86
173
174* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
175- 20090110 snapshot
176
177* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
178- fixed License: GPLv2+
179- added BuildRequires: gettext
180- source updated
181- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
182  and added x264-vine.patch
183#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
184
185* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
186- spec in utf8
187
188* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
189- run pre-allocate-rpm.sh in %%post
190- set PreReq: self-build-setup >= 0.8
191- apply new versioning policy
192
193* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
194- initial build for Vine Linux 4.2
195
196### end of file
Note: See TracBrowser for help on using the repository browser.