source: projects/specs/trunk/nonfree/self-build-x264/self-build-x264-vl.spec @ 10524

Revision 10524, 8.6 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

RevLine 
[9973]1%global snapshot_date   20160122
[5297]2%global snapshot_time   2245
3%global branch          stable
[615]4
[5297]5%global pkgname         x264
6%global name            self-build-%{pkgname}
[9973]7%global version         0.148
[10524]8%global release         2.%{snapshot_date}%{?_dist_release}
[5297]9
[615]10#define sourceurl0      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
[9215]11%define sourceurl0      http://download.videolan.org/pub/x264/snapshots/%{pkgname}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
[615]12
13Summary:        Package to automatically build %{pkgname} rpm package
14Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
15Name:           %{name}
16Version:        %{version}
17Release:        %{release}
18Source0:        %{pkgname}-vl.spec
19
20License:        GPLv2+
21Group:          Restricted Software
22
[6241]23Obsoletes:      x264 < %{version}, x264-devel < %{version}
[9241]24Obsoletes:      self-build-x264 < %{version}
[1258]25
[615]26Requires(post):         self-build-setup >= 0.9.9
27
28# (build)requies of target package.
29Requires(post): yasm
[7842]30Requires(post): self-build-gpac >= 0.5.0
[615]31
[4695]32BuildArch:      noarch
[615]33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Packager:       munepi
36
37%description
38x264 is a free library for encoding H264/AVC video streams, written from
39scratch.
40
41If you install this package, it automaticaly downloads source
42code ,compile it, and create rpm packages of %{pkgname}-%{version}.
43And the created rpm packages are automatically installed
44if installation is executed by apt-get command or synaptic
45package manager.
46
47[Note]
48This package requires many other packages to compile
49targetsoftware. So it consume more disk space than usual.
50Also installation takes logner time because of compilation.
51(This will take a few minutes to quarter or half of an hour,
52depends on building environment)
53
54[About self-build package]
55For some kind of software, distributing of binary package
56may viorate the patent or law. Therefore we chose self-build
57packge, create binary package on your machine, for such kind
58of softwares instead of distributing binary package.
59
60Please obey the national law when you use the created binary
61packages. And if you want to use the softwares using patented
62thechnology, it may be required to get a permission, make an
63agreement or purchas a license. Please consider it with your
64purpose or way of use and take appropriate action.
65
66%description -l ja
67x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
68コードするためのフリーなライブラリです.
69
70このパッケージをインストールすると、自動的にソースコードを
71ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
72パッケージを作成します。
73また apt-get コマンドや synaptic パッケージマネージャから実行
74した場合は、作成された rpm パッケージのインストールも自動的に
75行います。
76
77[注意]
78コンパイルに必要な多くの関連パッケージを要求するので通常より
79ディスクの領域を多く消費します。
80またインストール時にコンパイルを行うため、通常より時間がかか
81る場合があります。(環境にもよりますが数分から数十分程度)
82
83[self-build パッケージについて]
84ソフトウェアによってはバイナリパッケージの配布が特許や法律に
85違反する可能性があるものがあります。その為、このような問題が
86懸念されるソフトウェアについてはバイナリパッケージを直接配布
87せずに、ユーザの環境でバイナリを作成する self-build パッケー
88ジという方法を採っています。
89
90作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
91アのライセンス、および利用する国の各種法令に従ってください。
92また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
93センスの購入などが必要となる場合がありますので、利用する目的
94や形態に応じて各自で判断し適切な対応を取ってください。
95
96%prep
97[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
98
99
100%install
101%{__rm} -rf ${RPM_BUILD_ROOT}
102%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104
105%clean
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108%posttrans
[9973]109/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 23000
[615]110/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
111                                 %{pkgname}-devel-%{version}-%{release}
112
113%files
114%defattr(-,root,root)
115%{_datadir}/%{name}
116
117%changelog
[10524]118* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.148-2.20160122
119- rebuild with libcdio-0.93
120
[9973]121* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.148-1.20160122
122- updated source snapshot 20160122 stable branch (ABI 0.148)
123
[9663]124* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-5.20141218
125- rebuilt
126
[9423]127* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-4.20141218
128- rebuild
129
[9366]130* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-3.20141218
131- rebuild
132
[9241]133* Sun Jan 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-2.20141218
134- Obsoletes: self-build-x264 < %{version}
135
[9215]136* Fri Dec 26 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-1.20141218
137- updated source snapshot 20141218 stable branch (ABI 0.142)
138
[7842]139* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.136-1.20130927
140- updated source snapshot 20130927 stable branch (ABI 0.136)
141
142* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.129-1.20130118
143- updated source snapshot 20130118 stable branch (ABI 0.129)
144
[6241]145* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.124-1.20120525
146- updated source snapshot 20120525 stable branch (ABI 0.124)
147- changed release number; upstream have release numbers at least on stable branch
148
[5297]149* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
150- updated source snapshot 20111216 stable branch (ABI 0.119)
151
152* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
153- updated source snapshot 20111013 stable branch (ABI 0.116)
154
[4695]155* Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
156- changed to depend on %%{version} for Obsoletes: x264
157- added BuildArch: noarch
158
[3126]159* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
160- updated source snapshot 20110322
161
[1258]162* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
163- updated source snapshot 20100625
164
[615]165* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
166- renamed %%{Source0} to x264-vl.spec
167
168* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
169- updated source snapshot 20100216
170- applied to link x264 binary to the shared library from RPM Fusion development
171
172* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
173- changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
174- check version between original spec and self-build spec in %%prep
175
176* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
177- dropped BuildArch: noarch
178
179* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
180- 20090522 snapshot
181  - updated x264-vine.patch
182- added BuildArch: noarch
183- avoided to execute self-build-rpm.sh on RPM transaction
184  - moved %%post actions to %%posttrans
185
186* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
187- corrected release number in x264.spec
188
189* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
190- enable asm on x86/x86_64 arch. (fix typo?)
191
192* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
193- added PreReq: self-build-gpac
194
195* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
196- dropped PreReq: nasm for x86
197- added PreReq: yasm for x86
198
199* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
200- 20090110 snapshot
201
202* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
203- fixed License: GPLv2+
204- added BuildRequires: gettext
205- source updated
206- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
207  and added x264-vine.patch
208#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
209
210* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
211- spec in utf8
212
213* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
214- run pre-allocate-rpm.sh in %%post
215- set PreReq: self-build-setup >= 0.8
216- apply new versioning policy
217
218* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
219- initial build for Vine Linux 4.2
220
221### end of file
Note: See TracBrowser for help on using the repository browser.