source: projects/specs/trunk/nonfree/self-build-swftools/self-build-swftools-vl.spec @ 3289

Revision 3289, 4.4 KB checked in by munepi, 13 years ago (diff)

added zziplib, self-build-swftools

Line 
1#% define with_pdflib_lite 1
2
3%define pkgname swftools
4%define name    self-build-%{pkgname}
5%define version 0.9.1
6%define release 1%{?_dist_release}
7
8%define sourceurl0      http://www.swftools.org/%{pkgname}-%{version}.tar.gz
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source100:      swftools-0.9.1-prefix.patch
17
18# swftools is GPLv2+ licensed, lib/MD5.c is BSD licensed,
19# lib/action/actioncompiler.c is LGPLv2+ licensed
20License:        GPLv2+ and LGPLv2+ and BSD
21Group:          Restricted Software
22
23Requires(post):         self-build-setup >= 0.9.9
24
25Requires(post):  fftw-devel
26Requires(post):  fontconfig-devel
27Requires(post):  giflib-devel
28Requires(post):  libjpeg-devel
29Requires(post):  self-build-lame
30#Requires(post):  python-imaging-devel
31Requires(post):  python-devel
32Requires(post):  python-imaging
33Requires(post):  zziplib-devel
34%{?with_pdflib_lite:Requires(post):  pdflib-lite-devel}
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37BuildArch:      noarch
38
39Packager:       munepi
40
41%description
42SWFTools is a collection of utilities for working with Adobe Flash files (SWF
43files). The tool collection includes programs for reading SWF files, combining
44them, and creating them from other content (like images, sound files, videos or
45source code).
46
47
48[Note]
49This package requires many other packages to compile
50targetsoftware. So it consume more disk space than usual.
51Also installation takes logner time because of compilation.
52(This will take a few minutes to quarter or half of an hour,
53depends on building environment)
54
55[About self-build package]
56For some kind of software, distributing of binary package
57may viorate the patent or law. Therefore we chose self-build
58packge, create binary package on your machine, for such kind
59of softwares instead of distributing binary package.
60
61Please obey the national law when you use the created binary
62packages. And if you want to use the softwares using patented
63thechnology, it may be required to get a permission, make an
64agreement or purchas a license. Please consider it with your
65purpose or way of use and take appropriate action.
66
67%description -l ja
68SWFTools は Adobe Flash ファイル(SWF)を操作するためのユーティリティ集です。
69ユーティリティ集には、SWF ファイルを読んだり、SWF ファイルを結合したり、
70画像や音声、動画、ソースコードのような他のコンテンツからSWF ファイルを
71作成するプログラムが含まれています。
72
73
74[注意]
75コンパイルに必要な多くの関連パッケージを要求するので通常より
76ディスクの領域を多く消費します。
77またインストール時にコンパイルを行うため、通常より時間がかか
78る場合があります。(環境にもよりますが数分から数十分程度)
79
80[self-build パッケージについて]
81ソフトウェアによってはバイナリパッケージの配布が特許や法律に
82違反する可能性があるものがあります。その為、このような問題が
83懸念されるソフトウェアについてはバイナリパッケージを直接配布
84せずに、ユーザの環境でバイナリを作成する self-build パッケー
85ジという方法を採っています。
86
87作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
88アのライセンス、および利用する国の各種法令に従ってください。
89また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
90センスの購入などが必要となる場合がありますので、利用する目的
91や形態に応じて各自で判断し適切な対応を取ってください。
92
93%prep
94[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%posttrans
107/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 108000
108
109
110%files
111%defattr(-,root,root)
112%{_datadir}/%{name}/*
113
114%changelog
115* Fri Apr 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.9.1-1
116- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.