source: projects/specs/trunk/nonfree/self-build-pragha/self-build-pragha-vl.spec @ 4693

Revision 4693, 5.4 KB checked in by munepi, 13 years ago (diff)

updated {self-build-,}pragha-vl.spec

Line 
1%define pkgname pragha
2%define name    self-build-%{pkgname}
3%define version 0.8.9
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://dissonance.googlecode.com/files/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv3+
16Group:          Restricted Software
17
18# Requires(posttrans) not yet implemented. So we use (post) instead.
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):  alsa-lib-devel >= 1.0.15
23Requires(post):  dbus-glib-devel >= 0.74
24Requires(post):  gtk2-devel >= 2.16.0
25Requires(post):  flac-devel >= 1.2.1
26%if %{?_dist_release} != "vl5"
27Requires(post):  keybinder-devel >= 0.2.0
28%endif
29Requires(post):  libao-devel >= 0.8.8
30Requires(post):  libcddb-devel >= 1.2.1
31Requires(post):  libcdio-devel >= 0.78
32Requires(post):  curl-devel >= 7.18
33##Requires(post):  libmad-devel >= 0.15
34Requires(post):  libmodplug-devel
35Requires(post):  libnotify-devel >= 0.4.4
36Requires(post):  libsndfile-devel >= 1.0.17
37Requires(post):  libvorbis-devel >= 1.2.0
38Requires(post):  sqlite3-devel >= 3.4
39Requires(post):  taglib-devel >= 1.4
40Requires(post):  desktop-file-utils
41Requires(post):  gettext
42
43Requires(post):         self-build-libmad >= 0.15
44
45BuildArch:      noarch
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48Packager:       munepi
49
50%description
51Pragha is a lightweight GTK+ music manager that aims to be fast, bloat-free,
52and light on memory consumption. It is written completely in C and GTK+.
53
54Pragha is a fork of Consonance Music Manager, discontinued by the original
55author.
56
57
58If you install this package, it automaticaly downloads source
59code ,compile it, and create rpm packages of %{pkgname}-%{version}.
60And the created rpm packages are automatically installed
61if installation is executed by apt-get command or synaptic
62package manager.
63
64[Note]
65This package requires many other packages to compile
66targetsoftware. So it consume more disk space than usual.
67Also installation takes logner time because of compilation.
68(This will take a few minutes to quarter or half of an hour,
69depends on building environment)
70
71[About self-build package]
72For some kind of software, distributing of binary package
73may viorate the patent or law. Therefore we chose self-build
74packge, create binary package on your machine, for such kind
75of softwares instead of distributing binary package.
76
77Please obey the national law when you use the created binary
78packages. And if you want to use the softwares using patented
79thechnology, it may be required to get a permission, make an
80agreement or purchas a license. Please consider it with your
81purpose or way of use and take appropriate action.
82
83%description -l ja
84Pragha は軽量 GTK+ 楽曲管理アプリケーションです。
85
86このパッケージをインストールすると、自動的にソースコードを
87ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
88パッケージを作成します。
89また apt-get コマンドや synaptic パッケージマネージャから実行
90した場合は、作成された rpm パッケージのインストールも自動的に
91行います。
92
93[注意]
94コンパイルに必要な多くの関連パッケージを要求するので通常より
95ディスクの領域を多く消費します。
96またインストール時にコンパイルを行うため、通常より時間がかか
97る場合があります。(環境にもよりますが数分から数十分程度)
98
99[self-build パッケージについて]
100ソフトウェアによってはバイナリパッケージの配布が特許や法律に
101違反する可能性があるものがあります。その為、このような問題が
102懸念されるソフトウェアについてはバイナリパッケージを直接配布
103せずに、ユーザの環境でバイナリを作成する self-build パッケー
104ジという方法を採っています。
105
106作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
107アのライセンス、および利用する国の各種法令に従ってください。
108また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
109センスの購入などが必要となる場合がありますので、利用する目的
110や形態に応じて各自で判断し適切な対応を取ってください。
111
112%prep
113[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
114
115%install
116%{__rm} -rf ${RPM_BUILD_ROOT}
117%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119
120%clean
121%{__rm} -rf ${RPM_BUILD_ROOT}
122
123%posttrans
124/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 66000
125/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
126
127%files
128%defattr(-,root,root)
129%{_datadir}/%{name}
130
131%changelog
132* Tue Aug 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.9-1
133- new upstream release
134- added Requires(post):  keybinder-devel >= 0.2.0
135
136* Sun Feb 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.5-2
137- fixed %%posttrans
138
139* Sat Feb 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.5-1
140- new upstream release
141
142* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.2-1
143- initial bulid
Note: See TracBrowser for help on using the repository browser.