source: projects/specs/trunk/nonfree/self-build-pragha/self-build-pragha-vl.spec @ 2779

Revision 2779, 5.1 KB checked in by munepi, 13 years ago (diff)

updated self-build-pragha: new upstream release

Line 
1%define pkgname pragha
2%define name    self-build-%{pkgname}
3%define version 0.8.5
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://dissonance.googlecode.com/files/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv3+
16Group:          Restricted Software
17
18# Requires(posttrans) not yet implemented. So we use (post) instead.
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):  alsa-lib-devel >= 1.0.15
23Requires(post):  dbus-glib-devel >= 0.74
24Requires(post):  gtk2-devel >= 2.16.0
25Requires(post):  flac-devel >= 1.2.1
26Requires(post):  libao-devel >= 0.8.8
27Requires(post):  libcddb-devel >= 1.2.1
28Requires(post):  libcdio-devel >= 0.78
29Requires(post):  curl-devel >= 7.18
30##Requires(post):  libmad-devel >= 0.15
31Requires(post):  libmodplug-devel
32Requires(post):  libnotify-devel >= 0.4.4
33Requires(post):  libsndfile-devel >= 1.0.17
34Requires(post):  libvorbis-devel >= 1.2.0
35Requires(post):  sqlite3-devel >= 3.4
36Requires(post):  taglib-devel >= 1.4
37Requires(post):  desktop-file-utils
38Requires(post):  gettext
39
40Requires(post):         self-build-libmad >= 0.15
41
42BuildArch:      noarch
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44
45Packager:       munepi
46
47%description
48Pragha is a lightweight GTK+ music manager that aims to be fast, bloat-free,
49and light on memory consumption. It is written completely in C and GTK+.
50
51Pragha is a fork of Consonance Music Manager, discontinued by the original
52author.
53
54
55If you install this package, it automaticaly downloads source
56code ,compile it, and create rpm packages of %{pkgname}-%{version}.
57And the created rpm packages are automatically installed
58if installation is executed by apt-get command or synaptic
59package manager.
60
61[Note]
62This package requires many other packages to compile
63targetsoftware. So it consume more disk space than usual.
64Also installation takes logner time because of compilation.
65(This will take a few minutes to quarter or half of an hour,
66depends on building environment)
67
68[About self-build package]
69For some kind of software, distributing of binary package
70may viorate the patent or law. Therefore we chose self-build
71packge, create binary package on your machine, for such kind
72of softwares instead of distributing binary package.
73
74Please obey the national law when you use the created binary
75packages. And if you want to use the softwares using patented
76thechnology, it may be required to get a permission, make an
77agreement or purchas a license. Please consider it with your
78purpose or way of use and take appropriate action.
79
80%description -l ja
81Pragha は軽量 GTK+ 楽曲管理アプリケーションです。
82
83このパッケージをインストールすると、自動的にソースコードを
84ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
85パッケージを作成します。
86また apt-get コマンドや synaptic パッケージマネージャから実行
87した場合は、作成された rpm パッケージのインストールも自動的に
88行います。
89
90[注意]
91コンパイルに必要な多くの関連パッケージを要求するので通常より
92ディスクの領域を多く消費します。
93またインストール時にコンパイルを行うため、通常より時間がかか
94る場合があります。(環境にもよりますが数分から数十分程度)
95
96[self-build パッケージについて]
97ソフトウェアによってはバイナリパッケージの配布が特許や法律に
98違反する可能性があるものがあります。その為、このような問題が
99懸念されるソフトウェアについてはバイナリパッケージを直接配布
100せずに、ユーザの環境でバイナリを作成する self-build パッケー
101ジという方法を採っています。
102
103作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
104アのライセンス、および利用する国の各種法令に従ってください。
105また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
106センスの購入などが必要となる場合がありますので、利用する目的
107や形態に応じて各自で判断し適切な対応を取ってください。
108
109%prep
110[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
111
112%install
113%{__rm} -rf ${RPM_BUILD_ROOT}
114%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
115%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
116
117%clean
118%{__rm} -rf ${RPM_BUILD_ROOT}
119
120%posttrans
121/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 66000
122/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
123                                 %{pkgname}-devel-%{version}-%{release}
124
125%files
126%defattr(-,root,root)
127%{_datadir}/%{name}
128
129%changelog
130* Sat Feb 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.5-1
131- new upstream release
132
133* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.2-1
134- initial bulid
Note: See TracBrowser for help on using the repository browser.