source: projects/specs/trunk/nonfree/self-build-pragha/pragha-vl.spec @ 2160

Revision 2160, 4.5 KB checked in by munepi, 14 years ago (diff)

NEW: self-build-pragha and libmodplug

Line 
1Name:           pragha
2Version:        0.8.2
3Release:        1%{?_dist_release}
4Summary:        Lightweight GTK+ music manager
5Summary(ja):    軽量 GTK+ 楽曲管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv3+
9URL:            http://pragha.wikispaces.com/
10Source0:        http://dissonance.googlecode.com/files/%{name}-%{version}.tar.bz2
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires:  alsa-lib-devel >= 1.0.15
14BuildRequires:  dbus-glib-devel >= 0.74
15BuildRequires:  gtk2-devel >= 2.16.0
16BuildRequires:  flac-devel >= 1.2.1
17BuildRequires:  libao-devel >= 0.8.8
18BuildRequires:  libcddb-devel >= 1.2.1
19BuildRequires:  libcdio-devel >= 0.78
20BuildRequires:  curl-devel >= 7.18
21#BuildRequires:  libmad-devel >= 0.15
22BuildRequires:  libmodplug-devel
23BuildRequires:  libnotify-devel >= 0.4.4
24BuildRequires:  libsndfile-devel >= 1.0.17
25BuildRequires:  libvorbis-devel >= 1.2.0
26BuildRequires:  sqlite3-devel >= 3.4
27BuildRequires:  taglib-devel >= 1.4
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30
31%description
32Pragha is a lightweight GTK+ music manager that aims to be fast, bloat-free,
33and light on memory consumption. It is written completely in C and GTK+.
34
35Pragha is a fork of Consonance Music Manager, discontinued by the original
36author.
37
38
39%prep
40%setup -q
41# Fix spurious executable permissions
42%__chmod 0644 ChangeLog src/*.{c,h}
43
44%build
45%configure --disable-static
46%__make %{?_smp_mflags} V=1
47
48
49%install
50%__rm -rf $RPM_BUILD_ROOT
51%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
52desktop-file-install \
53    --delete-original \
54    --add-category=Audio \
55    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
56    ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
57%find_lang %{name}
58# remove duplicate docs
59%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/%{name}/doc
60
61%clean
62%__rm -rf $RPM_BUILD_ROOT
63
64
65%post
66touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
67update-desktop-database &> /dev/null || :
68
69
70%postun
71if [ $1 -eq 0 ] ; then
72    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
73    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
74fi
75update-desktop-database &> /dev/null || :
76
77
78%posttrans
79gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
80
81
82%files -f %{name}.lang
83%defattr(-,root,root,-)
84# FIXME add AUTHORS and README if not empty
85%doc ChangeLog COPYING FAQ NEWS
86%{_bindir}/pragha
87%{_datadir}/applications/%{name}.desktop
88%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
89%{_datadir}/pixmaps/%{name}/
90%{_datadir}/%{name}/
91%{_mandir}/man1/pragha.1.*
92
93
94%changelog
95* Fri Oct 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.2-1
96- new upstream release
97
98* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.1-1
99- new upstream release
100
101* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.0.2-1
102- initial build
103
104* Sat Aug 21 2010 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.8.0.2-3
105- rebuilt
106
107* Mon Aug 02 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.2-2
108- Fix desktop file
109
110* Fri Jul 30 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.2-1
111- Update to 0.8.0.2
112- Drop de.po patch, included upstream
113
114* Fri Jul 30 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.1-1
115- Update to 0.8.0.1
116- Add COPYING and NEWS to docs
117
118* Thu Jul 29 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-1
119- Update to 0.8.0
120
121* Fri Jun 25 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.7.1-1
122- Update to 0.7.7.1
123
124* Fri Jun 25 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.7-1
125- Update to 0.7.7
126
127* Sat Jun 19 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.6-1
128- Update to 0.7.6
129- Remove upstreamed use-software-mixer.patch
130
131* Fri Apr 22 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.4-1
132- Update to 0.7.4
133
134* Mon Mar 22 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.3-2
135- Use software mixer by default to cope with pulseaudio
136- Remove executable bits from docs
137
138* Tue Mar 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.3-1
139- Update to 0.7.3
140
141* Sat Feb 20 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.2-1
142- Update to 0.7.2
143
144* Wed Oct 28 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.1-1
145- Upadte to 0.7.1
146
147* Sat Oct 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.0-1
148- Upadte to 0.7.0
149
150* Sun Aug 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.3-1
151- Upadte to 0.6.3
152
153* Mon Jul 20 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.2.2-1
154- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.