source: projects/specs/trunk/nonfree/self-build-nautilus-dropbox/self-build-nautilus-dropbox-vl.spec @ 8907

Revision 8907, 4.6 KB checked in by munepi, 10 years ago (diff)

new upstream release

Line 
1%define pkgname nautilus-dropbox
2%define name    self-build-%{pkgname}
3%define version 1.6.2
4%define release 1%{?_dist_release}
5
6%define sourceurl https://www.dropbox.com/download?dl=packages/nautilus-dropbox-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14License:        GPLv2 and non-free
15Group:          Restricted Software
16
17# requires: downloading from https
18Requires(post): self-build-setup >= 0.9.9
19
20Requires(post): nautilus-devel >= 2.16.0
21Requires(post): glib2-devel >= 2.14.0
22Requires(post): libnotify-devel >= 0.4.4
23Requires(post): pygtk2
24Requires(post): python-docutils
25
26BuildArch:      noarch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Packager:       iwaim, shaolin, daisuke
30
31%description
32Dropbox extension for Nautilus.
33Dropbox is online backup, file sync and sharing made easy web seavice.
34See https://www.dropbox.com/
35
36If you install this package, it automaticaly downloads source
37code ,compile it, and create rpm packages of %{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42[About self-build package]
43For some kind of software, distributing of binary package
44may viorate the patent or law. Therefore we chose self-build
45packge, create binary package on your machine, for such kind
46of softwares instead of distributing binary package.
47
48Please obey the national law when you use the created binary
49packages. And if you want to use the softwares using patented
50thechnology, it may be required to get a permission, make an
51agreement or purchas a license. Please consider it with your
52purpose or way of use and take appropriate action.
53
54%description -l ja
55Nautilus のための Dropbox 拡張。
56Dropbox はオンラインバックアップやファイルの同期と共有を簡単に
57実現するウェブサービスです。
58詳細は https://www.dropbox.com/ を見てください。
59
60このパッケージをインストールすると、自動的にソースコードを
61ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
62パッケージを作成します。
63また apt-get コマンドや synaptic パッケージマネージャから実行
64した場合は、作成された rpm パッケージのインストールも自動的に
65行います。
66
67[注意]
68コンパイルに必要な多くの関連パッケージを要求するので通常より
69ディスクの領域を多く消費します。
70またインストール時にコンパイルを行うため、通常より時間がかか
71る場合があります。(環境にもよりますが数分から数十分程度)
72
73[self-build パッケージについて]
74ソフトウェアによってはバイナリパッケージの配布が特許や法律に
75違反する可能性があるものがあります。その為、このような問題が
76懸念されるソフトウェアについてはバイナリパッケージを直接配布
77せずに、ユーザの環境でバイナリを作成する self-build パッケー
78ジという方法を採っています。
79
80作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
81アのライセンス、および利用する国の各種法令に従ってください。
82また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
83センスの購入などが必要となる場合がありますので、利用する目的
84や形態に応じて各自で判断し適切な対応を取ってください。
85
86
87%install
88%{__rm} -rf ${RPM_BUILD_ROOT}
89%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
90%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
91
92%clean
93%{__rm} -rf ${RPM_BUILD_ROOT}
94
95%posttrans
96/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl}" 65000
97/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
98                                 %{pkgname}-images-nonfree-%{version}-%{release}
99
100%files
101%defattr(-,root,root)
102%{_datadir}/self-build-%{pkgname}
103
104%changelog
105* Mon Aug 18 2014 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.2-1
106- new upstream release
107
108* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
109- new upstream release
110
111* Thu Jul  7 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.6.8-1
112- new upstream release
113
114* Tue Nov 16 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.6.7-1
115- new upstream release
116
117* Sat Mar 13 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.1-1
118- initial release for Vine Linux
Note: See TracBrowser for help on using the repository browser.