source: projects/specs/trunk/nonfree/self-build-mplayer/self-build-mplayer-vl.spec @ 12251

Revision 12251, 17.6 KB checked in by ara_t, 4 years ago (diff)

self-build-mplayer: change BuildRequires?

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5# define with_ffmpeg 1
6%global ffmpegver 2.8.5
7
8%global pkgname mplayer
9%global name    self-build-%{pkgname}
10%global version 1.2
11#% global svndate  20120525
12%global release 3%{?svndate:.%svndate}%{?_dist_release}
13
14%global source0path     MPlayer/releases/MPlayer-%{version}.tar.xz
15%global source1url      http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23Source10:       mplayer-snapshot-vine.sh
24
25Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
26Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.8.tar.bz2
27Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.11.tar.bz2
28Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
29
30Source102:        %{pkgname}-1.1.1-config-vine.patch
31Source108:        %{pkgname}-1.1.1-manlinks.patch
32# Source114:        %{pkgname}-1.1.1-nodvdcss.patch
33Source118:        %{pkgname}-1.1.1-ffmpeg.patch
34
35License:        GPLv2+
36Group:          Restricted Software
37
38Obsoletes:      mplayer < %{version}-%{release}
39Obsoletes:      self-build-mplayer < %{version}-%{release}
40
41Requires(post):         self-build-setup >= 0.9.9
42%{?svndate:Requires(post):              subversion}
43
44# (build)requies of target package.
45Requires(post): SDL-devel
46Requires(post):  aalib-devel
47Requires(post): alsa-lib-devel
48Requires(post): cdparanoia-devel
49Requires(post):  desktop-file-utils
50Requires(post): libdvdnav-devel
51Requires(post):  enca-devel
52Requires(post): freetype2-devel >= 2.0.9
53Requires(post):  fribidi-devel
54Requires(post):  fontconfig-devel
55Requires(post): giflib-devel
56Requires(post): gtk2-devel
57Requires(post): mesa-libGL-devel
58Requires(post):  libXinerama-devel
59Requires(post):  libXScrnSaver-devel
60Requires(post):  libXv-devel
61Requires(post):  libXvMC-devel
62Requires(post):  libXxf86dga-devel
63Requires(post):  libXxf86vm-devel
64Requires(post):  libass-devel
65Requires(post): libpng-devel
66Requires(post): libjpeg-devel
67Requires(post): libdvdread
68Requires(post):  libmpcdec-devel >= 1.2.1
69Requires(post):  librtmp-devel >= 2.3
70Requires(post):  speex-devel >= 1.1
71%{?with_vaapi:Requires(post):libva-devel}
72Requires(post):  libvdpau-devel
73Requires(post): libvorbis-devel
74%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
75Requires(post):  lzo-devel >= 2
76Requires(post):  pulseaudio-lib-devel
77Requires(post):  speex-devel >= 1.1
78Requires(post):  twolame-devel
79Requires(post): xorg-x11-devel
80Requires(post):  yasm
81Requires(post): zlib-devel
82
83Requires(post):         lame
84Requires(post):   libmpeg2
85Requires(post):         self-build-mplayer-codecs
86##!!Requires(post):             self-build-libdvdcss
87Requires(post):         self-build-faac
88Requires(post):         self-build-faad2 >= 2.6.1
89# Requires(post):               self-build-lame
90Requires(post):         self-build-libdca
91Requires(post):         self-build-libmad
92Requires(post): self-build-x264 >= 0.136
93Requires(post):         self-build-xvidcore >= 0.9.2
94# Requires(post):               self-build-libmpeg2
95Requires:       TrueType-vlgothic
96Requires:       mesa-libGL
97
98BuildArch:      noarch
99BuildRoot:      %{_tmppath}/%{name}-%{version}-root
100
101Packager:       munepi
102
103%description
104MPlayer can play most standard video formats out of the box and almost
105all others with the help of external codecs.
106MPlayer currently works best from the command line, but visual feedback
107for many functions is available from its onscreen status display (OSD),
108which is also used for displaying subtitles.
109MPlayer also has a GUI with skin support and several unofficial alternative
110graphical frontends are available.
111
112MEncoder is a command line video encoder for advanced users that can
113be built from the MPlayer source tree. Unofficial graphical frontends
114exist but arenot included.
115
116MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
117support for some newer codecs are not yet inpmlemented.
118You should install mplayer-codecs package if you want to play videos
119using those new codecs.
120
121
122Additional function is automatically included if following
123packages are installed in advance.
124
125samba-libsmbclient-devel: SMB file system support
126
127
128[Note]
129This package requires many other packages to compile
130targetsoftware. So it consume more disk space than usual.
131Also installation takes logner time because of compilation.
132(This will take a few minutes to quarter or half of an hour,
133depends on building environment)
134
135[About self-build package]
136For some kind of software, distributing of binary package
137may viorate the patent or law. Therefore we chose self-build
138packge, create binary package on your machine, for such kind
139of softwares instead of distributing binary package.
140
141Please obey the national law when you use the created binary
142packages. And if you want to use the softwares using patented
143thechnology, it may be required to get a permission, make an
144agreement or purchas a license. Please consider it with your
145purpose or way of use and take appropriate action.
146
147%description -l ja
148MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
149またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
150で再生できます。
151現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
152は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
153面上で確認できます。
154MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
155非公式なフロントエンドも利用できます。
156
157MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
158非公式な GUI フロントエンドもありますが、このパッケージには含まれて
159いません。
160
161MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
162を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
163いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
164をインストールする必要があります。
165
166
167このパッケージより前に以下の関連パッケージをインストールして
168おくと、%{pkgname} が対応できる機能が自動的に追加されます。
169
170samba-libsmbclient-devel: SMB ファイルシステムのサポート
171
172
173[注意]
174コンパイルに必要な多くの関連パッケージを要求するので通常より
175ディスクの領域を多く消費します。
176またインストール時にコンパイルを行うため、通常より時間がかか
177る場合があります。(環境にもよりますが数分から数十分程度)
178
179[self-build パッケージについて]
180ソフトウェアによってはバイナリパッケージの配布が特許や法律に
181違反する可能性があるものがあります。その為、このような問題が
182懸念されるソフトウェアについてはバイナリパッケージを直接配布
183せずに、ユーザの環境でバイナリを作成する self-build パッケー
184ジという方法を採っています。
185
186作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
187アのライセンス、および利用する国の各種法令に従ってください。
188また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
189センスの購入などが必要となる場合がありますので、利用する目的
190や形態に応じて各自で判断し適切な対応を取ってください。
191
192
193%prep
194[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
195
196%install
197%{__rm} -rf ${RPM_BUILD_ROOT}
198%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
199%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
200%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
201%{__install} -m 644 \
202    %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} \
203    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
204%{__install} -m 644 \
205    %{SOURCE102} %{SOURCE108} %{SOURCE118} \
206    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
207
208
209%clean
210%{__rm} -rf ${RPM_BUILD_ROOT}
211
212%posttrans
213## official tarball
214/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
215    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
216    %{source1url} \
217    1429000
218exit 0
219
220## svn checkout
221# set locale
222case ${LANG} in
223    ja*)LOCALE=ja ;;
224    *) LOCALE=C ;;
225esac
226
227GetSrc_C(){
228    echo -n "     "
229    echo "Download source file with Subversion..."
230}
231
232GetSrc_ja(){
233    echo -n "     "
234    echo "Subversion を用いてソースファイルをダウンロードしています..."
235}
236
237GetSrc_${LOCALE}
238
239# svn checkout
240. /etc/self-build.conf
241(cd ${TEMP_DIR}
242su ${BUILD_USER} -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
243%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
244)
245
246/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
247    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 2261000
248   
249
250%files
251%defattr(-,root,root)
252%{_datadir}/%{name}
253
254%changelog
255* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 1.2-3
256- change BR: self-build-{lame,libmpeg2} to {lame,a52dec}-devel
257
258* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
259- rebuild with libcdio-0.93
260
261* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
262- new upstream release
263
264* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-4
265- rebuilt
266
267* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
268- rebuilt with ffmpeg-0.11.5
269
270* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
271- remove some obsolete comments (mplayer-vl.spec)
272
273* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
274- updated to 1.1.1
275- build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
276
277* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
278- rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
279
280* Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
281- updated to 1.1
282  - built with ffmpeg-0.11.1
283- added some skins
284
285* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
286- updated snapshot 20120525 with ffmpeg 0.11
287- dropped Requires(post): self-build-libdvdcss
288
289* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
290- updated snapshot 20111217 (with ffmpeg 0.9)
291
292* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
293- s/self-build-libdvdnav/libdvdnav/
294
295* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
296- updated %%source1path
297  - update to 1.8
298
299* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
300- dropped Requires(post): esound-devel
301
302* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
303- new upstream release
304  - ready for Vine Linux 6
305  - revived support for Vine Linux 5
306- added Requires(post):
307  - libass-devel
308  - librtmp-devel >= 2.3
309  - speex-devel >= 1.1
310
311* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
312- added BuildRequires:
313  - aalib-devel
314  - enca-devel
315  - lzo-devel
316  - speex-devel
317
318* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
319- updated fixed %{name}-config.patch
320  - applied %{name}-config-20100709-vine.patch
321
322* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
323- unpacked source archives
324
325* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
326- updated source snapshot 20100709
327- renamed %%Source10 to mplayer-snapshot-vine.sh
328- added Requires(post): libva-devel, libvpx-devel >= 0.9.1
329- dropped vl4 support
330- updated %%description
331
332* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
333- updated source snapshot 20100621
334- added Requires(post): libXinerama-devel
335- dropped vl4 support
336
337* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
338- updated source snapshot 20100401
339
340* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
341- updated source snapshot 20100317
342- renamed %%{Source0} to mplayer-vl.spec
343
344* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
345- updated source snapshot 20100216
346- dropped obsolete patches
347- added Requires(post): libvdpau-devel libXScrnSaver-devel
348
349* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
350- update mplayer-config-20091215-vine.patch
351- update mplayer-20091215-x86_32-compile.patch
352
353* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
354- source snapshot 20091031
355  - updated mplayer-20091031-x86_32-compile.patch
356
357* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
358- source snapshot 20091003
359
360* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
361- added some if conditions for "vl6"
362
363* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
364- source snapshot 20090905
365- added settings for vl6
366
367* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
368- source snapshot 20090821
369- replaced BR: libungif-devel with BR: giflib-devel
370- mentioned VDPAU support in %%description
371
372* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
373- source snapshot 20090722
374
375* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
376- source snapshot 20090702
377- check version between original spec and self-build spec in %%prep
378
379* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
380- source snapshot 20090611
381
382* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
383- added Requires: TrueType-vlgothic
384
385* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
386- source snapshot 20090522
387  - build with x264 >= 0.0.0-9.20090522
388  - updated mplayer-20090502-nodvdcss.patch
389- avoided to execute self-build-rpm.sh on RPM transaction
390  - moved %%post actions to %%posttrans
391
392* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
393- added PreReq: self-build-mplayer-codecs
394
395* Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
396- added BuildArch: noarch
397- source snapshot 20090502
398- updated mplayer-20090503-x86_32-compile.patch
399- updated mplayer-20090502-nodvdcss.patch
400
401* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
402- included source archives:
403  - mplayer-export-20090327.tar.bz2
404  - Blue-1.7.tar.bz2
405- applied mplayer-config-vine.patch
406
407* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
408- source snapshot 20090327
409- updated mplayer-20090327-x86_32-compile.patch
410- updated mplayer-20090325-nodvdcss.patch
411- dropped gmplayer-about-vine.patch
412
413* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
414- source snapshot 20090206
415- dropped mplayer-man-zh_CN.patch
416- updated mplayer-20090206-nodvdcss.patch
417- changed to PreReq:  self-build-faad2 from faad2-devel
418- added PreReq:  self-build-libmad
419
420* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
421- source snapshot 20090131
422- fixed %%files section
423
424* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
425- fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
426
427* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
428- source snapshot
429- update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
430- added PreReq:
431  - faad2-devel
432  - libmpcdec-devel
433  - twolame-devel
434  - yasm
435  - self-build-libdvdcss
436  - self-build-libdvdnav
437  - self-build-faac
438  - self-build-lame
439  - self-build-libdca
440  - self-build-x264 >= 0.0.0-4.20090110
441  - self-build-xvidcore >= 0.9.2
442- move %%define source0Exists() from %%post section to header
443- fixed %%post section: clean up source archive
444
445* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
446- source snapshot
447- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
448  --disable-faad-internal in configure options
449- dropped gmplayer-add-flv-extension.patch
450
451* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
452- source snapshot
453- fixed License
454- added some patches from RPM Fusion
455- updated gmplayer-about-vine.patch for 20081001 snapshot
456- added BuildRequires:  libdvdread
457- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
458- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
459  in configure options
460#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
461- added PreReq: subversion
462
463* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
464- fixed License
465- added some devel packages to support OpenGL
466
467* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
468- spec in utf8
469- fix sybolic link of subfont for vl5
470
471* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
472- add "Source105: CVE-2008-1558.patch".
473
474* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
475- build with new versioning policy.
476- add "Source200: gmplayer-about-vine.patch".
477- add "Source201: gmplayer-add-flv-extension.patch".
478- fix <BTS:VineLinux:603>.
479  - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
480  - add mirror URLs to self-build-rpm.sh.
481
482* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
483- add four official security patches (CVE-2008-0485, CVE-2008-0486,
484  CVE-2008-0629, CVE-2008-0630)
485- add mplayer-1.0rc2-20080211-stream_cddb.patch
486
487* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
488- change source download URL. <BTS:VineLinux:603>
489
490* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
491- fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
492
493* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
494- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.