source: projects/specs/trunk/nonfree/self-build-mplayer/self-build-mplayer-vl.spec @ 10524

Revision 10524, 17.4 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5# define with_ffmpeg 1
6%global ffmpegver 2.8.5
7
8%global pkgname mplayer
9%global name    self-build-%{pkgname}
10%global version 1.2
11#% global svndate  20120525
12%global release 2%{?svndate:.%svndate}%{?_dist_release}
13
14%global source0path     MPlayer/releases/MPlayer-%{version}.tar.xz
15%global source1url      http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23Source10:       mplayer-snapshot-vine.sh
24
25Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
26Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.8.tar.bz2
27Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.11.tar.bz2
28Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
29
30Source102:        %{pkgname}-1.1.1-config-vine.patch
31Source108:        %{pkgname}-1.1.1-manlinks.patch
32# Source114:        %{pkgname}-1.1.1-nodvdcss.patch
33Source118:        %{pkgname}-1.1.1-ffmpeg.patch
34
35License:        GPLv2+
36Group:          Restricted Software
37
38Obsoletes:      mplayer < %{version}-%{release}
39Obsoletes:      self-build-mplayer < %{version}-%{release}
40
41Requires(post):         self-build-setup >= 0.9.9
42%{?svndate:Requires(post):              subversion}
43
44# (build)requies of target package.
45Requires(post): SDL-devel
46Requires(post):  aalib-devel
47Requires(post): alsa-lib-devel
48Requires(post): cdparanoia-devel
49Requires(post):  desktop-file-utils
50Requires(post): libdvdnav-devel
51Requires(post):  enca-devel
52Requires(post): freetype2-devel >= 2.0.9
53Requires(post):  fribidi-devel
54Requires(post):  fontconfig-devel
55Requires(post): giflib-devel
56Requires(post): gtk2-devel
57Requires(post): mesa-libGL-devel
58Requires(post):  libXinerama-devel
59Requires(post):  libXScrnSaver-devel
60Requires(post):  libXv-devel
61Requires(post):  libXvMC-devel
62Requires(post):  libXxf86dga-devel
63Requires(post):  libXxf86vm-devel
64Requires(post):  libass-devel
65Requires(post): libpng-devel
66Requires(post): libjpeg-devel
67Requires(post): libdvdread
68Requires(post):  libmpcdec-devel >= 1.2.1
69Requires(post):  librtmp-devel >= 2.3
70Requires(post):  speex-devel >= 1.1
71%{?with_vaapi:Requires(post):libva-devel}
72Requires(post):  libvdpau-devel
73Requires(post): libvorbis-devel
74%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
75Requires(post):  lzo-devel >= 2
76Requires(post):  pulseaudio-lib-devel
77Requires(post):  speex-devel >= 1.1
78Requires(post):  twolame-devel
79Requires(post): xorg-x11-devel
80Requires(post):  yasm
81Requires(post): zlib-devel
82
83Requires(post):         self-build-mplayer-codecs
84##!!Requires(post):             self-build-libdvdcss
85Requires(post):         self-build-faac
86Requires(post):         self-build-faad2 >= 2.6.1
87Requires(post):         self-build-lame
88Requires(post):         self-build-libdca
89Requires(post):         self-build-libmad
90Requires(post): self-build-x264 >= 0.136
91Requires(post):         self-build-xvidcore >= 0.9.2
92Requires(post):         self-build-libmpeg2
93Requires:       TrueType-vlgothic
94Requires:       mesa-libGL
95
96BuildArch:      noarch
97BuildRoot:      %{_tmppath}/%{name}-%{version}-root
98
99Packager:       munepi
100
101%description
102MPlayer can play most standard video formats out of the box and almost
103all others with the help of external codecs.
104MPlayer currently works best from the command line, but visual feedback
105for many functions is available from its onscreen status display (OSD),
106which is also used for displaying subtitles.
107MPlayer also has a GUI with skin support and several unofficial alternative
108graphical frontends are available.
109
110MEncoder is a command line video encoder for advanced users that can
111be built from the MPlayer source tree. Unofficial graphical frontends
112exist but arenot included.
113
114MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
115support for some newer codecs are not yet inpmlemented.
116You should install mplayer-codecs package if you want to play videos
117using those new codecs.
118
119
120Additional function is automatically included if following
121packages are installed in advance.
122
123samba-libsmbclient-devel: SMB file system support
124
125
126[Note]
127This package requires many other packages to compile
128targetsoftware. So it consume more disk space than usual.
129Also installation takes logner time because of compilation.
130(This will take a few minutes to quarter or half of an hour,
131depends on building environment)
132
133[About self-build package]
134For some kind of software, distributing of binary package
135may viorate the patent or law. Therefore we chose self-build
136packge, create binary package on your machine, for such kind
137of softwares instead of distributing binary package.
138
139Please obey the national law when you use the created binary
140packages. And if you want to use the softwares using patented
141thechnology, it may be required to get a permission, make an
142agreement or purchas a license. Please consider it with your
143purpose or way of use and take appropriate action.
144
145%description -l ja
146MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
147またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
148で再生できます。
149現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
150は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
151面上で確認できます。
152MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
153非公式なフロントエンドも利用できます。
154
155MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
156非公式な GUI フロントエンドもありますが、このパッケージには含まれて
157いません。
158
159MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
160を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
161いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
162をインストールする必要があります。
163
164
165このパッケージより前に以下の関連パッケージをインストールして
166おくと、%{pkgname} が対応できる機能が自動的に追加されます。
167
168samba-libsmbclient-devel: SMB ファイルシステムのサポート
169
170
171[注意]
172コンパイルに必要な多くの関連パッケージを要求するので通常より
173ディスクの領域を多く消費します。
174またインストール時にコンパイルを行うため、通常より時間がかか
175る場合があります。(環境にもよりますが数分から数十分程度)
176
177[self-build パッケージについて]
178ソフトウェアによってはバイナリパッケージの配布が特許や法律に
179違反する可能性があるものがあります。その為、このような問題が
180懸念されるソフトウェアについてはバイナリパッケージを直接配布
181せずに、ユーザの環境でバイナリを作成する self-build パッケー
182ジという方法を採っています。
183
184作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
185アのライセンス、および利用する国の各種法令に従ってください。
186また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
187センスの購入などが必要となる場合がありますので、利用する目的
188や形態に応じて各自で判断し適切な対応を取ってください。
189
190
191%prep
192[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
193
194%install
195%{__rm} -rf ${RPM_BUILD_ROOT}
196%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
197%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
198%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
199%{__install} -m 644 \
200    %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} \
201    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
202%{__install} -m 644 \
203    %{SOURCE102} %{SOURCE108} %{SOURCE118} \
204    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
205
206
207%clean
208%{__rm} -rf ${RPM_BUILD_ROOT}
209
210%posttrans
211## official tarball
212/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
213    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
214    %{source1url} \
215    1429000
216exit 0
217
218## svn checkout
219# set locale
220case ${LANG} in
221    ja*)LOCALE=ja ;;
222    *) LOCALE=C ;;
223esac
224
225GetSrc_C(){
226    echo -n "     "
227    echo "Download source file with Subversion..."
228}
229
230GetSrc_ja(){
231    echo -n "     "
232    echo "Subversion を用いてソースファイルをダウンロードしています..."
233}
234
235GetSrc_${LOCALE}
236
237# svn checkout
238. /etc/self-build.conf
239(cd ${TEMP_DIR}
240su ${BUILD_USER} -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
241%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
242)
243
244/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
245    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 2261000
246   
247
248%files
249%defattr(-,root,root)
250%{_datadir}/%{name}
251
252%changelog
253* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
254- rebuild with libcdio-0.93
255
256* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
257- new upstream release
258
259* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-4
260- rebuilt
261
262* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
263- rebuilt with ffmpeg-0.11.5
264
265* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
266- remove some obsolete comments (mplayer-vl.spec)
267
268* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
269- updated to 1.1.1
270- build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
271
272* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
273- rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
274
275* Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
276- updated to 1.1
277  - built with ffmpeg-0.11.1
278- added some skins
279
280* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
281- updated snapshot 20120525 with ffmpeg 0.11
282- dropped Requires(post): self-build-libdvdcss
283
284* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
285- updated snapshot 20111217 (with ffmpeg 0.9)
286
287* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
288- s/self-build-libdvdnav/libdvdnav/
289
290* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
291- updated %%source1path
292  - update to 1.8
293
294* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
295- dropped Requires(post): esound-devel
296
297* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
298- new upstream release
299  - ready for Vine Linux 6
300  - revived support for Vine Linux 5
301- added Requires(post):
302  - libass-devel
303  - librtmp-devel >= 2.3
304  - speex-devel >= 1.1
305
306* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
307- added BuildRequires:
308  - aalib-devel
309  - enca-devel
310  - lzo-devel
311  - speex-devel
312
313* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
314- updated fixed %{name}-config.patch
315  - applied %{name}-config-20100709-vine.patch
316
317* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
318- unpacked source archives
319
320* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
321- updated source snapshot 20100709
322- renamed %%Source10 to mplayer-snapshot-vine.sh
323- added Requires(post): libva-devel, libvpx-devel >= 0.9.1
324- dropped vl4 support
325- updated %%description
326
327* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
328- updated source snapshot 20100621
329- added Requires(post): libXinerama-devel
330- dropped vl4 support
331
332* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
333- updated source snapshot 20100401
334
335* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
336- updated source snapshot 20100317
337- renamed %%{Source0} to mplayer-vl.spec
338
339* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
340- updated source snapshot 20100216
341- dropped obsolete patches
342- added Requires(post): libvdpau-devel libXScrnSaver-devel
343
344* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
345- update mplayer-config-20091215-vine.patch
346- update mplayer-20091215-x86_32-compile.patch
347
348* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
349- source snapshot 20091031
350  - updated mplayer-20091031-x86_32-compile.patch
351
352* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
353- source snapshot 20091003
354
355* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
356- added some if conditions for "vl6"
357
358* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
359- source snapshot 20090905
360- added settings for vl6
361
362* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
363- source snapshot 20090821
364- replaced BR: libungif-devel with BR: giflib-devel
365- mentioned VDPAU support in %%description
366
367* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
368- source snapshot 20090722
369
370* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
371- source snapshot 20090702
372- check version between original spec and self-build spec in %%prep
373
374* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
375- source snapshot 20090611
376
377* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
378- added Requires: TrueType-vlgothic
379
380* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
381- source snapshot 20090522
382  - build with x264 >= 0.0.0-9.20090522
383  - updated mplayer-20090502-nodvdcss.patch
384- avoided to execute self-build-rpm.sh on RPM transaction
385  - moved %%post actions to %%posttrans
386
387* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
388- added PreReq: self-build-mplayer-codecs
389
390* Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
391- added BuildArch: noarch
392- source snapshot 20090502
393- updated mplayer-20090503-x86_32-compile.patch
394- updated mplayer-20090502-nodvdcss.patch
395
396* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
397- included source archives:
398  - mplayer-export-20090327.tar.bz2
399  - Blue-1.7.tar.bz2
400- applied mplayer-config-vine.patch
401
402* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
403- source snapshot 20090327
404- updated mplayer-20090327-x86_32-compile.patch
405- updated mplayer-20090325-nodvdcss.patch
406- dropped gmplayer-about-vine.patch
407
408* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
409- source snapshot 20090206
410- dropped mplayer-man-zh_CN.patch
411- updated mplayer-20090206-nodvdcss.patch
412- changed to PreReq:  self-build-faad2 from faad2-devel
413- added PreReq:  self-build-libmad
414
415* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
416- source snapshot 20090131
417- fixed %%files section
418
419* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
420- fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
421
422* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
423- source snapshot
424- update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
425- added PreReq:
426  - faad2-devel
427  - libmpcdec-devel
428  - twolame-devel
429  - yasm
430  - self-build-libdvdcss
431  - self-build-libdvdnav
432  - self-build-faac
433  - self-build-lame
434  - self-build-libdca
435  - self-build-x264 >= 0.0.0-4.20090110
436  - self-build-xvidcore >= 0.9.2
437- move %%define source0Exists() from %%post section to header
438- fixed %%post section: clean up source archive
439
440* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
441- source snapshot
442- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
443  --disable-faad-internal in configure options
444- dropped gmplayer-add-flv-extension.patch
445
446* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
447- source snapshot
448- fixed License
449- added some patches from RPM Fusion
450- updated gmplayer-about-vine.patch for 20081001 snapshot
451- added BuildRequires:  libdvdread
452- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
453- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
454  in configure options
455#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
456- added PreReq: subversion
457
458* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
459- fixed License
460- added some devel packages to support OpenGL
461
462* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
463- spec in utf8
464- fix sybolic link of subfont for vl5
465
466* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
467- add "Source105: CVE-2008-1558.patch".
468
469* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
470- build with new versioning policy.
471- add "Source200: gmplayer-about-vine.patch".
472- add "Source201: gmplayer-add-flv-extension.patch".
473- fix <BTS:VineLinux:603>.
474  - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
475  - add mirror URLs to self-build-rpm.sh.
476
477* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
478- add four official security patches (CVE-2008-0485, CVE-2008-0486,
479  CVE-2008-0629, CVE-2008-0630)
480- add mplayer-1.0rc2-20080211-stream_cddb.patch
481
482* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
483- change source download URL. <BTS:VineLinux:603>
484
485* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
486- fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
487
488* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
489- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.